View Issue Details

IDProjectCategoryView StatusLast Update
0015682ScribusGeneralpublic2021-02-11 00:46
Reporterjunqiding Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10
Product Version1.5.4 
Target VersionFixed in Version1.5.7.svn 
Summary0015682: Scribus crashes when checking fonts on startup
DescriptionScribus always crashes with exception during checking fonts: after loading Brushsci.tff. This happens with 1.5.4 (both 32bit and 64bit) not with 1.4.8. Do not know how to pass that step.
Additional InformationTried to remove and re-install many times but still not be able to pass that step. Saw a discussion before which the person removed Dell backup and recovery to solve the issue. I do not have that program and try to disable some 32bit processes but no luck.
Tagsfonts
PatchNo

Activities

junqiding

2019-05-13 02:01

reporter  

scribus 1.5.4 crash.PNG (80,526 bytes)
scribus 1.5.4 crash.PNG (80,526 bytes)
checkfonts150.xml (57,061 bytes)
prefs150.xml (7,614 bytes)
scribus150.rc (70,753 bytes)

ale

2019-05-13 11:30

manager   ~0046207

the things you have tried to get your scribus look like "crazy" to me (i mean the dell recovery program thing or disabling processes) and i would not suggest anybody to do the same.

what you can try is to remove or disable the Brushsci font in your windows and see if then you can launch scribus.
if you then can launch scribus and you consider Bruschsci a good quality font that should work with scribus, you are welcome to upload it here and let other people test if they face the same issue.

good luck!

junqiding

2019-05-13 11:42

reporter   ~0046209

Hi Ale, that was the first thing I tried (to remove the fonts). If I remove the brushsci.tff, it will stop in the previous one. If I remove one more, it stop in the even one earlier.

ale

2019-05-13 12:10

manager   ~0046210

so, the problem is probably not with the fonts : - )

indeed, looking at your screenshot, it says that it could load the font.

you could try to remove the scribus preferences... on windows they should be located in

<username>\AppData\Roaming\Scribus

and then start scribus.

junqiding

2019-05-13 12:57

reporter   ~0046211

Thanks. All tried (remove individual pref file). Still the same error.

jghali

2019-05-13 16:29

administrator   ~0046213

>> If I remove the brushsci.tff, it will stop in the previous one. If I remove one more, it stop in the even one earlier.

Brushsci is the last font which was loaded correctly. So you should not try to remove that font but find which font is loaded afterwards in order to find the font which triggers the issue.

Luna Nightshade

2019-05-13 16:30

reporter   ~0046214

Which one would be the next font checked (are they checked in alphabetical order by file name?)

jghali

2019-05-13 16:45

administrator   ~0046215

Yeah, for a same directory, they are checked in alphabetical order of file name.

junqiding

2019-05-13 16:53

reporter   ~0046216

The next one is BSSYM7.ttf. I also tried to remove it from font. Still got the same error. Interestingly it is only in version 1.5.x that Scribus crashes. It works for 1.4.x even in the same computer. I also tried 1.5.5svn. It also crashes at the same spot. I read the discuss in this: https://bugs.scribus.net/view.php?id=13252. But I do not think my issue is the same. I also tried to modify the Windows properties as shown in https://www.thewindowsclub.com/exception-access-violation-windows. It also cannot fix the issue.

utnik

2019-05-13 16:56

updater   ~0046217

yes, they are checked in aphabetical order – according to 'checkfonts150.xml' the next one should be 'BSSYM7.TTF'.

jghali

2019-12-12 18:00

administrator   ~0047259

Closing this issue as it has not seen any activity since a long time and has still not allowed us to reproduce the crash or even determine a root cause for the crash.

junqiding

2021-01-02 21:44

reporter   ~0048606

I finally found which one caused the issue. But I do not know how to fix it. I reset my Windows computer and reinstall Scribus different versions. The issue I saw happened 1.5.3 to 1.5.6.1. Before I install one Chinese font, the software runs perfectly. This time, I install one Chinese font and test the software, the software works perfectly until I install one font. The problem is that I could not find the font I installed so I can remove the font. I have no idea how to fix the problem without reset the computer. Could you please take a look how to solve the problem? (this issue was not happened for early Scribus version.)

jghali

2021-01-02 22:39

administrator   ~0048608

You have to upload the font file elsewhere then, and paste the link here.

jghali

2021-01-02 22:43

administrator   ~0048609

>> The problem is that I could not find the font I installed so I can remove the font

On Windows 10: Parameters > Customization > Fonts, then click on font you want to uninstall, then click on uninstall button.

junqiding

2021-01-03 00:13

reporter   ~0048618

This is the font file.
https://drive.google.com/file/d/1CuEkkYgAeegnCqzlpfccIeMzMIIvw5-y/view?usp=sharing

utnik

2021-01-03 09:35

updater   ~0048620

a font check shows two mayor errors in the 'name' table.

junqiding

2021-01-04 04:13

reporter   ~0048622

Any solution? Is it possible to automatically reject the fonts when Scribus builds the font cache (adding the True/False statement after checking whether the font has error)? It is difficult for user to choose which fonts are OK for the new system. In my case, I even do not know how to uninstall the fonts which have errors.

jghali

2021-01-04 17:04

administrator   ~0048624

>> In my case, I even do not know how to uninstall the fonts which have errors.

I've written above how to do it. I'm writing it again: Startup Menu > Parameters > Customization > Fonts, then click on font you want to uninstall, then click on uninstall button.

jghali

2021-01-04 17:09

administrator   ~0048625

This kind of font will be rejected from now on. Do not install old ms fonts on new systems: if Microsoft do not provide them anymore on these systems, they have good reason to do so.

Alexandru

2021-02-08 18:15

reporter   ~0048814

Hello, I am encountering basically the same issue yet with different fonts, please help! I saw in the console it was crashing after loading some Chinese fonts starting with the letter C, I got rid of them and now it stops at Cormorant. The next font alphabetically is Courier New and I dont have any more Chinese fonts starting with the letter C. I tried deleting the user AppData, doesn’t help, and version 1.4.x is working fine. I don’t have the font that the original poster identified as being problematic, I have Microsoft fonts with similar names of the type msxyz but I cant remove them for they are protected system fonts, How can I identify what font may be causing this issue? I used a program to make this list of my fonts but it shows their font names not filenames.

Font List.odt (50,978 bytes)

junqiding

2021-02-08 23:31

reporter   ~0048816

Hi Alexandru, did you try the svn version? It works with that version after the team modified the program. I know it does not work from 1.5.3 to the newest release version. Download the svn version and try it.

Alexandru

2021-02-11 00:46

reporter   ~0048820

Yes it’s working now with the svn version, thank you!

Issue History

Date Modified Username Field Change
2019-05-13 02:01 junqiding New Issue
2019-05-13 02:01 junqiding File Added: scribus 1.5.4 crash.PNG
2019-05-13 02:01 junqiding File Added: checkfonts150.xml
2019-05-13 02:01 junqiding File Added: prefs150.xml
2019-05-13 02:01 junqiding File Added: scribus150.rc
2019-05-13 02:01 junqiding Tag Attached: fonts
2019-05-13 11:30 ale Note Added: 0046207
2019-05-13 11:42 junqiding Note Added: 0046209
2019-05-13 12:10 ale Note Added: 0046210
2019-05-13 12:57 junqiding Note Added: 0046211
2019-05-13 16:29 jghali Note Added: 0046213
2019-05-13 16:30 Luna Nightshade Note Added: 0046214
2019-05-13 16:45 jghali Note Added: 0046215
2019-05-13 16:53 junqiding Note Added: 0046216
2019-05-13 16:56 utnik Note Added: 0046217
2019-12-12 18:00 jghali Assigned To => jghali
2019-12-12 18:00 jghali Status new => resolved
2019-12-12 18:00 jghali Resolution open => unable to reproduce
2019-12-12 18:00 jghali Note Added: 0047259
2019-12-12 18:00 jghali Status resolved => closed
2021-01-02 21:44 junqiding Status closed => feedback
2021-01-02 21:44 junqiding Resolution unable to reproduce => reopened
2021-01-02 21:44 junqiding Note Added: 0048606
2021-01-02 22:05 junqiding Status feedback => assigned
2021-01-02 22:39 jghali Note Added: 0048608
2021-01-02 22:40 jghali Priority high => normal
2021-01-02 22:43 jghali Note Added: 0048609
2021-01-03 00:13 junqiding Note Added: 0048618
2021-01-03 09:35 utnik File Added: Bildschirmfoto2021-01-03.png
2021-01-03 09:35 utnik Note Added: 0048620
2021-01-04 04:13 junqiding Note Added: 0048622
2021-01-04 16:57 jghali Summary Scribus crashes with EXCEPTION_ACCESS_VIOLATION during start (check fonts) => Scribus crashes when checking fonts on startup
2021-01-04 17:04 jghali Note Added: 0048624
2021-01-04 17:09 jghali Status assigned => resolved
2021-01-04 17:09 jghali Resolution reopened => fixed
2021-01-04 17:09 jghali Fixed in Version => 1.5.7.svn
2021-01-04 17:09 jghali Note Added: 0048625
2021-02-08 18:15 Alexandru File Added: Font List.odt
2021-02-08 18:15 Alexandru Note Added: 0048814
2021-02-08 23:31 junqiding Note Added: 0048816
2021-02-11 00:46 Alexandru Note Added: 0048820