View Issue Details

IDProjectCategoryView StatusLast Update
0016006ScribusGeneralpublic2019-12-15 16:36
Reporterreetp Assigned Tocbradney  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.5.5 
Target VersionFixed in Version 
Summary0016006: libpoppler crashes Inkscape
DescriptionNot sure where best to report this but we recently upgraded desktops to Xubuntu Bionic.

We use both the Inkscape and Scribus PPAs

We experienced instant crashes in Inkscape when trying to import PDFs and EPS files.

After a lot of hunting about we found these bugs:

https://gitlab.com/inkscape/inbox/issues/1215
https://gitlab.com/inkscape/inkscape/issues/255

Its seems this is due to an issue with the version of poppler that you supply in your PPA.

Scribus PPA: 0.74.0-0ubuntu1.2~ppa1
Downgrade to: 0.74.0-0ubuntu1.2~ppa0

We removed the Scribus PPA, downgraded Scribus and poppler, and Inkscape worked perfectly thereafter.
TagsNo tags attached.
PatchNo

Activities

ale

2019-12-12 17:26

manager   ~0047256

the problem is known and the person in charge is notified and is thinking about a solution:

http://lists.scribus.net/pipermail/scribus/2019-December/055874.html

in this specific case, the best place for the report would have been the debian bug tracker, but i don't think that further actions are now necessary.

reetp

2019-12-12 18:02

reporter   ~0047260

Ah yes - thanks.

jghali

2019-12-12 18:02

administrator   ~0047261

Last edited: 2019-12-12 18:03

View 2 revisions

>> Its seems this is due to an issue with the version of poppler that you supply in your PPA

The Scribus PPA is not managed by Scribus team, so the debian or ubuntu bug tracker would have indeed been a better place to report this issue.

cbradney

2019-12-15 16:36

administrator   ~0047272

Resolving per previous comments

Issue History

Date Modified Username Field Change
2019-12-12 14:56 reetp New Issue
2019-12-12 17:14 jghali Category - => General
2019-12-12 17:26 ale Note Added: 0047256
2019-12-12 18:02 reetp Note Added: 0047260
2019-12-12 18:02 jghali Note Added: 0047261
2019-12-12 18:03 jghali Note Edited: 0047261 View Revisions
2019-12-15 16:36 cbradney Assigned To => cbradney
2019-12-15 16:36 cbradney Status new => resolved
2019-12-15 16:36 cbradney Resolution open => fixed
2019-12-15 16:36 cbradney Note Added: 0047272