View Issue Details

IDProjectCategoryView StatusLast Update
0016541ScribusPrintingpublic2021-04-15 20:37
Reporterabhidesh128 Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinux (AppImage)OSMX LinuxOS Version19.4 Patito Feo
Product Version1.5.7.svn 
Fixed in Version1.5.7.svn 
Summary0016541: Minor issues regarding print seperations
DescriptionWhile working on a document for pre-press :-

1) In 'Setup Printer' dialogue, on the option tab, a document can be printed normally, or with color separation. When 'Print Separation' is selected, we can select which color is to be separated. There are four options - All, Cyan, Magenta, Yellow. But there is no Black option. So, black color cannot be separated individually.

2) In the above options of selecting colors, if 'All' is selected, Scribus prints a color separated postscript file, that has Black, Cyan and Magenta separations, but no Yellow separation.
Steps To ReproduceFirst issue :
1. Create a CMYK document by toggling color management on.
2. Include some colored images in it.
3. Click on the print option on the ribbon.
3. In the 'Setup Printer' dialogue, go to option tab. In the upper left list, select 'Print Seperations'.
4. The list for selecting color is enabled. There is no 'Black' option.

Second issue :
1. In the above list of color separations, select 'All' option.
2. Print the document to file by selecting the desired destination. A .ps file will be printed with separations.
3. There is no color separation for Yellow color in the printed file.
Tagsappimage, CMYK, color management, print problem
PatchNo

Activities

jghali

2021-04-08 17:56

administrator   ~0049087

1) Yep, indeed the black color was missing in separation combobox, this issue is now fixed
2) I did a test and could not reproduce. The order in which separations are outputted is : Black, Cyan, Magenta, Yellow, then spot colors.

abhidesh128

2021-04-09 02:25

reporter   ~0049088

To verify the second issue again, I created a test document and saved it as PDF/x-a, with printer mode, then I reopened it again to print the postscript separations. I found that when I print the all separations including spot color, it does skip the spot color itself..! If I delete the circle of spot color, and then print the separations, then it skips yellow...! I am sharing my test documents.
Document-1.pdf (781,670 bytes)

jghali

2021-04-09 17:39

administrator   ~0049089

After doing a test, I realized that both of your issues are in fact related. I was not able to reproduce your second issue because fixing the first one also fixed the second. So your second issue is in fact also fixed now.

Issue History

Date Modified Username Field Change
2021-04-08 06:57 abhidesh128 New Issue
2021-04-08 06:57 abhidesh128 Tag Attached: appimage
2021-04-08 06:57 abhidesh128 Tag Attached: CMYK
2021-04-08 06:57 abhidesh128 Tag Attached: color management
2021-04-08 06:57 abhidesh128 Tag Attached: print problem
2021-04-08 17:56 jghali Note Added: 0049087
2021-04-09 02:25 abhidesh128 Note Added: 0049088
2021-04-09 02:25 abhidesh128 File Added: Document-1.pdf
2021-04-09 02:25 abhidesh128 File Added: Document-1.pdf(converted)(No Test Spot Color).ps
2021-04-09 02:25 abhidesh128 File Added: Document-1.pdf(converted)(with Test Spot Color).ps
2021-04-09 17:39 jghali Note Added: 0049089
2021-04-09 17:39 jghali Assigned To => jghali
2021-04-09 17:39 jghali Status new => resolved
2021-04-09 17:39 jghali Resolution open => fixed
2021-04-09 17:39 jghali Fixed in Version => 1.5.7.svn
2021-04-15 20:37 cbradney Status resolved => closed