View Issue Details

IDProjectCategoryView StatusLast Update
0016830ScribusBuild Systempublic2022-08-16 20:36
Reportergoto_coder Assigned Tocbradney  
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Platform64bitOSUbuntuOS Version20.04
Fixed in Version1.5.9.svn 
Summary0016830: Typo in Findpoppler.cmake?
DescriptionIn the file cmake/modules/Findpoppler.cmake, there seems to be a typo regarding the variables intended to store information about paths to poppler-cpp directories.
Line 5 will set variables 'poppler_cpp_INCLUDE_DIRS' and 'poppler_cpp_LIBRARY_DIRS', with the 'cpp' part written in minor characters:
  5 pkg_search_module(poppler_cpp REQUIRED libpoppler-cpp>=21.03.0 poppler-cpp>=21.03.0)

However, later in the file the same (?) variables are referenced with the 'cpp' infix written in capital characters, e.g. line 17:
 15 find_path(poppler_cpp_INCLUDE_DIR
 16 NAMES poppler-version.h
 17 PATHS ${PKG_poppler_CPP_INCLUDE_DIRS} ${poppler_CPP_INCLUDE_DIRS} /usr/local/include /usr/include
 18 PATH_SUFFIXES poppler
 19 NO_DEFAULT_PATH
 20 )

When inserting cmake 'message()' statements at the end of the file, I noticed that the variables with the capital 'CPP' are indeed empty, while the minor versions aren't:
message(poppler_CPP_INCLUDE_DIR=${poppler_CPP_INCLUDE_DIR}) # empty
message(poppler_CPP_LIBRARY=${poppler_CPP_LIBRARY}) # empty
message(poppler_cpp_INCLUDE_DIR=${poppler_cpp_INCLUDE_DIR}) # prints a proper path
message(poppler_cpp_LIBRARY=${poppler_cpp_LIBRARY}) # prints a proper path

Since cmake variable names are case sensitive (https://cmake.org/cmake/help/latest/manual/cmake-language.7.html#variables), I figured this was a typo and should probably be fixed.
TagsCMake, poppler
PatchYes

Activities

goto_coder

2022-08-15 12:35

reporter   ~0049739

cmake_find_poppler_typo_0016830_2022-08-15_goto_coder.diff (962 bytes)   
Index: ScribusSVN/cmake/modules/Findpoppler.cmake
===================================================================
--- ScribusSVN/cmake/modules/Findpoppler.cmake	(revision 25126)
+++ ScribusSVN/cmake/modules/Findpoppler.cmake	(working copy)
@@ -14,7 +14,7 @@
 
 find_path(poppler_cpp_INCLUDE_DIR
 	NAMES poppler-version.h
-	PATHS ${PKG_poppler_CPP_INCLUDE_DIRS} ${poppler_CPP_INCLUDE_DIRS} /usr/local/include /usr/include
+	PATHS ${PKG_poppler_cpp_INCLUDE_DIRS} ${poppler_cpp_INCLUDE_DIRS} /usr/local/include /usr/include
 	PATH_SUFFIXES poppler
 	NO_DEFAULT_PATH
 	)
@@ -28,7 +28,7 @@
 
 find_library(poppler_cpp_LIBRARY
 	NAMES libpoppler-cpp poppler-cpp
-	PATHS ${PKG_poppler_CPP_LIBRARIES} ${poppler_CPP_LIBRARY_DIRS} /usr/local/lib /usr/lib /usr/lib/${CMAKE_LIBRARY_ARCHITECTURE}
+	PATHS ${PKG_poppler_cpp_LIBRARIES} ${poppler_cpp_LIBRARY_DIRS} /usr/local/lib /usr/lib /usr/lib/${CMAKE_LIBRARY_ARCHITECTURE}
 	PATH_SUFFIXES poppler
 	NO_DEFAULT_PATH
 	)

cbradney

2022-08-16 20:36

administrator   ~0049743

Fixed, thank you

Issue History

Date Modified Username Field Change
2022-08-15 12:34 goto_coder New Issue
2022-08-15 12:34 goto_coder Tag Attached: CMake
2022-08-15 12:34 goto_coder Tag Attached: poppler
2022-08-15 12:35 goto_coder Note Added: 0049739
2022-08-15 12:35 goto_coder File Added: cmake_find_poppler_typo_0016830_2022-08-15_goto_coder.diff
2022-08-16 20:36 cbradney Assigned To => cbradney
2022-08-16 20:36 cbradney Status new => resolved
2022-08-16 20:36 cbradney Resolution open => fixed
2022-08-16 20:36 cbradney Fixed in Version => 1.5.9.svn
2022-08-16 20:36 cbradney Note Added: 0049743