View Issue Details

IDProjectCategoryView StatusLast Update
0003407ScribusImport / Exportpublic2020-03-20 23:31
ReporterPeturrr Assigned ToTsoots  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionwon't fix 
PlatformLinux x86OSUbuntuOS Version6.04
Product Version1.3.3cvs 
Target VersionFixed in Version 
Summary0003407: New text import filter using start and end markers.
DescriptionI am creating a Songbook with Scribus. All the songs will be written in chordpro format, a standard for txt based song notation. The start of the chorus is marked with {soc} and the end of the chorus with {eoc}. A chorus can have multiple paragraphs so the import filter for "format paragraphs starting with [.]" isn't capable of formatting the file unless the chordpro standard isn't followed.

The easy solution for this is a new text import filter that goes something like this:

Apply 'paragraph style' 'chorus' to 'section starting with' '{soc} 'and ending with' '{eoc}
Steps To ReproduceChordpro formatted file:

[E]this is a [C#m]song
[B]And now we start [A]singing the chorus

{soc}
[E]Lalala[B/D#]lala
[C#]lalala[B]lala

[A]joy joy joy
[Bsus4]we are singing with [B]joy
{eoc}
Additional InformationIt probably can be used for lots and lots of other things. It makes work easier because you don't need to specify for every new paragraph you're typing the style.
TagsNo tags attached.
Patch

Relationships

child of 0003621 assignedTsoots [OBSOLETE] Metabug: COSS text importer update 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2006-03-14 09:02 Peturrr New Issue
2006-04-10 21:57 Tsoots Status new => assigned
2006-04-10 21:57 Tsoots Assigned To => Tsoots
2006-04-10 21:57 Tsoots Relationship added child of 0003621
2020-03-20 23:31 cbradney Status assigned => resolved
2020-03-20 23:31 cbradney Resolution open => won't fix