View Issue Details

IDProjectCategoryView StatusLast Update
0008551ScribusUsabilitypublic2014-07-07 17:53
Reporterhammeredklavier Assigned To 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionunable to reproduce 
PlatformOSWindows XPOS Version
Product Version1.3.6svn 
Target VersionFixed in Version 
Summary0008551: Deleting page range sometimes deletes all except page 1
DescriptionThis is a strange and nasty one! There are some conditions that I haven't quite isolated that cause Scribus to delete most of a document if I try to delete say four or five blank pages from the end of document. It seems to occur only when the final page is in the range deleted. So for example if I have a document that has 15 pages of which only 12 have content, and I delete pages 13-15, it deletes all except page 1! This is potentially lethal because sometimes it won't undo and if you inadvertently save...!
Steps To ReproduceCreate a 15 page document (for e.g.), put some stuff on say 11 of them and delete pages 13-15. It doesn't always do it for some reason but it's done it to me several times now... I'll see if I can isolate the conditions for you, meantime you might find some fundamental cause by examining the code.
TagsNo tags attached.
Patch

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2009-10-28 09:10 hammeredklavier New Issue
2014-07-07 17:53 FirasH Status new => closed
2014-07-07 17:53 FirasH Resolution open => unable to reproduce