View Issue Details

IDProjectCategoryView StatusLast Update
0008778ScribusImport / Exportpublic2010-02-07 00:52
Reportermontsamu Assigned Tochristoph_s  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.3.5 
Target VersionFixed in Version 
Summary0008778: importing pages from a scribus document: text frames are not linked properly
DescriptionWhen importing pages from a scribus document with linked text frames, the frames are imported with the correct names (e.g. "my_frame_1, my_frame_2" and so on) but text is only placed into the first text frame, with the red x in the lower right corner to indicate overflow -- the text frames are not linked as they were in the document being imported.

Re-linking is fairly trivial and no data is lost, but this should likely work.

(Potential issue: what if text frame names on the document being imported clash with a text frame name in the current document?)
Steps To Reproduce1. create "document-1.sla" with 2 pages, each with a text frame.
2. enter more text than will fit into the first page's text frame
3. link the first page's text frame to the second page's text frame
4. create "document-2.sla" and attempt to import all pages from document-1.sla
5. notice that the second page's text frame is empty and that the first page's text frame complains that it has too much text
TagsNo tags attached.
Patch

Relationships

duplicate of 0008056 assignedale [WIP PATCH] Import pages with linked text frames breaks the links 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2010-02-06 22:03 montsamu New Issue
2010-02-07 00:52 christoph_s Relationship added duplicate of 0008056
2010-02-07 00:52 christoph_s Duplicate ID 0 => 8056
2010-02-07 00:52 christoph_s Status new => resolved
2010-02-07 00:52 christoph_s Resolution open => duplicate
2010-02-07 00:52 christoph_s Assigned To => christoph_s
2010-02-07 00:52 christoph_s Status resolved => closed