View Issue Details

IDProjectCategoryView StatusLast Update
0009830ScribusStory Editor / Text Framespublic2016-02-10 17:04
Reporterzoffix Assigned To 
Status newResolutionopen 
PlatformUbuntu 10.10 MaverickOSUbuntuOS Version10.10 Maverick
Product Version1.4.0svn 
Summary0009830: Keyboard Shortcuts for Special Characters don't work
DescriptionI'm aware that shortcuts for styles don't work yet, but I'm pretty sure I had success using the shortcuts to insert double left quotation marks.

This functionally, it seems, is now gone. My previous shortcut (CTRL+SHIFT+") for double left no longer works.

I wanted to assign a shortcut for inserting the Bullet character, but the action has no effect; as is the case with changing the shortcut for non-breaking dash.
Steps To Reproduce1) Change shortcut for non-breaking dash to anything you want, or assign one for "Insert -> Bullet"
2) Try pressing said shortcut in story editor - the shortcut combination doesn't work.
Additional InformationI've tried changing the shortcut for Align and Distribute and worked fine, which is what makes me think I'm misremembering these shortcuts ever worked.


related to 0010289 new [patch] make shortcuts for styles working 
related to 0013506 new Some Shortcuts do not work 
related to 0005194 new Common User Access keyboard shortcuts not honored 



2011-03-10 21:50

administrator   ~0025786

Works for me... but it is control shift ' here, as " is the shifted character - it is *totally* keyboard layout dependent.


2011-03-11 01:47

reporter   ~0025791

Hm, just tried at home on Ubuntu 10.04. Even if I set the shortcut to F10, it doesn't work.

Tried to also change the shortcut for non-breaking dash from the default ctrl+alt+- to F10, in the preferences it shows the "F10", but in the Story Editor's menu it still shows the ctrl+alt+- shortcut, and it's that shortcut - not the F10 - that types the non-breaking dash.

Let me know if there's some way I could provide more info on this issue.


2011-03-12 10:40

administrator   ~0025799

Unable to reproduce this with Scribus 1.4.0.rc2 built in a 10.10 virtual machine. Setting F10 works here.


2011-03-12 18:15

reporter   ~0025801


What I just did is deleted my build and ~/.scribus and rebuilt everything fresh.

Setting F10 doesn't work, even though in the file ~/.scribus/scribus135.rc the shortcut is set to F10.

I even searched that file for occurrence of Ctrl+Alt+-, and it's not even there!

Is there some other file where Scribus looks for its shortcuts? I'm just flabbergasted with Ctrl+Alt+- inserting the non-breaking dash, even though that sequence is not set anywhere...


2011-10-04 05:34

reporter   ~0026957

I am using Scribus 1.4.0 rc5, Build ID: C-*-T-*-C1.8.6-Windows, the computer is running M$ XP and I get one of these problems.

My keyboard shortcut for "Double Left" is Ctrl+Shift+'
That shortcut works fine.
My keyboard shortcut for "Double Right" is Alt+Shift+"
This shortcut does NOT work correctly. I get a double straight quote instead of a double closing, typographic quote.

The display of the second shortcut is different from Scribus 1.3.3... which were Ctrl+Shift+' and Alt+Shift+'

This difference in 1.4 is consistent, at least the ;: and /? and .> keys show the unshifted character with Ctrl+Shift and the shifted one with Alt+Shift.

Issue History

Date Modified Username Field Change
2011-03-10 15:31 zoffix New Issue
2011-03-10 21:50 cbradney Note Added: 0025786
2011-03-11 01:47 zoffix Note Added: 0025791
2011-03-12 10:40 cbradney Note Added: 0025799
2011-03-12 18:15 zoffix Note Added: 0025801
2011-10-04 05:34 richardpaulhall Note Added: 0026957
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames
2015-10-27 16:40 Kunda Relationship added related to 0010289
2016-02-10 17:04 Kunda Tag Attached: shortcuts
2016-02-10 17:04 Kunda Relationship added related to 0013506
2016-02-10 17:04 Kunda Relationship added related to 0005194