Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001034ScribusStory Editor / Text Framespublic2004-09-05 15:242011-03-14 13:13
Reportercbradney 
Assigned Tocbradney 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformAthlon XP 2600+ 1gb ramOSGentoo LinuxOS VersionUp to date
Product Version1.2.5cvs 
Target VersionFixed in Version1.4.0svn 
Summary0001034: Edit Paste disabled after copy from another program, but Control V works
DescriptionWhen I copy from oo.o I can paste in with Control V, but the Edit Paste menu is still disabled unless I select the clipboard value with klipper.
TagsNo tags attached.
Patch
Attached Files

- Relationships
related to 0000898closed Scribus shows always Document-1 after deiconifying 
related to 0001274closedfschmid "paste" from the story editors edit-menu doesnt work when text from any kde app is in the clipboard 
related to 0002161acknowledged Re-examine copy/paste and drag & drop 

-  Notes
(0002377)
packetbell (reporter)
2004-09-14 20:49

Running Scribus on Fedora Core 2 (Gnome, Metacity), I cannot paste at all from Gnome/GTK apps (tried OpenOffice, Abiword, GEdit), either using the 'Paste' function from the edit menu or the CTRL-V shortcut.
Since Scribus is the only KDE app I use, I did some testing. I can paste from other Gnome/GTK apps into the KDE editor (Kate), and I can paste from Kate into Scribus (loses font attributes though).

Using Scribus 1.2 final.
(0004870)
plinnell (administrator)
2005-06-01 22:19

This also affects Copying within Scribus itself

Select All > Copy Menu is disabled in SE

1) New Doc > Auto Text Frames

2) Insert Sample Text

3) Open Story Editor

4 ) Select All

The Edit Copy Menu item is greyed out, but the right click context menu is enabled.
(0005380)
plinnell (administrator)
2005-07-03 23:13

bumping to 1.2.3
(0007818)
plinnell (administrator)
2005-12-26 21:09

Copy Edit > Paste to Text Frame from OO 2.0.1 works.

Copy Edit > Paste to SE from OO 2.0.1 disabled, but Ctrl-V works.
(0025803)
cbradney (administrator)
2011-03-13 00:03

Seems fixed, resolving.

- Issue History
Date Modified Username Field Change
2004-09-05 15:24 cbradney New Issue
2004-09-14 20:49 packetbell Note Added: 0002377
2004-12-12 20:32 cbradney Relationship added related to 0001274
2005-05-08 21:59 plinnell Relationship added related to 0000898
2005-05-15 12:59 plinnell Product Version 1.2 => 1.2.2cvs
2005-06-01 22:19 plinnell Note Added: 0004870
2005-06-30 08:17 ringerc Relationship added related to 0002161
2005-07-03 23:13 plinnell Note Added: 0005380
2005-07-03 23:30 plinnell Product Version 1.2.2cvs => 1.2.3
2005-07-06 21:38 plinnell Product Version 1.2.3 => 1.2.3cvs
2005-09-12 11:19 plinnell Product Version 1.2.3cvs => 1.2.4cvs
2005-12-26 21:09 plinnell Note Added: 0007818
2005-12-26 21:09 plinnell Product Version 1.2.4cvs => 1.2.5cvs
2011-03-13 00:03 cbradney Note Added: 0025803
2011-03-13 00:03 cbradney Status assigned => resolved
2011-03-13 00:03 cbradney Fixed in Version => 1.4.0svn
2011-03-13 00:03 cbradney Resolution open => fixed
2011-03-13 00:03 cbradney Assigned To fschmid => cbradney
2011-03-14 13:13 cbradney Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker