Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0010519ScribusGeneralpublic2012-01-15 21:442012-04-29 12:54
Reportercbradney 
Assigned Tofschmid 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0010519: Copy page functionality is broken
DescriptionWhen copying page 2 of a 4 page document 10x to the end, the first new page contains no items.
When copying page 3 of a 4 page document 10x to the end, the first 2 new pages contain no items and there is an item on the non existent page 15, ie off the end of the doc.
TagsNo tags attached.
Patch
Attached Files? file icon pagemovetest150.sla [^] (12,344 bytes) 2012-01-15 21:44
png file icon Screen Shot 2012-01-17 at 9.19.54 PM.png [^] (43,350 bytes) 2012-01-17 21:20


png file icon TenCopies.png [^] (17,372 bytes) 2012-01-17 23:38

- Relationships

-  Notes
(0027543)
cbradney (administrator)
2012-01-16 21:31

Franz, this would seem to be as a result of r16159, removal of serializer code.
(0027548)
fschmid (administrator)
2012-01-17 20:47

Tested it here, can't reproduce, works as is should.
(0027549)
cbradney (administrator)
2012-01-17 21:21

Uploaded screenshot of copying page 2 of the doc 10x to the end. you can see the 5th page has no item on it.
(0027550)
jghali (administrator)
2012-01-17 22:40

I can confirm the described behavior, copying page doesn't work either on Windows.
(0027551)
fschmid (administrator)
2012-01-17 23:34

Then either you or Craig should fix that bug, as i definitly can't confirm that behaviour here. I tried it with the attached doc as well with other own docs.
(0027552)
fschmid (administrator)
2012-01-17 23:39

Attached a screenshot how it looks on my side.
(0027553)
fschmid (administrator)
2012-01-18 00:28

Found the issue: the page to be copied must be the current page.

- Issue History
Date Modified Username Field Change
2012-01-15 21:44 cbradney New Issue
2012-01-15 21:44 cbradney File Added: pagemovetest150.sla
2012-01-16 20:25 cbradney Assigned To => cbradney
2012-01-16 20:25 cbradney Status new => confirmed
2012-01-16 21:30 cbradney Assigned To cbradney => fschmid
2012-01-16 21:30 cbradney Status confirmed => assigned
2012-01-16 21:31 cbradney Note Added: 0027543
2012-01-17 20:47 fschmid Note Added: 0027548
2012-01-17 20:47 fschmid Assigned To fschmid => cbradney
2012-01-17 21:20 cbradney File Added: Screen Shot 2012-01-17 at 9.19.54 PM.png
2012-01-17 21:21 cbradney Note Added: 0027549
2012-01-17 21:21 cbradney Assigned To cbradney => fschmid
2012-01-17 22:40 jghali Note Added: 0027550
2012-01-17 23:34 fschmid Note Added: 0027551
2012-01-17 23:38 fschmid File Added: TenCopies.png
2012-01-17 23:38 fschmid Assigned To fschmid => cbradney
2012-01-17 23:39 fschmid Note Added: 0027552
2012-01-18 00:27 fschmid Assigned To cbradney => fschmid
2012-01-18 00:28 fschmid Note Added: 0027553
2012-01-18 00:29 fschmid Status assigned => resolved
2012-01-18 00:29 fschmid Fixed in Version => 1.5.0svn
2012-01-18 00:29 fschmid Resolution open => fixed
2012-04-29 12:54 cbradney Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker