Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011254ScribusUndo/Redopublic2012-12-15 07:422012-12-17 06:25
Reporterchristoph_s 
Assigned Tofschmid 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSLinuxOS VersionOpenSUSE 12.1
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0011254: Vector import doesn't work after frame copy
DescriptionThis is a rather odd issue I encountered. See the description below.
Steps To Reproduce1) Create text frame and insert sample text.

2) Create image frame

3) Load image

4) Copy image frame

5) Double click on text frame and paste the image frame

6) Undo all steps listed above except 1).

7) Use File > Import > Get Vector File and select a vector file

--> progress dialog and changed mouse cursor appear as expected

8) Place the vector item on canvas

--> The previously removed image frame (via Undo) is inserted instead of the vector drawing
Additional InformationWorks without issue in 1.4.2.svn.
TagsNo tags attached.
Patch
Attached Files

- Relationships

-  Notes
(0029375)
fschmid (administrator)
2012-12-15 08:08

Seems to be a fault of the Undo System, as i have no knowledge of this i can't fix that bug.
(0029388)
jghali (administrator)
2012-12-15 14:35
edited on: 2012-12-15 14:46

The bug is in fact not related to undo and can be reproduced more simply :

1) Create image frame
2) Load image
3) Copy image frame
4) Use File > Import > Get Vector File and select a vector file
5) Place the vector item on canvas
--> The copied image frame is inserted instead of the vector drawing

(0029416)
christoph_s (administrator)
2012-12-17 06:25

Tested, fixed. Thanks.

- Issue History
Date Modified Username Field Change
2012-12-15 07:42 christoph_s New Issue
2012-12-15 07:42 christoph_s Status new => assigned
2012-12-15 07:42 christoph_s Assigned To => fschmid
2012-12-15 08:08 fschmid Note Added: 0029375
2012-12-15 08:08 fschmid Assigned To fschmid =>
2012-12-15 08:09 fschmid Status assigned => new
2012-12-15 14:35 jghali Note Added: 0029388
2012-12-15 14:35 jghali Summary Vector import doesn't work after undoing inline frame insertion => Vector import doesn't work after frame copy
2012-12-15 14:46 jghali Note Edited: 0029388 View Revisions
2012-12-16 19:55 fschmid Status new => resolved
2012-12-16 19:55 fschmid Fixed in Version => 1.5.0svn
2012-12-16 19:55 fschmid Resolution open => fixed
2012-12-16 19:55 fschmid Assigned To => fschmid
2012-12-17 06:25 christoph_s Note Added: 0029416
2012-12-17 06:25 christoph_s Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker