Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011296ScribusImport / Exportpublic12-Dec-27 23:3113-May-30 23:27
Reporterchristoph_s 
Assigned Tofschmid 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSLinuxOS VersionOpenSUSE 12.1
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0011296: XTG Import crashes Scribus
DescriptionImporting any XTG file results in Sig6 crash. The import proceeds to the import dialog asking for the style names. After clicking OK, Scribus crashes.
Additional InformationProgram received signal SIGABRT, Aborted.
0x00007ffff00c1d95 in raise () from /lib64/libc.so.6
(gdb) bt
#0 0x00007ffff00c1d95 in raise () from /lib64/libc.so.6
0000001 0x00007ffff00c32ab in abort () from /lib64/libc.so.6
0000002 0x00007ffff3fd7ec4 in qt_message_output (msgType=<optimized out>, buf=<optimized out>)
    at global/qglobal.cpp:2323
0000003 0x00007ffff3fd807f in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=
    QtFatalMsg, msg=0x7ffff41467c8 "ASSERT: \"%s\" in file %s, line %d", ap=0x7fffffff9938)
    at global/qglobal.cpp:2369
0000004 0x00007ffff3fd8224 in qFatal (msg=<optimized out>) at global/qglobal.cpp:2552
0000005 0x00007ffff3fd826a in qt_assert (assertion=<optimized out>, file=<optimized out>, line=<optimized out>)
    at global/qglobal.cpp:2018
0000006 0x000000000087f8f7 in QString::at (this=0x380b058, i=4444) at /usr/include/QtCore/qstring.h:699
0000007 0x00007fffd32f3b6d in XtgScanner::lookAhead (this=0x380b030)
    at /home/christoph/scribus15/Scribus/scribus/plugins/gettext/xtgim/xtgscanner.cpp:1256
0000008 0x00007fffd32f1856 in XtgScanner::defNewLine (this=0x380b030)
    at /home/christoph/scribus15/Scribus/scribus/plugins/gettext/xtgim/xtgscanner.cpp:859
0000009 0x00007fffd32f42a9 in XtgScanner::xtgParse (this=0x380b030)
    at /home/christoph/scribus15/Scribus/scribus/plugins/gettext/xtgim/xtgscanner.cpp:1342
0000010 0x00007fffd32e83ef in XtgIm::XtgIm (this=0x3bf59a0, fileName=..., enc=..., textItem=0x379d010, textOnly=
    false) at /home/christoph/scribus15/Scribus/scribus/plugins/gettext/xtgim/xtgim.cpp:99
0000011 0x00007fffd32e7e43 in GetText2 (filename=..., encoding=..., textOnly=false, textItem=0x379d010)
    at /home/christoph/scribus15/Scribus/scribus/plugins/gettext/xtgim/xtgim.cpp:56
0000012 0x00000000009693e4 in gtGetText::CallDLL (this=0x3c85720, idata=..., filePath=..., encoding=..., textOnly=
    false, append=false, importItem=0x379d010) at /home/christoph/scribus15/Scribus/scribus/gtgettext.cpp:248
0000013 0x000000000096865e in gtGetText::launchImporter (this=0x3c85720, importer=-1, filename=..., textOnly=false,
    encoding=..., append=false, target=0x0) at /home/christoph/scribus15/Scribus/scribus/gtgettext.cpp:107
0000014 0x0000000000c900b0 in ScribusMainWindow::slotGetContent (this=0x1ab8f30)
    at /home/christoph/scribus15/Scribus/scribus/scribus.cpp:4417
0000015 0x00000000007dd6a2 in ScribusMainWindow::qt_static_metacall (_o=0x1ab8f30, _c=QMetaObject::InvokeMetaMethod,
    _id=52, _a=0x7fffffffab90) at /home/christoph/scribus15/Scribus/scribus/moc_scribus.cxx:479
0000016 0x00007ffff40f6691 in QMetaObject::activate (sender=0x2241670, m=<optimized out>,
    local_signal_index=<optimized out>, argv=0x7fffffffab90) at kernel/qobject.cpp:3548
0000017 0x00007ffff51fcd52 in QAction::triggered(bool) () from /usr/lib64/libQtGui.so.4
0000018 0x00007ffff51fcf3f in QAction::activate(QAction::ActionEvent) () from /usr/lib64/libQtGui.so.4
0000019 0x00007ffff564b459 in ?? () from /usr/lib64/libQtGui.so.4
0000020 0x00007ffff5651672 in ?? () from /usr/lib64/libQtGui.so.4
---Type <return> to continue, or q <return> to quit---
0000021 0x00007ffff5253abc in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
0000022 0x00007ffff5652c0b in QMenu::event(QEvent*) () from /usr/lib64/libQtGui.so.4
0000023 0x00007ffff52031e4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
0000024 0x00007ffff5208883 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
0000025 0x00007ffff40e271c in QCoreApplication::notifyInternal (this=0x7fffffffdb10, receiver=0x37a7060, event=
    0x7fffffffb560) at kernel/qcoreapplication.cpp:946
0000026 0x00007ffff52041b2 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/libQtGui.so.4
0000027 0x00007ffff5280801 in ?? () from /usr/lib64/libQtGui.so.4
0000028 0x00007ffff527effa in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/libQtGui.so.4
0000029 0x00007ffff52a6e32 in ?? () from /usr/lib64/libQtGui.so.4
0000030 0x00007fffee15f58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
0000031 0x00007fffee15fd88 in ?? () from /usr/lib64/libglib-2.0.so.0
0000032 0x00007fffee15ff59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
0000033 0x00007ffff41119cf in QEventDispatcherGlib::processEvents (this=0x198b800, flags=<optimized out>)
    at kernel/qeventdispatcher_glib.cpp:424
0000034 0x00007ffff52a6abe in ?? () from /usr/lib64/libQtGui.so.4
0000035 0x00007ffff40e1252 in QEventLoop::processEvents (this=<optimized out>, flags=...)
    at kernel/qeventloop.cpp:149
0000036 0x00007ffff40e14a7 in QEventLoop::exec (this=0x7fffffffc1f0, flags=...) at kernel/qeventloop.cpp:204
0000037 0x00007ffff564e471 in QMenu::exec(QPoint const&, QAction*) () from /usr/lib64/libQtGui.so.4
0000038 0x00000000008f702a in CanvasMode_Normal::createContextMenu (this=0x25004c0, currItem=0x379d010, mx=190.5, my=
    177) at /home/christoph/scribus15/Scribus/scribus/canvasmode_normal.cpp:1905
0000039 0x00000000008f138a in CanvasMode_Normal::mouseReleaseEvent (this=0x25004c0, m=0x7fffffffce30)
    at /home/christoph/scribus15/Scribus/scribus/canvasmode_normal.cpp:1042
0000040 0x0000000000d93324 in ScribusView::eventFilter (this=0x3a28e70, obj=0x3b39480, event=0x7fffffffce30)
    at /home/christoph/scribus15/Scribus/scribus/scribusview.cpp:4376
0000041 0x00007ffff40e28a8 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=
    0x3b39480, event=0x7fffffffce30) at kernel/qcoreapplication.cpp:1056
0000042 0x00007ffff52031af in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
0000043 0x00007ffff5208883 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
0000044 0x00007ffff40e271c in QCoreApplication::notifyInternal (this=0x7fffffffdb10, receiver=0x3b39480, event=
    0x7fffffffce30) at kernel/qcoreapplication.cpp:946
0000045 0x00007ffff52041b2 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/libQtGui.so.4
---Type <return> to continue, or q <return> to quit---
0000046 0x00007ffff5280135 in ?? () from /usr/lib64/libQtGui.so.4
0000047 0x00007ffff527effa in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/libQtGui.so.4
0000048 0x00007ffff52a6e32 in ?? () from /usr/lib64/libQtGui.so.4
0000049 0x00007fffee15f58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
0000050 0x00007fffee15fd88 in ?? () from /usr/lib64/libglib-2.0.so.0
0000051 0x00007fffee15ff59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
0000052 0x00007ffff41119cf in QEventDispatcherGlib::processEvents (this=0x198b800, flags=<optimized out>)
    at kernel/qeventdispatcher_glib.cpp:424
0000053 0x00007ffff52a6abe in ?? () from /usr/lib64/libQtGui.so.4
0000054 0x00007ffff40e1252 in QEventLoop::processEvents (this=<optimized out>, flags=...)
    at kernel/qeventloop.cpp:149
0000055 0x00007ffff40e14a7 in QEventLoop::exec (this=0x7fffffffdac0, flags=...) at kernel/qeventloop.cpp:204
0000056 0x00007ffff40e62c5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
0000057 0x00000000011dffbb in mainApp (argc=1, argv=0x7fffffffdc88)
    at /home/christoph/scribus15/Scribus/scribus/main_nix.cpp:86
0000058 0x00000000011dff48 in main (argc=1, argv=0x7fffffffdc88)
    at /home/christoph/scribus15/Scribus/scribus/main_nix.cpp:54
TagsNo tags attached.
Attached Files? file icon beans report.xtg [^] (4,444 bytes) 12-Dec-27 23:31
? file icon sobe report.xtg [^] (4,229 bytes) 12-Dec-27 23:31
? file icon pagina 10 report.xtg [^] (22,928 bytes) 12-Dec-29 08:47
? file icon XTGimporter extraits.xtg [^] (1,088 bytes) 12-Dec-29 23:25
? file icon XtgImporter.sla [^] (12,858 bytes) 12-Dec-29 23:28
? file icon xpress33-1.xtg [^] (1,663 bytes) 12-Dec-30 01:15
? file icon xpress33-2.xtg [^] (1,394 bytes) 12-Dec-30 01:16

- Relationships
related to 0011311new XPress Tag (XTG) test cases 

-  Notes
(0029511)
fschmid (administrator)
12-Dec-29 08:31

Can you please upload some files with content? The two files already uploaded contain only style and formatting information but not textual content.
(0029512)
christoph_s (administrator)
12-Dec-29 08:47

voilĂ 
(0029519)
JLuc (updater)
12-Dec-29 23:10
edited on: 12-Dec-29 23:29

How did I test : I do click right on a text frame and "import text" and choose a XTG export for a QXP7.31 (i uploaded XTGimporter_extraits.xtg and xtgImporter.sla with predefined styles) (it is NOT a filename_report.xtg automatically created during "bring all files and ressources together" operation)

AMOF it crashes SIG6 at the end of the (badly done) import :

Sometime during the import, a "Select alternate font" dialog is displayed with a font SELECT widget. But it doesnt say why we ought to select an alternate font. I guess some font is missing or cannot be used. Dialog title should mention which font it is.

+ styles used in the XTG are allways declared missing ("Style MyExistingStyle is not defined, falling back to Scribus Default"), even when the style exists in the SLA. Clicking or not clicking the "prefix styles with document name" option at the begining does not change this (The prefix is never displayed in this warning dialog).

+ "Import text only" in the first "choose file" dialog does not change behaviour.

(0029524)
christoph_s (administrator)
12-Dec-30 01:15

Here are two other files with real content, created with XPress 3.3 under Windows 3.
(0029525)
christoph_s (administrator)
12-Dec-30 01:17

As to the font substitution, I agree. Should be the same as with SLA, ODT etc.
(0030198)
christoph_s (administrator)
13-May-29 08:14

It would we be great if someone could finally fix the crash, because otherwise it's impossible to test the importer.
(0030202)
christoph_s (administrator)
13-May-30 23:27

Tested, fixed. Thanks.

- Issue History
Date Modified Username Field Change
12-Dec-27 23:31 christoph_s New Issue
12-Dec-27 23:31 christoph_s File Added: beans report.xtg
12-Dec-27 23:31 christoph_s File Added: sobe report.xtg
12-Dec-29 08:31 fschmid Note Added: 0029511
12-Dec-29 08:47 christoph_s File Added: pagina 10 report.xtg
12-Dec-29 08:47 christoph_s Note Added: 0029512
12-Dec-29 23:10 JLuc Note Added: 0029519
12-Dec-29 23:17 JLuc Note Edited: 0029519 View Revisions
12-Dec-29 23:18 JLuc Note Edited: 0029519 View Revisions
12-Dec-29 23:21 JLuc Note Edited: 0029519 View Revisions
12-Dec-29 23:25 JLuc File Added: XTGimporter extraits.xtg
12-Dec-29 23:26 JLuc Note Edited: 0029519 View Revisions
12-Dec-29 23:26 JLuc Note Edited: 0029519 View Revisions
12-Dec-29 23:28 JLuc File Added: XtgImporter.sla
12-Dec-29 23:29 JLuc Note Edited: 0029519 View Revisions
12-Dec-30 01:15 christoph_s Note Added: 0029524
12-Dec-30 01:15 christoph_s File Added: xpress33-1.xtg
12-Dec-30 01:16 christoph_s File Added: xpress33-2.xtg
12-Dec-30 01:17 christoph_s Note Added: 0029525
12-Dec-30 08:53 christoph_s Relationship added related to 0011311
13-May-29 08:14 christoph_s Note Added: 0030198
13-May-30 10:13 fschmid Status new => resolved
13-May-30 10:13 fschmid Fixed in Version => 1.5.0svn
13-May-30 10:13 fschmid Resolution open => fixed
13-May-30 10:13 fschmid Assigned To => fschmid
13-May-30 23:27 christoph_s Note Added: 0030202
13-May-30 23:27 christoph_s Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker