Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011307ScribusUser Interfacepublic2012-12-30 05:562014-07-04 15:23
Reporterchristoph_s 
Assigned Tocbradney 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0011307: Non-switching translations in Scribus 1.5svn
DescriptionAs in earlier versions there are a text strings in the UI that don't switch to the new UI language after it has been changed. Here's the place to collect them, so they can be fixed before the release of 1.5.0.
TagsNo tags attached.
Patch
Attached Files

- Relationships

-  Notes
(0029526)
christoph_s (administrator)
2012-12-30 05:57

First one: Image preview quality in the status bar at the bottom.
(0029527)
christoph_s (administrator)
2012-12-30 06:06
edited on: 2012-12-30 06:08

Properties Palette: Colour > Fill: Almost all strings, Stroke: Drop-down entries for Stroke mode.

(0029528)
christoph_s (administrator)
2012-12-30 06:09

Properties Palette: Transparency: Almost all strings.
(0029529)
christoph_s (administrator)
2012-12-30 06:12

Properties Palette: Table > Fill: "Colour" and "Shade".
(0029530)
christoph_s (administrator)
2012-12-30 06:15

Properties Palette: Image > "Scaling"
(0029531)
christoph_s (administrator)
2012-12-30 06:21

Style Manager > Character Styles: Section captions ("Basic Formatting" etc.)
(0029532)
christoph_s (administrator)
2012-12-30 06:24

Style Manager > Table Styles: Section caption and drop-down list.

Style Manager > Cell Styles: Section caption and drop-down list.
(0029533)
christoph_s (administrator)
2012-12-30 06:26

Item > Send to Scrapbook (menu entry)
(0029534)
christoph_s (administrator)
2012-12-30 06:29

Properties Palette > Group: Almost everything from Fill Options on.
(0029535)
christoph_s (administrator)
2012-12-30 06:31

Action History: Window caption.
(0029536)
christoph_s (administrator)
2012-12-30 06:33

Align & Distribute > Distribute > Reverse Distribution
(0029545)
jghali (administrator)
2012-12-30 22:19

Christoph, there is almost no interest in looking those non switching strings currently. Most if not all the strings you mention do not switch simply because the translation files are out of date.
(0029546)
cbradney (administrator)
2012-12-30 23:47

Jean is correct. Complete your translation of the DE ts file and then check again.
(0029548)
christoph_s (administrator)
2012-12-31 00:50

I don't think this is correct. To make sure I only listed non-witching strings, I switched from German to English. The strings mentioned here are those that still show the German translation after a switch to English.
(0029551)
christoph_s (administrator)
2012-12-31 08:54

Moreover, this bug has been created as a reminder for the final polishing of the next major release, not as something that requires immediate action.
(0029555)
cbradney (administrator)
2012-12-31 11:03

Christoph - we don't create bugs for airy fairy possibilities for future action. We create them for reproduceable bugs, or new features. Either update your translations and re-test, or close this bug.
(0029568)
christoph_s (administrator)
2013-01-01 08:49

Craig, please read what I wrote again: The strings I added are already translated, yet the UI doesn't switch back to the default (English) if English is being selected as a new UI language.

This is a reproduceable bug, and, honestly, I think it makes more sense to collect all of those issues in a single bug entry than to create a new one for every string.

As to "airy-fairy", we've been talking about a tentative feature freeze a couple of days ago, haven't we? Feature freeze, even if tentative, means (at least as I understand it) polishing the existing features, and removing non-switching UI strings is definitely part of the polishing.
(0029574)
cbradney (administrator)
2013-01-01 18:02

Ok, if those ones are definitely translated then I can take a look, however, I'd rather see one language fully translated then we can check everything.
(0029621)
christoph_s (administrator)
2013-01-07 08:55

Craig, I didn't expect you to look at these issues right now, especially since more string changes are expected until the release of 1.5.0. I just opened this bug to have a single place to collect all "offending" strings, so this can be resolved in one go when the time is right.
(0029622)
bubu (reporter)
2013-01-07 09:22

I can confirm this bug on Hungarian. The Hungarian translation is complete (last lupdate was 10 day before.)
(0030957)
christoph_s (administrator)
2013-12-28 08:17

After the change to Qt5, all menu bar entries won't be translated on the fly. The same goes for the menu entries (not for the sub-menu entries) in the Item and View menus. In the Insert entries, some items' translations don't switch.
(0030958)
cbradney (administrator)
2013-12-28 11:56

Thats normal, I turned off auto translation, close/reopen Scribus. Maybe with my menu rewrite I can reenable it but maybe not.
(0031031)
cbradney (administrator)
2014-01-11 00:15

Menu retranslation should now work ok
(0031050)
cbradney (administrator)
2014-01-12 16:45

Resolving this. Please translate the DE ts file and once complete, then we can review for strings that do not switch via a new bug.
(0031055)
christoph_s (administrator)
2014-01-13 01:34

To be continued ...

- Issue History
Date Modified Username Field Change
2012-12-30 05:56 christoph_s New Issue
2012-12-30 05:57 christoph_s Note Added: 0029526
2012-12-30 06:06 christoph_s Note Added: 0029527
2012-12-30 06:08 christoph_s Note Edited: 0029527 View Revisions
2012-12-30 06:09 christoph_s Note Added: 0029528
2012-12-30 06:12 christoph_s Note Added: 0029529
2012-12-30 06:15 christoph_s Note Added: 0029530
2012-12-30 06:21 christoph_s Note Added: 0029531
2012-12-30 06:24 christoph_s Note Added: 0029532
2012-12-30 06:26 christoph_s Note Added: 0029533
2012-12-30 06:29 christoph_s Note Added: 0029534
2012-12-30 06:31 christoph_s Note Added: 0029535
2012-12-30 06:33 christoph_s Note Added: 0029536
2012-12-30 22:19 jghali Note Added: 0029545
2012-12-30 23:47 cbradney Note Added: 0029546
2012-12-31 00:50 christoph_s Note Added: 0029548
2012-12-31 08:54 christoph_s Note Added: 0029551
2012-12-31 11:03 cbradney Note Added: 0029555
2013-01-01 08:49 christoph_s Note Added: 0029568
2013-01-01 18:02 cbradney Note Added: 0029574
2013-01-07 08:55 christoph_s Note Added: 0029621
2013-01-07 09:22 bubu Note Added: 0029622
2013-12-28 08:17 christoph_s Note Added: 0030957
2013-12-28 08:18 christoph_s Target Version 1.5.0 => 1.5.1
2013-12-28 11:56 cbradney Note Added: 0030958
2014-01-11 00:15 cbradney Note Added: 0031031
2014-01-12 16:45 cbradney Note Added: 0031050
2014-01-12 16:45 cbradney Status new => resolved
2014-01-12 16:45 cbradney Fixed in Version => 1.5.0svn
2014-01-12 16:45 cbradney Resolution open => fixed
2014-01-12 16:45 cbradney Assigned To => cbradney
2014-01-13 01:34 christoph_s Note Added: 0031055
2014-01-13 01:34 christoph_s Status resolved => closed
2014-07-04 15:23 Kunda Target Version 1.5.1 => 1.5.0



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker