Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011335ScribusImport / Exportpublic13-Jan-06 03:5613-Jan-07 21:42
Reporterchristoph_s 
Assigned Tofschmid 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSLinuxOS VersionOpenSUSE 12.1
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0011335: Scribus fails to import PS files created by itself
DescriptionIf I open the attached PS file generated by 1.5.0svn with no document open, the import is broken (all PS pages on one page in the Scribus document.

If a document is open and the PS file is being imported, Scribus crashes.
Steps To ReproduceFor the crash:

- Start Scribus

- Create new doc (nothing else has to be done to reproduce the crash).

- Open the attached PS file.

--> Splat
Additional InformationProgram received signal SIGSEGV, Segmentation fault.
0x000000000087864e in ScPage::xOffset (this=0x0) at /home/christoph/scribus15/Scribus/scribus/scpage.h:51
51 double xOffset() const { return m_xOffset; }
(gdb) bt
#0 0x000000000087864e in ScPage::xOffset (this=0x0) at /home/christoph/scribus15/Scribus/scribus/scpage.h:51
0000001 0x0000000000c74bc1 in ScribusMainWindow::setStatusBarMousePosition (this=0x1af6280, xp=432.75, yp=
    272.28346456692918) at /home/christoph/scribus15/Scribus/scribus/scribus.cpp:1179
0000002 0x00000000007e1fce in ScribusMainWindow::qt_static_metacall (_o=0x1af6280, _c=QMetaObject::InvokeMetaMethod,
    _id=22, _a=0x7fffffff9cc0) at /home/christoph/scribus15/Scribus/scribus/moc_scribus.cxx:445
0000003 0x00007ffff40f6691 in QMetaObject::activate (sender=0x3c3fbf0, m=<optimized out>,
    local_signal_index=<optimized out>, argv=0x7fffffff9cc0) at kernel/qobject.cpp:3548
0000004 0x00000000007e8b6b in ScribusView::MousePos (this=0x3c3fbf0, _t1=432.75, _t2=272.28346456692918)
    at /home/christoph/scribus15/Scribus/scribus/moc_scribusview.cxx:593
0000005 0x0000000000da1de9 in ScribusView::eventFilter (this=0x3c3fbf0, obj=0x3c43150, event=0x7fffffffa360)
    at /home/christoph/scribus15/Scribus/scribus/scribusview.cpp:4342
0000006 0x00007ffff40e28a8 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=
    0x3c43150, event=0x7fffffffa360) at kernel/qcoreapplication.cpp:1056
0000007 0x00007ffff52031af in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
0000008 0x00007ffff5208883 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
0000009 0x00007ffff40e271c in QCoreApplication::notifyInternal (this=0x7fffffffdb10, receiver=0x3c43150, event=
    0x7fffffffa360) at kernel/qcoreapplication.cpp:946
0000010 0x00007ffff52041b2 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/libQtGui.so.4
0000011 0x00007ffff5280135 in ?? () from /usr/lib64/libQtGui.so.4
0000012 0x00007ffff527effa in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/libQtGui.so.4
0000013 0x00007ffff52a6e32 in ?? () from /usr/lib64/libQtGui.so.4
0000014 0x00007fffee15f58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
0000015 0x00007fffee15fd88 in ?? () from /usr/lib64/libglib-2.0.so.0
0000016 0x00007fffee15ff59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
0000017 0x00007ffff41119cf in QEventDispatcherGlib::processEvents (this=0x19b3800, flags=<optimized out>)
    at kernel/qeventdispatcher_glib.cpp:424
0000018 0x00007ffff52a6abe in ?? () from /usr/lib64/libQtGui.so.4
0000019 0x00007ffff40e645f in QCoreApplication::processEvents (flags=...) at kernel/qcoreapplication.cpp:1133
0000020 0x00007fffdbebaf92 in PdfPlug::import (this=0x4dddef0, fNameIn=..., trSettings=..., flags=1, showProgress=
    true) at /home/christoph/scribus15/Scribus/scribus/plugins/import/pdf/importpdf.cpp:202
0000021 0x00007fffdbec610e in ImportPdfPlugin::import (this=0x208b320, fileName=..., flags=1)
    at /home/christoph/scribus15/Scribus/scribus/plugins/import/pdf/importpdfplugin.cpp:222
0000022 0x00007fffdbec5268 in ImportPdfPlugin::loadFile (this=0x208b320, fileName=..., flags=1)
    at /home/christoph/scribus15/Scribus/scribus/plugins/import/pdf/importpdfplugin.cpp:149
---Type <return> to continue, or q <return> to quit---
0000023 0x0000000000992171 in FileFormat::loadFile (this=0x20a1ce0, fileName=..., flags=1, index=0)
    at /home/christoph/scribus15/Scribus/scribus/loadsaveplugin.cpp:433
0000024 0x000000000092e26a in FileLoader::loadFile (this=0x35959f0, currDoc=0x3aa20d0)
    at /home/christoph/scribus15/Scribus/scribus/fileloader.cpp:239
0000025 0x0000000000c956af in ScribusMainWindow::loadDoc (this=0x1af6280, fileName=...)
    at /home/christoph/scribus15/Scribus/scribus/scribus.cpp:4078
0000026 0x0000000000c933f0 in ScribusMainWindow::slotDocOpen (this=0x1af6280)
    at /home/christoph/scribus15/Scribus/scribus/scribus.cpp:3800
0000027 0x00000000007e27b2 in ScribusMainWindow::qt_static_metacall (_o=0x1af6280, _c=QMetaObject::InvokeMetaMethod,
    _id=67, _a=0x7fffffffc460) at /home/christoph/scribus15/Scribus/scribus/moc_scribus.cxx:495
0000028 0x00007ffff40f6691 in QMetaObject::activate (sender=0x20e8e40, m=<optimized out>,
    local_signal_index=<optimized out>, argv=0x7fffffffc460) at kernel/qobject.cpp:3548
0000029 0x00007ffff51fcd52 in QAction::triggered(bool) () from /usr/lib64/libQtGui.so.4
0000030 0x00007ffff51fcf3f in QAction::activate(QAction::ActionEvent) () from /usr/lib64/libQtGui.so.4
0000031 0x00007ffff564b459 in ?? () from /usr/lib64/libQtGui.so.4
0000032 0x00007ffff5651672 in ?? () from /usr/lib64/libQtGui.so.4
0000033 0x00007ffff5253abc in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
0000034 0x00007ffff5652c0b in QMenu::event(QEvent*) () from /usr/lib64/libQtGui.so.4
0000035 0x00007ffff52031e4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
0000036 0x00007ffff5208883 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
0000037 0x00007ffff40e271c in QCoreApplication::notifyInternal (this=0x7fffffffdb10, receiver=0x2294de0, event=
    0x7fffffffce30) at kernel/qcoreapplication.cpp:946
0000038 0x00007ffff52041b2 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/libQtGui.so.4
0000039 0x00007ffff5280801 in ?? () from /usr/lib64/libQtGui.so.4
0000040 0x00007ffff527effa in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/libQtGui.so.4
0000041 0x00007ffff52a6e32 in ?? () from /usr/lib64/libQtGui.so.4
0000042 0x00007fffee15f58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
0000043 0x00007fffee15fd88 in ?? () from /usr/lib64/libglib-2.0.so.0
0000044 0x00007fffee15ff59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
0000045 0x00007ffff41119cf in QEventDispatcherGlib::processEvents (this=0x19b3800, flags=<optimized out>)
    at kernel/qeventdispatcher_glib.cpp:424
0000046 0x00007ffff52a6abe in ?? () from /usr/lib64/libQtGui.so.4
0000047 0x00007ffff40e1252 in QEventLoop::processEvents (this=<optimized out>, flags=...)
    at kernel/qeventloop.cpp:149
---Type <return> to continue, or q <return> to quit---
0000048 0x00007ffff40e14a7 in QEventLoop::exec (this=0x7fffffffdac0, flags=...) at kernel/qeventloop.cpp:204
0000049 0x00007ffff40e62c5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
0000050 0x00000000011fc45b in mainApp (argc=1, argv=0x7fffffffdc88)
    at /home/christoph/scribus15/Scribus/scribus/main_nix.cpp:86
0000051 0x00000000011fc3e8 in main (argc=1, argv=0x7fffffffdc88)
    at /home/christoph/scribus15/Scribus/scribus/main_nix.cpp:54
TagsNo tags attached.
Attached Files? file icon Document-2.ps [^] (915,775 bytes) 13-Jan-06 03:56

- Relationships

-  Notes
(0029611)
fschmid (administrator)
13-Jan-06 10:55

Can't reproduce that crash, not with own docs nor with the attached doc.

> If I open the attached PS file generated by 1.5.0svn with no document open, the import is broken (all PS pages on one page in the Scribus document.
Have cleanly 4 Pages here, only the content isn't 100% correct, but thats the fault of Ghostscripts ps2pdf.

Have you tried to install the latest Ghostscript?
(0029612)
cbradney (administrator)
13-Jan-06 11:10

Scribus should never crash no matter what GS returns.
(0029615)
jghali (administrator)
13-Jan-06 17:18

I committed a fix for a variable being used without being initialized. WIth that fix i can import the attached ps file with ghostscript 9.05. Christoph, please test with your gs version.
(0029619)
christoph_s (administrator)
13-Jan-07 00:01

With Jean's fix the import is working if no other document is open, but the crash still happens.

GS version is 9.00.
(0029638)
christoph_s (administrator)
13-Jan-07 21:42

Tested, fixed. Thanks.

- Issue History
Date Modified Username Field Change
13-Jan-06 03:56 christoph_s New Issue
13-Jan-06 03:56 christoph_s File Added: Document-2.ps
13-Jan-06 10:55 fschmid Note Added: 0029611
13-Jan-06 11:10 cbradney Note Added: 0029612
13-Jan-06 17:18 jghali Note Added: 0029615
13-Jan-07 00:01 christoph_s Note Added: 0029619
13-Jan-07 10:07 fschmid Status new => resolved
13-Jan-07 10:07 fschmid Fixed in Version => 1.5.0svn
13-Jan-07 10:07 fschmid Resolution open => fixed
13-Jan-07 10:07 fschmid Assigned To => fschmid
13-Jan-07 21:42 christoph_s Note Added: 0029638
13-Jan-07 21:42 christoph_s Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker