Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011399ScribusUser Interfacepublic2013-01-25 16:522014-12-14 01:31
ReporterJLuc 
Assigned ToFirasH 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version1.5.0svn 
Target Version1.5.1Fixed in Version1.5.0svn 
Summary0011399: Dialogs are hidden by Palettes docked and then undocked
DescriptionScribus Dialogs (example: Style Manager/Nodes) are hidden by Palettes (listed under Windows menu) in determined condition.
Steps To Reproduce0) Create a new document
1) Open: Windows > Properties (F2) (works with all palettes)
2) Open: Edit > Styles... (F3) (works with all dialogs)
3) Dock and then Undock Properties palette

Now Properties palette is always on top of Styles dialog.
Here on openSUSE even moving to a different application (Alt+Tab) keeps the palette always on top.
Additional InformationTested with 1.5.0.svn (19343) on openSUSE 13.1
TagsNo tags attached.
Patch
Attached Files

- Relationships
related to 0009057confirmed Scribus floating toolbars are visible in other applications 
related to 0012073closedFirasH Master Pages always on top even when switching applications 

-  Notes
(0029767)
christoph_s (administrator)
2013-01-26 07:19

I cannot replicate this on OpenSUSE and Windows 7. The Nodes palette is always on top of the PP.
(0032741)
Kunda (manager)
2014-07-14 18:41

Unable to reproduce on OSX 10.8.5 r19342
When Nodes is active it's on top of PP. If i switch applications, Nodes and the rest of Scribus is hidden.
(0032742)
FirasH (developer)
2014-07-14 19:01

Confirming. Edited the report.
(0032743)
Kunda (manager)
2014-07-14 19:38

Still unable to reproduce on OSX 10.8.5
(0032957)
JLuc (updater)
2014-07-24 11:50
edited on: 2014-07-24 11:51

I reported this 18 months ago for ubuntu 12.10. Today, i confirm this on ubuntu 13.10 but i'm not disturbed with this behaviour, since i work with the property palettes docked, and the style window in a 2nd smaller screen.

I guess the described behaviour is an issue when working on small screen, since one has to close the property palette so as to be able to use the style dialog.

(0034287)
FirasH (developer)
2014-12-13 22:28

After update to Qt 5.4.0, I cannot reproduce this on openSUSE 13.1.

- Issue History
Date Modified Username Field Change
2013-01-25 16:52 JLuc New Issue
2013-01-26 07:18 christoph_s Summary Points window keeps being hiden => Nodes window keeps being hiden
2013-01-26 07:18 christoph_s Description Updated View Revisions
2013-01-26 07:19 christoph_s Note Added: 0029767
2014-07-14 18:41 Kunda Note Added: 0032741
2014-07-14 18:41 Kunda Status new => feedback
2014-07-14 19:01 FirasH Note Added: 0032742
2014-07-14 19:01 FirasH Status feedback => confirmed
2014-07-14 19:01 FirasH Category Usability => User Interface
2014-07-14 19:01 FirasH OS Ubuntu =>
2014-07-14 19:01 FirasH OS Version 1.4.2 and 1.5svn =>
2014-07-14 19:01 FirasH Summary Nodes window keeps being hiden => Dialogs are hidden by Palettes docked and then undocked
2014-07-14 19:01 FirasH Description Updated View Revisions
2014-07-14 19:01 FirasH Steps to Reproduce Updated View Revisions
2014-07-14 19:01 FirasH Additional Information Updated View Revisions
2014-07-14 19:38 Kunda Note Added: 0032743
2014-07-14 22:45 Kunda Target Version => 1.5.1
2014-07-24 06:37 Kunda Relationship added related to 0009057
2014-07-24 11:50 JLuc Note Added: 0032957
2014-07-24 11:51 JLuc Note Edited: 0032957 View Revisions
2014-07-24 11:51 JLuc Note Edited: 0032957 View Revisions
2014-09-12 17:04 Kunda Relationship added related to 0012073
2014-12-13 22:28 FirasH Note Added: 0034287
2014-12-13 22:28 FirasH Status confirmed => resolved
2014-12-13 22:28 FirasH Fixed in Version => 1.5.0svn
2014-12-13 22:28 FirasH Resolution open => no change required
2014-12-13 22:28 FirasH Assigned To => FirasH
2014-12-14 01:31 FirasH Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker