Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011530ScribusPlug-inspublic13-May-19 07:1413-May-21 01:59
Reporterchristoph_s 
Assigned Tofschmid 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
Platformx86_64OSLinuxOS VersionOpenSUSE 12.1
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0011530: Error loading the PUB import plug-in
DescriptionBuilding 1.5.0svn with libmspub works fine, and CMake reports this:

-- checking for module 'libwpg-0.2'
-- found libwpg-0.2, version 0.2.1
-- checking for module 'libwpd-0.9'
-- found libwpd-0.9, version 0.9.3
-- checking for module 'libwpd-stream-0.9'
-- found libwpd-stream-0.9, version 0.9.3
-- checking for module 'libmspub-0.0'
-- found libmspub-0.0, version 0.0.6


However, when I launch 1.5.0svn, I get this error message:

There is a problem loading 1 of 41 plug-ins.
libimportpub.so
This is probably caused by some kind of dependency issue or old plug-ins existing in your install directory. If you clean out your install directory and reinstall and this still occurs, please report it on bugs.scribus.net.
Additional InformationI'm still building 1.5.0svn with Qt 4.8.4, not 5.0 or 5.1.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0030150)
fschmid (administrator)
13-May-19 09:13

Please go to the plugin installation directory and issue in a console the command "ldd libimportpub.so". This should report any dependency issues. Please upload the command output here.
(0030151)
christoph_s (administrator)
13-May-20 07:57

ldd libimportpub.so

...

libQtXml.so.4 => /usr/lib64/libQtXml.so.4 (0x00007fda04a99000)
        libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007fda0473c000)
        libz.so.1 => /lib64/libz.so.1 (0x00007fda04523000)
        libwpg-0.2.so.2 => /usr/lib64/libwpg-0.2.so.2 (0x00007fda042f7000)
        libwpd-0.9.so.9 => /usr/lib64/libwpd-0.9.so.9 (0x00007fda0401f000)
        libwpd-stream-0.9.so.9 => /usr/lib64/libwpd-stream-0.9.so.9 (0x00007fda03e0f000)
        libmspub-0.0.so.0 => not found
...

locate libmspub:

...

/usr/local/include/libmspub-0.0
/usr/local/include/libmspub-0.0/libmspub
/usr/local/include/libmspub-0.0/libmspub/libmspub.h
/usr/local/include/libmspub-0.0/libmspub/MSPUBDocument.h
/usr/local/include/libmspub-0.0/libmspub/MSPUBStringVector.h
/usr/local/lib64/libmspub-0.0.la
/usr/local/lib64/libmspub-0.0.so
/usr/local/lib64/libmspub-0.0.so.0
/usr/local/lib64/libmspub-0.0.so.0.0.6
/usr/local/lib64/pkgconfig/libmspub-0.0.pc

...
(0030152)
fschmid (administrator)
13-May-20 09:31

Thanks for the informations, i can only suggest that you should be sure that the following things are set on your system.
1) Do you have a line like "/usr/local/lib64" in your /etc/ld.so.conf file?
2) Did you issue an "ldconfig" call after the "make install" of libmspub?
(0030153)
christoph_s (administrator)
13-May-20 18:52

1) /etc/ld.so.conf looks like this:

/usr/local/lib64
/usr/local/lib
include /etc/ld.so.conf.d/*.conf
# /lib64, /lib, /usr/lib64 and /usr/lib gets added
# automatically by ldconfig after parsing this file.
# So, they do not need to be listed.

2) No.
(0030154)
christoph_s (administrator)
13-May-20 21:54

Running ldconfig as root solved the issue, but why is this necessary only for libmspub, not the other required libs?
(0030155)
fschmid (administrator)
13-May-20 23:25
edited on: 13-May-20 23:26

Normally the "make install" performs an "ldconfig" but it seems that this is missing in libmspub "make install"
Personally i do always an "ldconfig" after "make install"


- Issue History
Date Modified Username Field Change
13-May-19 07:14 christoph_s New Issue
13-May-19 07:14 christoph_s Status new => assigned
13-May-19 07:14 christoph_s Assigned To => fschmid
13-May-19 09:13 fschmid Note Added: 0030150
13-May-20 07:57 christoph_s Note Added: 0030151
13-May-20 09:31 fschmid Note Added: 0030152
13-May-20 18:52 christoph_s Note Added: 0030153
13-May-20 21:54 christoph_s Note Added: 0030154
13-May-20 23:25 fschmid Note Added: 0030155
13-May-20 23:26 fschmid Note Edited: 0030155 View Revisions
13-May-20 23:26 fschmid Status assigned => resolved
13-May-20 23:26 fschmid Fixed in Version => 1.5.0svn
13-May-20 23:26 fschmid Resolution open => no change required
13-May-21 01:59 christoph_s Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker