Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001175ScribusGeneralpublic2004-10-01 22:442005-05-29 19:01
Reportermhanski 
Assigned Tocbradney 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformAMD Athlon XP 3000+OSMandrake Linux OfficialOS Version10
Product Version1.3 
Target VersionFixed in Version1.3.0cvs 
Summary0001175: Switching between GUI languages from within Scribus
DescriptionAllow to switch the GUI language while running Scribus, e.g. in Settings>Select language (like Skype does, see screen shot)
TagsNo tags attached.
Patch
Attached Filespng file icon skype_language_selection.png [^] (63,978 bytes) 2004-10-01 22:44


png file icon germ_pol1.png [^] (183,388 bytes) 2005-05-14 19:43


png file icon germ_brit1.png [^] (153,270 bytes) 2005-05-14 19:44


png file icon file_pl2en.png [^] (25,868 bytes) 2005-05-16 19:42


png file icon extras_pl2en.png [^] (13,487 bytes) 2005-05-16 19:42


png file icon script_pl2en.png [^] (10,537 bytes) 2005-05-16 19:42


png file icon help_pl2en.png [^] (12,103 bytes) 2005-05-16 19:43


png file icon form_fields.png [^] (11,455 bytes) 2005-05-19 18:04


png file icon links.png [^] (7,479 bytes) 2005-05-19 18:04

- Relationships
child of 0003821acknowledged Metabug: Usability 

-  Notes
(0002744)
cbradney (administrator)
2004-10-21 18:22

Do you want the language chosen to then be a part of preferences?
If so, problem.. Scribus loads the preferences as part of the process when the splashscreen is showing, and the language is already set for the update messages then.. any ideas?
(0002745)
subik (manager)
2004-10-21 19:05

preferences - yes.
change from menu - no. there are a lot of things depending on the language at start.
(0002747)
cbradney (administrator)
2004-10-21 19:15

Either way, we dont load prefs before the Splashscreen now.. and we would at least need to load that preference. Changing from a menu is probably the easiest part.
(0002754)
cbradney (administrator)
2004-10-22 08:36

Subik, another thing is, if theres a prefs entry.. what would come first? what order?
- -l/--lang setting
- LC_ALL
- LC_MESSAGES
- LANG
- prefs

Thats my guess as it is in the list. IE, sticking prefs on the end, because if you specify a cmd line option you really want it like that.
(0002755)
mhanski (developer)
2004-10-22 10:25
edited on: 2004-10-22 17:38

I agree, that the command line option should overwrite all other settings, but prefs should definitely prevail over LC_* and LANG variables. Otherwise, switching language within Scribus wouldn't make any sense, as you needed to change these variables first, to make it work on the next Scribus launch.

I think it's a good idea to store the chosen language somewhere in ~./scribus/scribus.rc and use this setting on the next launch. That's the way, Skype does it (see the screen shot), apart from immediately switching the GUI to the chosen language.

The pros of such a solution are pretty obvious. The question: "How do I switch Scribus to Polish?" is very common, this would add a lot to usability for quys (think of all those Mac users), who simply want to click on an icon to launch Scribus and don't care so much for CL options and environmental variables. Secondly, it would show to users, how many GUI languages are available - I'm pretty sure, there are lots of people who don't bother to look into Help>About>Translations. Not to mention us Scribus translators, whose life would be much easier with this option available :)

edited on: 04-10-22 17:38
(0004574)
cbradney (administrator)
2005-05-10 22:37

In progress.
(0004581)
louisdesjardins (developer)
2005-05-11 16:47

I have one concern about the Skype screenshot which shows a list where not all the names are in the same language. English followed by Fran├žais and at the bottom Svenska ... this is very confusing. IMO the whole list should appear in the language Scribus was launched. When in the new language, the list now shows in that new language.

Also, there should be a way to make sure Scribus remembers from last time.

Would that prevent us from having multiple windows/languages at once on the screen? As it is right now, I don't have a problem and it is easy to compare different languages. For translating, it's great. (All this done through command line)

Anyway, just a few thoughts.
(0004585)
cbradney (administrator)
2005-05-11 21:03

Its in Prefs, General. When you select a new language and close the prefs window, the GUI reloads in the new language, all strings in the same language (or whatevers translated in the loaded qm file of course).

The value is stored in Scribus prefs13.xml file. It takes preference over the environment variables, but is overridden by the command line -l/--lang option.
(0004627)
mhanski (developer)
2005-05-14 19:49

I like your idea with the language settings in Prefs. It's consistent with the other settings.

However, there are at least 2 insects to be killed, to make it work properly:

1. After changing the language in Prefs, the menus don't switch to the new language, while the dialogs do -- see the screen shot germ_pol1.png

2. If you change the language twice, you will get a sig 11 with a message in the 3rd language -- I can reproduce it every time -- see the screen shot germ_brit1.png
(0004628)
cbradney (administrator)
2005-05-14 19:49

/me sees your images and awaits the comments...
(0004629)
cbradney (administrator)
2005-05-14 19:52

1. I've just committed the code for it. This is a work in progress, currently the plugin menu items do not yet change, plus all the palettes I'm sure.

2. Your crash, AFAIK, related to having a doc open. I'm guessing you went, open 1.3, change lang, new doc, change lang. Changing lang with a doc open was causing this error. Also fixed in CVS in my commit just before you added the images.

Anon CVS is updated, please grab and test. Tnx
(0004630)
mhanski (developer)
2005-05-14 19:58

Ad 2. Correct assumption, sig 11 happens while a doc is open, and not, if I change languages without opened docs
(0004632)
mhanski (developer)
2005-05-14 22:45

Ad 1. Much better now, main menu OK, menu File, Script, and Help still shows some entries in the other language -- probably the plug-ins you've mentioned

Ad 2. This bug is dead, works perfectly now.
(0004659)
cbradney (administrator)
2005-05-15 23:57

Plugin menu items change language now, however many many translations need updating to get this to look correct.
(0004673)
mhanski (developer)
2005-05-16 19:47

Much better now, let's kill the rest of them one by one.

I launched Scribus with Polish and switched it to British English then.

See the 4 last screen shots -- after the switch to English some of the menu items in File, Extras, Script, and Help remained Polish.
(0004689)
cbradney (administrator)
2005-05-17 12:43

Most palettes should update now, depending on the translation file of course.
(0004696)
mhanski (developer)
2005-05-17 20:28
edited on: 2005-05-17 20:29

I've done the same as yesterday -- switched from PL to EN(UK)

File -- 3 strings still Polish ("Nowy z szablonu", "Zapisz jako szablon", "Podglad wydruku")

Extras -- 1 string Polish ("Znak")

Script -- all strings remain Polish

Help -- 1 string Polish ("Podrecznik wtyczki skryptowej")

These strings remain Polish, even if I switch to German.

(0004698)
cbradney (administrator)
2005-05-17 23:08

Ok, I think I'm making progress on the plugins. Scripter and its menus still need fixing but I need a think over in general this to make sure its not too complicated for plugin writers. Seems ok. Will look over this in the next days and commit when I think its ok.

Please check other areas that you find arent translated after switching. I may know about some but most are ok now I think.
(0004703)
cbradney (administrator)
2005-05-18 12:30

Ok, I think i got it now for plugins and their menu items. :) Works here for pl-en_gb-pl.
(0004705)
mhanski (developer)
2005-05-18 20:15
edited on: 2005-05-18 20:16

You are almost there :)

Menu Insert -- still one Polish entry ("Znak")

Scripts > Show console -- Window title still Polish

Main menu > click on the arrow beside "OK" -- all entries are Polish

Main menu > click on the arrow beside "ABC" -- both entries still Polish

Preferences > Hyphenator settings -- default language still Polish after the switch

I can't find the Scripter Settings in 1.3 anymore (where are they?), so I haven't turned on and checked the Macro menu.

(0004709)
cbradney (administrator)
2005-05-19 14:46

Are you sure your translation file is up to date for those menu items?
(0004710)
mhanski (developer)
2005-05-19 14:56

Yes, since those menu items remained _Polish_, instead of English, after I had switched from PL to EN(UK). The listed menu items didn't change after the switch.
(0004711)
cbradney (administrator)
2005-05-19 15:04

Ah ok. Will have a look tonight if I get a chance, otherwise it will be Monday. I will not make it change hyphenation language. That is a per document, per frame setting.
(0004712)
cbradney (administrator)
2005-05-19 15:12

-Menu Insert -- still one Polish entry ("Znak")

Got that one.

-Scripts > Show console -- Window title still Polish

Got that one.

-Main menu > click on the arrow beside "OK" -- all entries are Polish
-Main menu > click on the arrow beside "ABC" -- both entries still Polish

Dont understand what you mean with these? OK and ABC is from where?

-Preferences > Hyphenator settings -- default language still Polish after the switch

Wont change.

-I can't find the Scripter Settings in 1.3 anymore (where are they?), so I haven't turned on and checked the Macro menu.

Gone, the macro manager stuff isnt in 1.3 yet, and may or may not be added.
(0004713)
mhanski (developer)
2005-05-19 15:17

please don't forget to turn and check the Macro menu -- I didn't know, how to do it in 1.3.

BTW, this is really a great feature, I like it very much, great improvement of usability - I will put it on wiki asap :)
(0004714)
mhanski (developer)
2005-05-19 15:27

-Main menu > click on the arrow beside "OK" -- all entries are Polish
-Main menu > click on the arrow beside "ABC" -- both entries still Polish

Dont understand what you mean with these? OK and ABC is from where?

Sorry, it wasn't the main menu, but the tool palette below it -- these are both pull down menus, the right to [OK] icon contains PDF form elements (text field, list, etc.), the second left to it beside the [ABC] icon for creating links (symbolic link, etc.)
(0004715)
cbradney (administrator)
2005-05-19 15:36

Ok grab CVS. Console title changes now, the Character/Znak submenu changes too.
(0004716)
mhanski (developer)
2005-05-19 18:07

Only the two pull down menus beside [OK] and [ABC] to do yet (see the 2 last screen shots), the rest is OK
(0004717)
cbradney (administrator)
2005-05-19 18:35

Try now :)
(0004722)
mhanski (developer)
2005-05-19 21:00

Now it's done :)
(0004723)
cbradney (administrator)
2005-05-19 21:18

Cool :)

I know of a couple of other places to do. For next week.
(0004754)
cbradney (administrator)
2005-05-22 23:05

Updated it today to translate the plugin names in Prefs too.
(0004767)
cbradney (administrator)
2005-05-24 20:16

Allowing the tooltips and text to change for the text alignment and text style selectors on mpalette is done now.
(0004778)
mhanski (developer)
2005-05-25 18:17

Everything you've mentioned, works ok. I've been trying to catch up with my Polish ts file, to test it more toroughly :)
(0004783)
cbradney (administrator)
2005-05-26 13:31

Resolving this. For any others we can have a new bug. It is pretty much covered now if the translation file is up to date.

- Issue History
Date Modified Username Field Change
2004-10-01 22:44 mhanski New Issue
2004-10-01 22:44 mhanski File Added: skype_language_selection.png
2004-10-01 23:09 cbradney Product Version => 1.3
2004-10-21 18:22 cbradney Note Added: 0002744
2004-10-21 19:05 subik Note Added: 0002745
2004-10-21 19:15 cbradney Note Added: 0002747
2004-10-22 08:36 cbradney Note Added: 0002754
2004-10-22 10:25 mhanski Note Added: 0002755
2004-10-22 13:07 cbradney Status new => assigned
2004-10-22 13:07 cbradney Assigned To => cbradney
2004-10-22 17:38 mhanski Note Edited: 0002755
2005-05-10 22:37 cbradney Note Added: 0004574
2005-05-11 16:47 louisdesjardins Note Added: 0004581
2005-05-11 21:03 cbradney Note Added: 0004585
2005-05-14 19:43 mhanski File Added: germ_pol1.png
2005-05-14 19:44 mhanski File Added: germ_brit1.png
2005-05-14 19:49 mhanski Note Added: 0004627
2005-05-14 19:49 cbradney Note Added: 0004628
2005-05-14 19:52 cbradney Note Added: 0004629
2005-05-14 19:58 mhanski Note Added: 0004630
2005-05-14 22:45 mhanski Note Added: 0004632
2005-05-15 23:57 cbradney Note Added: 0004659
2005-05-16 19:42 mhanski File Added: file_pl2en.png
2005-05-16 19:42 mhanski File Added: extras_pl2en.png
2005-05-16 19:42 mhanski File Added: script_pl2en.png
2005-05-16 19:43 mhanski File Added: help_pl2en.png
2005-05-16 19:47 mhanski Note Added: 0004673
2005-05-17 12:43 cbradney Note Added: 0004689
2005-05-17 20:28 mhanski Note Added: 0004696
2005-05-17 20:29 mhanski Note Edited: 0004696
2005-05-17 23:08 cbradney Note Added: 0004698
2005-05-18 12:30 cbradney Note Added: 0004703
2005-05-18 20:15 mhanski Note Added: 0004705
2005-05-18 20:16 mhanski Note Edited: 0004705
2005-05-19 14:46 cbradney Note Added: 0004709
2005-05-19 14:56 mhanski Note Added: 0004710
2005-05-19 15:04 cbradney Note Added: 0004711
2005-05-19 15:12 cbradney Note Added: 0004712
2005-05-19 15:17 mhanski Note Added: 0004713
2005-05-19 15:27 mhanski Note Added: 0004714
2005-05-19 15:36 cbradney Note Added: 0004715
2005-05-19 18:04 mhanski File Added: form_fields.png
2005-05-19 18:04 mhanski File Added: links.png
2005-05-19 18:07 mhanski Note Added: 0004716
2005-05-19 18:35 cbradney Note Added: 0004717
2005-05-19 21:00 mhanski Note Added: 0004722
2005-05-19 21:18 cbradney Note Added: 0004723
2005-05-22 23:05 cbradney Note Added: 0004754
2005-05-24 20:16 cbradney Note Added: 0004767
2005-05-25 18:17 mhanski Note Added: 0004778
2005-05-26 13:31 cbradney Status assigned => resolved
2005-05-26 13:31 cbradney Fixed in Version => 1.3.0cvs
2005-05-26 13:31 cbradney Resolution open => fixed
2005-05-26 13:31 cbradney Note Added: 0004783
2005-05-29 19:01 cbradney Status resolved => closed
2006-05-15 20:19 christoph_s Relationship added child of 0003821



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker