Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011768ScribusShape Drawingpublic13-Oct-06 14:2413-Dec-30 08:01
ReporterJLuc 
Assigned Tofschmid 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0011768: Arc selection frame in case of cheese piece
DescriptionInsert Arc tool enables to insert part-of-disk shapes and its later possible to change the angles

Originaly the shape is an allmost full circle, but its possible to specify angles and make it looks like a cheese piece or a cake piece. In such a case,
the selection frame is
- of the right size : half the dimensions of the whole disk
- at the wrong place : even if the cheese cake is not on the top left part of the original disk, this is the place where the selection frame is placed.

See attached image.
TagsNo tags attached.
Attached Filesjpeg file icon Sélection_004.jpeg [^] (18,587 bytes) 13-Oct-06 14:25


jpeg file icon saved cheese.jpeg [^] (29,794 bytes) 13-Oct-06 15:10


jpeg file icon reloaded cheese.jpeg [^] (14,287 bytes) 13-Oct-06 15:10

- Relationships

-  Notes
(0030678)
JLuc (updater)
13-Oct-06 14:34
edited on: 13-Oct-06 14:47

I dont manage to reproduce with the UI but it can be reproduced using the multiple duplicate tool : ask "no gap" and a 30° rotation and you'll see the selection frame of the duped objects is outside the cheese piece.
Note that Transform tool does NOT have this issue, only the multiple duplicate tool.

I have had several other issues :
- a crash
- weird relationship between action requested through moving blue anchor points and result of action (for example : with an end-of-arc point at 360°, clicking on the other end-of-arc point moved it from one side of the horizontal line to the symetrical point on the other side)
- another crash, whose gdb backtrace i include here :

(gdb) run
Starting program: /usr/bin/scribus-trunk
warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7ffff7ffa000
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffdfb26700 (LWP 10098)]
[New Thread 0x7fffdf325700 (LWP 10099)]
[New Thread 0x7fffddeb4700 (LWP 10100)]
"fr_FR.UTF-8"
[New Thread 0x7fffcfc67700 (LWP 10103)]
[New Thread 0x7fffbeac5700 (LWP 10109)]
[Thread 0x7fffbeac5700 (LWP 10109) exited]
[New Thread 0x7fffbeac5700 (LWP 10111)]
[New Thread 0x7fffb48e1700 (LWP 10114)]
[Thread 0x7fffbeac5700 (LWP 10111) exited]
[Thread 0x7fffb48e1700 (LWP 10114) exited]
[Thread 0x7fffddeb4700 (LWP 10100) exited]
ASSERT failure in QVector<T>::at: "index out of range", file /usr/include/qt4/QtCore/qvector.h, line 351

Program received signal SIGABRT, Aborted.
0x00007ffff0bec425 in raise () from /lib/x86_64-linux-gnu/libc.so.6
(gdb) bt
#0 0x00007ffff0bec425 in raise () from /lib/x86_64-linux-gnu/libc.so.6
0000001 0x00007ffff0befb8b in abort () from /lib/x86_64-linux-gnu/libc.so.6
0000002 0x00007ffff43a850b in qt_message_output(QtMsgType, char const*) ()
   from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000003 0x00007ffff43a88bf in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000004 0x00007ffff43a8a64 in qFatal(char const*, ...) ()
   from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000005 0x000000000082b1e1 in QVector<FPoint>::at(int) const ()
0000006 0x00000000009005cc in FPointArray::pointQF(int) const ()
0000007 0x0000000000869296 in CanvasMode_EditArc::applyValues(double, double, double, double) ()
0000008 0x00000000007857e4 in ?? ()
0000009 0x00007ffff44c6281 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000010 0x000000000079dc7b in ArcVectorDialog::NewVectors(double, double, double, double) ()
0000011 0x0000000000df8f08 in ArcVectorDialog::changeVectors() ()
0000012 0x000000000079da6d in ?? ()
0000013 0x00007ffff44c6281 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000014 0x00007ffff55f8300 in QDoubleSpinBox::valueChanged(double) ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000015 0x00007ffff53c7d97 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
---Type <return> to continue, or q <return> to quit---
0000016 0x00007ffff5338b9e in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000017 0x00007ffff533a7bb in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000018 0x00007ffff533a921 in QAbstractSpinBox::focusOutEvent(QFocusEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000019 0x00007ffff4fb3dfd in QWidget::event(QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000020 0x00007ffff4f63894 in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000021 0x00007ffff4f68713 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000022 0x00007ffff44b1e9c in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000023 0x00007ffff4f620ae in QApplicationPrivate::setFocusWidget(QWidget*, Qt::FocusReason) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000024 0x00007ffff4fa6ef1 in QWidget::setFocus(Qt::FocusReason) ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000025 0x00007ffff4fa71d1 in QWidget::focusNextPrevChild(bool) ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000026 0x00007ffff4fb4bf6 in QWidget::event(QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000027 0x00007ffff4f63894 in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000028 0x00007ffff4f68dd5 in QApplication::notify(QObject*, QEvent*) ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000029 0x00007ffff44b1e9c in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000030 0x00007ffff5007c49 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000031 0x00007ffff50080bb in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000032 0x00007ffff4fe2637 in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000033 0x00007ffff500c0d2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000034 0x00007fffee1e9d13 in g_main_context_dispatch ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000035 0x00007fffee1ea060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000036 0x00007fffee1ea124 in g_main_context_iteration ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
0000037 0x00007ffff44e13bf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000038 0x00007ffff500bd5e in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
0000039 0x00007ffff44b0c82 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000040 0x00007ffff44b0ed7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000041 0x00007ffff44b5f67 in QCoreApplication::exec() ()
   from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
0000042 0x00000000011b6f0b in mainApp(int, char**) ()
---Type <return> to continue, or q <return> to quit---
0000043 0x00000000011b6e98 in main ()
(gdb)

(0030679)
JLuc (updater)
13-Oct-06 14:39
edited on: 13-Oct-06 14:41

sometime, moving a point moves both points
clicking on a point moves it in some mysterious way (and the other too sometime)

globaly this tool is not ready for use, as it is now, except for simple shapes that dont need to be edited

(0030680)
JLuc (updater)
13-Oct-06 15:09
edited on: 13-Oct-06 15:17

Worse is : saving and restoring is bad. See the 2 documents : "saved cheese" and "reopened cheese"
Document was created using the multiple transform rotation

Its difficult to create the desired shape because the transform tool dont seem to be able to rotate around the center of the cheese - with such a small piece at least - + the center of the supposed-to-be duplicate objects cannot be aligned well using the "Space and Align" palette (they seem to have different sizes ???)

11 warnings on the terminal :
QVariantMap DBusMenuExporterDBus::getProperties(int, const QStringList&) const: Condition failed: action

(0030963)
JLuc (updater)
13-Dec-29 20:18

Tested ok : these bugs are fixed.

- Issue History
Date Modified Username Field Change
13-Oct-06 14:24 JLuc New Issue
13-Oct-06 14:25 JLuc File Added: Sélection_004.jpeg
13-Oct-06 14:34 JLuc Note Added: 0030678
13-Oct-06 14:39 JLuc Note Added: 0030679
13-Oct-06 14:41 JLuc Note Edited: 0030679 View Revisions
13-Oct-06 14:47 JLuc Note Edited: 0030678 View Revisions
13-Oct-06 14:59 jghali Target Version => 1.5.0
13-Oct-06 15:09 JLuc Note Added: 0030680
13-Oct-06 15:10 JLuc File Added: saved cheese.jpeg
13-Oct-06 15:10 JLuc File Added: reloaded cheese.jpeg
13-Oct-06 15:17 JLuc Note Edited: 0030680 View Revisions
13-Dec-25 13:05 fschmid Status new => resolved
13-Dec-25 13:05 fschmid Fixed in Version => 1.5.0svn
13-Dec-25 13:05 fschmid Resolution open => fixed
13-Dec-25 13:05 fschmid Assigned To => fschmid
13-Dec-29 20:18 JLuc Note Added: 0030963
13-Dec-30 08:01 christoph_s Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker