Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012009ScribusGeneralpublic2014-01-24 13:332015-02-21 14:38
ReporterJLuc 
Assigned Tocbradney 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.5.0svn 
Target VersionFixed in Version1.5.0svn 
Summary0012009: Preferences > Paths > Documents should have immediate effect
DescriptionWhen user changes Preferences > Paths > Documents , nothing happens immediately.
User needs to restart Scribus first for the change to be applied.
That's not the way it should behave.

Scribus UI (and all UIs) usually propose options that take place once "Ok" is pressed. This dialog should behave as all other do.
Steps To Reproduce0) Start Scribus
1) Go to: File > Preferences... > Paths
2) Change "Documents" path and click OK
3) Go to: File > Open...
The old path previously set will be used.

4) Restart Scribus
5) Go to: File > Open...
The new path will be used.
Additional InformationScribus 1.5.0.svn (19357)
TagsNo tags attached.
PatchNo
Attached Files

- Relationships

-  Notes
(0031188)
fschmid (administrator)
2014-01-25 08:54

Can't reproduce here, Open Dialog always uses the path that was set in Preferences.
(0031195)
FirasH (developer)
2014-01-26 00:41

I also can't reproduce this issue. After changing the Documents Path under Preferences, restart Scribus and File > Open will show the Path you've selected.
(0032866)
FirasH (developer)
2014-07-21 07:02

JLuc can you re-test and verify if this is still reproducible? Thanks.
(0032881)
JLuc (updater)
2014-07-21 13:26

I tested and here is my answer : It seems that it requires to restart scribus for this option to be taken into account.
So the bug is not that it doesnt work, it's that its not applied when user validates the change.
(0032882)
FirasH (developer)
2014-07-21 17:31

Updated the report.
(0032922)
cbradney (administrator)
2014-07-22 22:56

QString prefsDocDir(prefsManager->documentDir());
    if (!prefsDocDir.isEmpty())
        docDir = docContext->get("docsopen", prefsDocDir);
    else
        docDir = docContext->get("docsopen", ".");

So.. the reason for this is that Scribus remembers, in the docsopen context of preferences, where you open previous files in the current working session. We'd either have to get rid of that session based memory, or reset it when Preferences are changed.
(0034541)
cbradney (administrator)
2015-02-19 20:02

No bug as such... discuss and suggest or close this bug please.
(0034542)
JLuc (updater)
2015-02-19 20:29

As you wrote in your previous comment : "get rid of that session based memory, or reset it when Preferences are changed." seems the right way to go.

I dont understand your last comment.
Do you mean the bug should be relabelled as "path change should apply immediately once user has pressed 'change' button" ? or less friendly "scribus should warn that the user will have to close scribus in order the requested change to really happen ?" ?

In case it helps i changed the bug text and title.
(0034548)
cbradney (administrator)
2015-02-20 17:26

r19848
(0034555)
Kunda (manager)
2015-02-21 14:38

Fixed (OSX 10.9.5 r19849 Qt5.4). Thanks Craig!

- Issue History
Date Modified Username Field Change
2014-01-24 13:33 JLuc New Issue
2014-01-25 08:54 fschmid Note Added: 0031188
2014-01-26 00:41 FirasH Note Added: 0031195
2014-07-21 07:02 FirasH Note Added: 0032866
2014-07-21 07:02 FirasH Status new => feedback
2014-07-21 13:26 JLuc Note Added: 0032881
2014-07-21 13:26 JLuc Status feedback => new
2014-07-21 17:31 FirasH Note Added: 0032882
2014-07-21 17:31 FirasH Reproducibility have not tried => always
2014-07-21 17:31 FirasH Status new => confirmed
2014-07-21 17:31 FirasH OS ubuntu 13.10 =>
2014-07-21 17:31 FirasH Summary "Path to documents" preference not used for File Open => Preferences > Paths > Documents needs Scribus restart to be applied
2014-07-21 17:31 FirasH Description Updated View Revisions
2014-07-21 17:31 FirasH Steps to Reproduce Updated View Revisions
2014-07-21 17:31 FirasH Additional Information Updated View Revisions
2014-07-22 22:56 cbradney Note Added: 0032922
2014-07-24 21:08 cbradney Assigned To => cbradney
2014-07-24 21:08 cbradney Status confirmed => feedback
2014-08-06 16:06 JLuc Status feedback => confirmed
2015-02-19 20:02 cbradney Note Added: 0034541
2015-02-19 20:28 JLuc Patch => No
2015-02-19 20:28 JLuc Summary Preferences > Paths > Documents needs Scribus restart to be applied => Preferences > Paths > Documents should have immediate effect
2015-02-19 20:28 JLuc Description Updated View Revisions
2015-02-19 20:29 JLuc Note Added: 0034542
2015-02-20 17:26 cbradney Status confirmed => resolved
2015-02-20 17:26 cbradney Fixed in Version => 1.5.0svn
2015-02-20 17:26 cbradney Resolution open => fixed
2015-02-20 17:26 cbradney Note Added: 0034548
2015-02-21 14:38 Kunda Note Added: 0034555
2015-02-21 14:38 Kunda Status resolved => closed



Copyright © 2000 - 2015 MantisBT Team
Powered by Mantis Bugtracker