Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012251ScribusUndo/Redopublic2014-04-21 21:052015-02-27 11:37
ReporterFirasH 
Assigned Tocbradney 
PrioritynormalSeverityblockReproducibilityalways
StatusassignedResolutionreopened 
Platformx86_64OSopenSUSEOS Version13.1
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version 
Summary0012251: Editing Inline Items crashes Scribus if Undo has to delete a Page
DescriptionEditing Inline Items crashes Scribus if Undo has to delete a Page.
Steps To Reproduce0) Create a new document (single page) and make sure Windows > Inline Frames/Action History are opened
1) Go to Page > Insert... (1 Page at End, click OK)
2) Move to the new Page and add a Text Frame (works with all items)
3) Select the text Frame and right-click > Send to > Inline Items
4) Double-click on the Text Frame just Added in "Inline Frames"
5) Undo until "Initial State"

Scribus crashes due to Signal 6 (after trying to undo "Document - Add Page")
Additional InformationScribus 1.5.0 SVN (19075)

Probably related to 0012241

ASSERT failure in QList<T>::at: "index out of range", file /home/.../Qt/5.2.1/gcc_64/include/QtCore/qlist.h, line 472

Program received signal SIGABRT, Aborted.
0x00007fffef778849 in raise () from /lib64/libc.so.6
(gdb) bt
#0 0x00007fffef778849 in raise () from /lib64/libc.so.6
0000001 0x00007fffef779cd8 in abort () from /lib64/libc.so.6
0000002 0x00007ffff747b10e in QMessageLogger::fatal(char const*, ...) const ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000003 0x00007ffff7477e14 in qt_assert_x(char const*, char const*, char const*, int) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000004 0x000000000084016b in QList<ScPage*>::at (this=0x3358de0, i=1) at /home/.../Qt/5.2.1/gcc_64/include/QtCore/qlist.h:472
0000005 0x0000000000d0b668 in ScribusDoc::deletePage (this=0x3358470, pageNumber=0)
    at /home/.../Scribus/scribus/scribusdoc.cpp:2785
0000006 0x0000000000cba173 in ScribusMainWindow::deletePage (this=0x19b01d0, from=1, to=1)
    at /home/.../Scribus/scribus/scribus.cpp:6901
0000007 0x0000000000cc8530 in ScribusMainWindow::restoreAddPage (this=0x19b01d0, state=0x3609e90, isUndo=true)
    at /home/.../Scribus/scribus/scribus.cpp:8615
0000008 0x0000000000cc7791 in ScribusMainWindow::restore (this=0x19b01d0, state=0x3609e90, isUndo=true)
    at /home/.../Scribus/scribus/scribus.cpp:8505
0000009 0x0000000000de3930 in UndoState::undo (this=0x3609e90) at /home/.../Scribus/scribus/undostate.cpp:73
0000010 0x0000000000dd47e2 in TransactionState::undo (this=0x31d73c0)
    at /home/.../Scribus/scribus/undomanager.cpp:808
0000011 0x0000000000de2a6b in UndoStack::undo (this=0x35e1ca0, steps=1, objectId=-1)
    at /home/.../Scribus/scribus/undostack.cpp:80
0000012 0x0000000000dd31b1 in UndoManager::undo (this=0x1be2f00, steps=1)
    at /home/.../Scribus/scribus/undomanager.cpp:553
0000013 0x0000000000796eda in UndoManager::qt_static_metacall (_o=0x1be2f00, _c=QMetaObject::InvokeMetaMethod, _id=12,
    _a=0x7fffffffc330) at /home/.../Scribus/build/scribus/moc_undomanager.cpp:143
0000014 0x00007ffff769d6b1 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000015 0x000000000078bc5c in ScrAction::triggeredData (this=0x1c00c40, _t1=1)
    at /home/.../Scribus/build/scribus/moc_scraction.cpp:229
0000016 0x0000000000c6b584 in ScrAction::triggeredToTriggeredData (this=0x1c00c40)
    at /home/.../Scribus/scribus/scraction.cpp:178
0000017 0x000000000078b831 in ScrAction::qt_static_metacall (_o=0x1c00c40, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0x7fffffffc5a0)
    at /home/.../Scribus/build/scribus/moc_scraction.cpp:114
0000018 0x00007ffff769d6b1 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000019 0x00007ffff6ce0e92 in QAction::triggered(bool) () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000020 0x00007ffff6ce2cc7 in QAction::activate(QAction::ActionEvent) () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000021 0x00007ffff6dec125 in ?? () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000022 0x00007ffff6dec3e4 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000023 0x00007ffff6eae9fa in QToolButton::mouseReleaseEvent(QMouseEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000024 0x00007ffff6d24077 in QWidget::event(QEvent*) () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000025 0x00007ffff6eaf890 in QToolButton::event(QEvent*) () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000026 0x00007ffff6cec0f4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000027 0x00007ffff6cef4d6 in QApplication::notify(QObject*, QEvent*) () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000028 0x00007ffff7674734 in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000029 0x00007ffff6cee54a in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000030 0x00007ffff6d43b65 in ?? () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000031 0x00007ffff6d45f98 in ?? () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000032 0x00007ffff6cec0f4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000033 0x00007ffff6cef6ae in QApplication::notify(QObject*, QEvent*) () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Widgets.so.5
0000034 0x00007ffff7674734 in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000035 0x00007ffff6608c21 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Gui.so.5
0000036 0x00007ffff66094a5 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Gui.so.5
0000037 0x00007ffff65f0ba8 in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Gui.so.5
0000038 0x00007fffe58231b0 in ?? () from /home/.../Qt/5.2.1/gcc_64/plugins/platforms/libqxcb.so
0000039 0x00007fffed058316 in g_main_dispatch (context=0x7fffe0001740) at gmain.c:3066
0000040 g_main_context_dispatch (context=context@entry=0x7fffe0001740) at gmain.c:3642
0000041 0x00007fffed058668 in g_main_context_iterate (context=context@entry=0x7fffe0001740, block=block@entry=1,
    dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3713
0000042 0x00007fffed05870c in g_main_context_iteration (context=0x7fffe0001740, may_block=1) at gmain.c:3774
0000043 0x00007ffff76c5374 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000044 0x00007ffff76734ab in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000045 0x00007ffff767753e in QCoreApplication::exec() () from /home/.../Qt/5.2.1/gcc_64/lib/libQt5Core.so.5
0000046 0x000000000123361c in mainApp (argc=1, argv=0x7fffffffdd78) at /home/.../Scribus/scribus/main_nix.cpp:86
0000047 0x00000000012335ac in main (argc=1, argv=0x7fffffffdd78) at /home/.../Scribus/scribus/main_nix.cpp:54
TagsNo tags attached.
Patch
Attached Files

- Relationships
related to 0012356closedcbradney Undo/Redo crashes Scribus while editing master page 
child of 0012500acknowledged Metabug: Undo/Redo (1.5.0.svn) 

-  Notes
(0032051)
FirasH (developer)
2014-06-07 21:08

Probably related to 0012356.
(0032055)
FirasH (developer)
2014-06-09 15:14

The issue is still present with Scribus 1.5.0 SVN (19191).
(0032090)
FirasH (developer)
2014-06-12 10:43

Re-opeining as not to forget about this issue.
(0032106)
cbradney (administrator)
2014-06-12 20:10

Wasn't this a duplicate?
(0032107)
FirasH (developer)
2014-06-12 20:15

No, not a duplicate.
I linked this issue to 0012356 as the crash was always caused by Undo/Redo deleting a page.
(0032438)
Kunda (manager)
2014-07-03 17:02

Confirmed on OSX 10.8.5 1.5svn r19309
(0033498)
Kunda (manager)
2014-09-05 00:35

Crash is still present on 1.5.0svn r19477
(0034623)
JLuc (updater)
2015-02-27 11:37

Issue is still there.

The displays remains in inline edit mode even after the edited item is destroyed after user has undone its creation.

Solutions could be :

either a) record "enter inline edit mode" as an action. Undoing would bring scribus back in "normal edit mode".
As a user, i feel that a) is the expected behaviour, because it feels logical that the viewport follows the selected itmes and the actions, even during undo.

or b) when undoing an object's creation (or deleting an object in whatever way), do test whether this object is currently being edited in inline edit mode, and in such a case, exit this mode first.

- Issue History
Date Modified Username Field Change
2014-04-21 21:05 FirasH New Issue
2014-06-07 21:08 FirasH Note Added: 0032051
2014-06-09 12:23 cbradney Relationship added duplicate of 0012356
2014-06-09 12:23 cbradney Status new => resolved
2014-06-09 12:23 cbradney Resolution open => duplicate
2014-06-09 12:23 cbradney Assigned To => cbradney
2014-06-09 15:14 FirasH Note Added: 0032055
2014-06-12 10:43 FirasH Note Added: 0032090
2014-06-12 10:43 FirasH Status resolved => feedback
2014-06-12 10:43 FirasH Resolution duplicate => reopened
2014-06-12 20:10 cbradney Note Added: 0032106
2014-06-12 20:15 FirasH Note Added: 0032107
2014-06-12 20:15 FirasH Status feedback => assigned
2014-07-03 17:02 Kunda Note Added: 0032438
2014-07-03 17:03 Kunda Target Version => 1.5.0
2014-07-09 03:21 FirasH Relationship added child of 0012500
2014-09-05 00:35 Kunda Note Added: 0033498
2014-09-11 04:25 Kunda Severity crash => block
2014-10-30 14:34 Kunda Sticky Issue No => Yes
2014-12-21 15:23 FirasH Relationship deleted 0012356
2014-12-21 15:23 FirasH Relationship added related to 0012356
2015-02-27 11:37 JLuc Note Added: 0034623



Copyright © 2000 - 2015 MantisBT Team
Powered by Mantis Bugtracker