Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012309ScribusUndo/Redopublic2014-05-14 19:002015-03-17 20:58
ReporterFirasH 
Assigned Tocbradney 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSopenSUSEOS Version13.1
Product Version1.4.4.svn 
Target Version1.5.0Fixed in Version1.4.6.svn 
Summary0012309: "Arrange Pages" changes to pages arrangement might lead to wrong behavior of Undo/Redo
DescriptionChanging the last page arrangement of a document in "Arrange Pages" leads to a wrong behavior of Undo/Redo following the described steps.
Steps To Reproduce0) Create a new document with 2 pages and make sure Windows > "Action History" and "Arrange Pages" are opened
1) Add a colored Shape on the first page so that you can recognize the behavior of the page
2) Go to "Arrange Pages" > Document Pages: select the last page (2) and drag it under the icon of the last page (2) so that a darker blue rectangle is shown.
Basically: drag the last page to the end of the document (does not make sense because the last page is already the last one).

You can notice that each time you repeat step 2 a new entry "Document-X - Move Page" is being added.

3) Zoom out so that you can see both pages
4) Undo/Redo

The pages are swapped with Undo, but Redo does not affect the page arrangement.

The last page should not be allowed to being dragged to the last position in arrangement.

This can be reproduced even with 1 page, but the result is simply a list of useless entries in "Action History".
Additional InformationIssue present on:
Scribus 1.4.4 SVN (19119)
Scribus 1.5.0 SVN (19120)
TagsNo tags attached.
Patch
Attached Files

- Relationships

-  Notes
(0031919)
FirasH (developer)
2014-05-24 15:07

Probably my description wasn't clear, so here's a step by step video:
https://www.dropbox.com/s/rxo84vg92f4hlk4/12309.mp4 [^]

I'd raise the priority of this bug as it affects also 1.4.4 which should be released very soon.
(0031920)
christoph_s (administrator)
2014-05-25 08:22

This is really a corner case that shouldn't hold back the release of 1.4.4.
(0034685)
Kunda (manager)
2015-03-12 01:01

I can't drag pages in the 'Arrange Pages' window :(
Using osx 10.9.5 r19910 Qt5.4.1
(0034688)
FirasH (developer)
2015-03-12 19:04

Thanks cbradney!
Fixed in 1.4.6.svn (19909) and 1.5.0.svn (19911).

- Issue History
Date Modified Username Field Change
2014-05-14 19:00 FirasH New Issue
2014-05-24 15:07 FirasH Note Added: 0031919
2014-05-25 08:22 christoph_s Note Added: 0031920
2014-05-25 08:22 christoph_s Status new => confirmed
2014-05-25 08:22 christoph_s Target Version => 1.5.0
2015-02-12 02:03 Kunda Sticky Issue No => Yes
2015-03-11 20:29 cbradney Status confirmed => resolved
2015-03-11 20:29 cbradney Fixed in Version => 1.4.6.svn
2015-03-11 20:29 cbradney Resolution open => fixed
2015-03-11 20:29 cbradney Assigned To => cbradney
2015-03-12 01:01 Kunda Note Added: 0034685
2015-03-12 19:04 FirasH Note Added: 0034688
2015-03-12 19:04 FirasH Status resolved => closed
2015-03-17 20:58 Kunda Sticky Issue Yes => No



Copyright © 2000 - 2015 MantisBT Team
Powered by Mantis Bugtracker