Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012529ScribusUndo/Redopublic2014-07-16 17:382014-07-17 00:38
ReporterFirasH 
Assigned Tojghali 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSopenSUSEOS Version13.1
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0012529: Changing Document Layout/Master Pages might lead to crash (steps included)
DescriptionChanging Document Layout/Master Pages might lead to crash (steps included).
Steps To Reproduce0) Create a new document as Single Page and make sure Windows > Arrange Pages is opened
1) Go to: File > Document Setup... > Document Setup > Layout > 3-Fold, then click OK
2) Go to: Page > Insert... and add 4 pages
3) Go to: Edit > Master Pages...
4) Create a new Master Page with "Middle" as destination page
5) Select page 3 and Page > Apply Master Page... > apply the "Middle" Master Page
6) Go to: File > Document Setup... > Document Setup > Layout > Single Page, then click OK
7) Undo until the Undo button is greyed out
8) Redo until the Redo button is greyed out: pages are not added but in Windows > Arrange Pages they are listed
9) Double-click on page 3 in Arrange Pages

Scribus crashes due to Signal 6

To avoid the crash, after Step eight click on Close and all the pages will show up.
Additional InformationScribus 1.5.0.svn (19347)


ASSERT failure in QList<T>::at: "index out of range", file /home/.../Qt/5.3/gcc_64/include/QtCore/qlist.h, line 479

Program received signal SIGABRT, Aborted.
0x00007fffef509849 in raise () from /lib64/libc.so.6
(gdb) bt
 0 0x00007fffef509849 in raise ()
   from /lib64/libc.so.6
 1 0x00007fffef50acd8 in abort ()
   from /lib64/libc.so.6
 2 0x00007ffff74168ae in QMessageLogger::fatal(char const*, ...) const ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 3 0x00007ffff7411d74 in qt_assert_x(char const*, char const*, char const*, int) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 4 0x000000000084390b in QList<ScPage*>::at (this=0x33d3820, i=2)
    at /home/.../Qt/5.3/gcc_64/include/QtCore/qlist.h:479
 5 0x0000000000da83df in ScribusView::GotoPage (this=0x33f5860, Seite=2)
    at /home/.../Scribus/scribus/scribusview.cpp:2378
 6 0x0000000000cc42d1 in ScribusMainWindow::selectPagesFromOutlines (this=0x19c4030, Page=2)
    at /home/.../Scribus/scribus/scribus.cpp:7304
 7 0x0000000000790265 in ScribusMainWindow::qt_static_metacall (_o=0x19c4030, _c=QMetaObject::InvokeMetaMethod, _id=170,
    _a=0x7fffffffc0a0) at /home/.../Scribus/build/scribus/moc_scribus.cpp:1130
 8 0x00007ffff768a7b1 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 9 0x00000000007b13aa in PagePalette_Pages::gotoPage (this=0x2b29240, _t1=2)
    at /home/.../Scribus/build/scribus/ui/moc_pagepalette_pages.cpp:220
 10 0x0000000000fa6295 in PagePalette_Pages::pageView_gotoPage (this=0x2b29240, r=5, c=0, b=1)
    at /home/.../Scribus/scribus/ui/pagepalette_pages.cpp:156
 11 0x00000000007b10e5 in PagePalette_Pages::qt_static_metacall (_o=0x2b29240, _c=QMetaObject::InvokeMetaMethod, _id=15,
    _a=0x7fffffffc300) at /home/.../Scribus/build/scribus/ui/moc_pagepalette_pages.cpp:150
 12 0x00007ffff768a7b1 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 13 0x00000000007b22b4 in SeView::Click (this=0x2b2f050, _t1=5, _t2=0, _t3=1)
    at /home/.../Scribus/build/scribus/ui/moc_pagepalette_widgets.cpp:320
 14 0x0000000000faf429 in SeView::mouseReleaseEvent (this=0x2b2f050, e=0x7fffffffcde0)
    at /home/.../Scribus/scribus/ui/pagepalette_widgets.cpp:169
 15 0x00007ffff6cc5c27 in QWidget::event(QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 16 0x00007ffff6dd0b46 in QFrame::event(QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 17 0x00007ffff6edeb4b in QAbstractItemView::viewportEvent(QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 18 0x00007ffff7659173 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 19 0x00007ffff6c8da5f in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 20 0x00007ffff6c90e8c in QApplication::notify(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 21 0x00007ffff7658f04 in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 22 0x00007ffff6c8fffa in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 23 0x00007ffff6ce5e87 in ?? ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 24 0x00007ffff6ce89d8 in ?? ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 25 0x00007ffff6c8da94 in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 26 0x00007ffff6c910b6 in QApplication::notify(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
 27 0x00007ffff7658f04 in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 28 0x00007ffff650c537 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Gui.so.5
 29 0x00007ffff650cf75 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Gui.so.5
 30 0x00007ffff64f2208 in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Gui.so.5
 31 0x00007fffe548c460 in ?? ()
   from /home/.../Qt/5.3/gcc_64/plugins/platforms/libqxcb.so
 32 0x00007fffecddd316 in g_main_dispatch (context=0x7fffe0001740)
    at gmain.c:3066
 33 g_main_context_dispatch (context=context@entry=0x7fffe0001740)
    at gmain.c:3642
 34 0x00007fffecddd668 in g_main_context_iterate (context=context@entry=0x7fffe0001740, block=block@entry=1,
    dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3713
 35 0x00007fffecddd70c in g_main_context_iteration (context=0x7fffe0001740, may_block=1)
    at gmain.c:3774
 36 0x00007ffff76b3574 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 37 0x00007ffff765711b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 38 0x00007ffff765bfe5 in QCoreApplication::exec() ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
 39 0x0000000001240a34 in mainApp (argc=1, argv=0x7fffffffdd18)
    at /home/.../Scribus/scribus/main_nix.cpp:86
 40 0x00000000012409c4 in main (argc=1, argv=0x7fffffffdd18)
    at /home/.../Scribus/scribus/main_nix.cpp:54
TagsNo tags attached.
Patch
Attached Files

- Relationships
child of 0012500acknowledged Metabug: Undo/Redo (1.5.0.svn) 

-  Notes
(0032780)
Kunda (manager)
2014-07-16 18:16

Confirmed on OSX 10.8.5 1.5svn r19342
(0032790)
FirasH (developer)
2014-07-17 00:38

Thanks jghali!
Scribus 1.5.0.svn (19349): cannot reproduce this issue.
Closing as fixed.

- Issue History
Date Modified Username Field Change
2014-07-16 17:38 FirasH New Issue
2014-07-16 18:07 FirasH Category General => Undo/Redo
2014-07-16 18:16 Kunda Note Added: 0032780
2014-07-16 18:16 Kunda Status new => confirmed
2014-07-16 18:16 Kunda Target Version => 1.5.0
2014-07-16 20:13 FirasH Relationship added child of 0012500
2014-07-17 00:01 jghali Status confirmed => resolved
2014-07-17 00:01 jghali Fixed in Version => 1.5.0svn
2014-07-17 00:01 jghali Resolution open => fixed
2014-07-17 00:01 jghali Assigned To => jghali
2014-07-17 00:38 FirasH Note Added: 0032790
2014-07-17 00:38 FirasH Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker