Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012537ScribusGeneralpublic14-Jul-18 20:3114-Jul-19 22:16
ReporterFirasH 
Assigned Tojghali 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSFreeBSDOS Version10.0.2
Product Version1.5.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0012537: Crash clicking on "Page 1" in Windows > Outline
DescriptionCrash clicking on "Page 1" in Windows > Outline.
Steps To Reproduce0) Create a new document and make sure Windows > Outline is opened
1) Go to: Edit > Master Pages...
2) Add a new master page "New Master Page 1"
3) Exit edit master page mode (End Edit)
4) Add a Text Frame on the document Page
5) Undo 2 times, then Redo redo 2 times (buttons are greyed out)
6) Click on the entries in Windows > Outline in the following order:
     - Normal
     - New Master Page 1
     - Page 1

Scribus crashes due Signal 6
Additional InformationScribus 1.5.0.svn (19354)


ASSERT failure in QList<T>::at: "index out of range", file /usr/local/include/qt5/QtCore/qlist.h, line 472

Program received signal SIGABRT, Aborted.
[Switching to Thread 813c06400 (LWP 100774/scribus)]
0x000000080965ae1a in kill () from /lib/libc.so.7
(gdb) bt
#0 0x000000080965ae1a in kill ()
   from /lib/libc.so.7
0000001 0x0000000809659ac9 in abort ()
   from /lib/libc.so.7
0000002 0x00000008022c0169 in QMessageLogger::debug ()
   from /usr/local/lib/libQt5Core.so.5
0000003 0x00000008022c0740 in QMessageLogger::fatal ()
   from /usr/local/lib/libQt5Core.so.5
0000004 0x00000008022bd488 in qt_assert_x ()
   from /usr/local/lib/libQt5Core.so.5
0000005 0x0000000000828970 in QList<ScPage*>::at (this=0x8237e2968, i=1)
    at qlist.h:472
0000006 0x0000000000dbec1f in ScribusMainWindow::editMasterPagesEnd (
    this=0x813c09000)
    at /usr/home/.../Scribus/scribus/scribus.cpp:8369
0000007 0x0000000000dbfa1f in ScribusMainWindow::closeActiveWindowMasterPageEditor
    (this=0x813c09000)
    at /usr/home/.../Scribus/scribus/scribus.cpp:9355
0000008 0x000000000117a15a in OutlinePalette::slotSelect (this=0x822d72300,
    ite=0x822e95260)
    at /usr/home/.../Scribus/scribus/ui/outlinepalette.cpp:996
0000009 0x00000000011777da in OutlinePalette::slotMultiSelect (this=0x822d72300)
    at /usr/home/.../Scribus/scribus/ui/outlinepalette.cpp:961
0000010 0x00000000007602af in OutlinePalette::qt_static_metacall (_o=0x822d72300,
    _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x7fffffffb2f0)
    at /usr/home/.../Scribus/build/scribus/ui/moc_outlinepalette.cpp:168
0000011 0x000000080249d827 in QMetaObject::activate ()
   from /usr/local/lib/libQt5Core.so.5
0000012 0x0000000802c6bc00 in QTreeWidget::currentItemChanged ()
   from /usr/local/lib/libQt5Widgets.so.5
0000013 0x0000000802c6f0a5 in QTreeWidget::event ()
   from /usr/local/lib/libQt5Widgets.so.5
0000014 0x000000080249d827 in QMetaObject::activate ()
   from /usr/local/lib/libQt5Core.so.5
0000015 0x00000008024340ea in QItemSelectionModel::emitSelectionChanged ()
   from /usr/local/lib/libQt5Core.so.5
0000016 0x0000000802433c0d in QItemSelectionModel::select ()
   from /usr/local/lib/libQt5Core.so.5
0000017 0x0000000802c40b4e in QTreeViewPrivate::select ()
   from /usr/local/lib/libQt5Widgets.so.5
0000018 0x0000000802c40126 in QTreeView::setSelection ()
   from /usr/local/lib/libQt5Widgets.so.5
0000019 0x0000000802bff665 in QAbstractItemView::mousePressEvent ()
   from /usr/local/lib/libQt5Widgets.so.5
0000020 0x0000000802c3cc1c in QTreeView::mousePressEvent ()
   from /usr/local/lib/libQt5Widgets.so.5
0000021 0x0000000802a3226d in QWidget::event ()
   from /usr/local/lib/libQt5Widgets.so.5
0000022 0x0000000802b07337 in QFrame::event ()
   from /usr/local/lib/libQt5Widgets.so.5
0000023 0x0000000802b7fafa in QAbstractScrollArea::viewportEvent ()
   from /usr/local/lib/libQt5Widgets.so.5
0000024 0x0000000802bfef9e in QAbstractItemView::viewportEvent ()
   from /usr/local/lib/libQt5Widgets.so.5
0000025 0x0000000802c399f8 in QTreeView::viewportEvent ()
   from /usr/local/lib/libQt5Widgets.so.5
0000026 0x0000000001170f17 in OutlineWidget::viewportEvent (this=0x822d2ea90,
    event=0x7fffffffc948)
    at /usr/home/.../Scribus/scribus/ui/outlinepalette.cpp:415
0000027 0x0000000802b805f5 in QAbstractScrollArea::qt_metacall ()
   from /usr/local/lib/libQt5Widgets.so.5
0000028 0x000000080246ddac in QCoreApplicationPrivate::sendThroughObjectEventFilters ()
   from /usr/local/lib/libQt5Core.so.5
0000029 0x00000008029fc194 in QApplicationPrivate::notify_helper ()
   from /usr/local/lib/libQt5Widgets.so.5
0000030 0x00000008029ff018 in QApplication::notify ()
   from /usr/local/lib/libQt5Widgets.so.5
0000031 0x000000080246dac2 in QCoreApplication::notifyInternal ()
   from /usr/local/lib/libQt5Core.so.5
0000032 0x00000008029fcb45 in QApplicationPrivate::sendMouseEvent ()
   from /usr/local/lib/libQt5Widgets.so.5
0000033 0x0000000802a4eaca in QWidgetPrivate::setModal_sys ()
   from /usr/local/lib/libQt5Widgets.so.5
0000034 0x0000000802a4ddff in QWidgetPrivate::setModal_sys ()
   from /usr/local/lib/libQt5Widgets.so.5
0000035 0x00000008029fc1a7 in QApplicationPrivate::notify_helper ()
   from /usr/local/lib/libQt5Widgets.so.5
0000036 0x00000008029fec0c in QApplication::notify ()
   from /usr/local/lib/libQt5Widgets.so.5
0000037 0x000000080246dac2 in QCoreApplication::notifyInternal ()
   from /usr/local/lib/libQt5Core.so.5
0000038 0x000000080314d8f7 in QGuiApplicationPrivate::processMouseEvent ()
   from /usr/local/lib/libQt5Gui.so.5
0000039 0x000000080314cc41 in QGuiApplicationPrivate::processWindowSystemEvent ()
   from /usr/local/lib/libQt5Gui.so.5
0000040 0x000000080313db58 in QWindowSystemInterface::sendWindowSystemEvents ()
   from /usr/local/lib/libQt5Gui.so.5
0000041 0x00000008134b26f0 in qt_plugin_instance ()
   from /usr/local/lib/qt5/plugins/platforms/libqxcb.so
0000042 0x000000080b991142 in g_main_context_dispatch ()
   from /usr/local/lib/libglib-2.0.so.0
0000043 0x000000080b991497 in g_main_context_pending ()
   from /usr/local/lib/libglib-2.0.so.0
0000044 0x000000080b991524 in g_main_context_iteration ()
   from /usr/local/lib/libglib-2.0.so.0
0000045 0x00000008024bbe58 in QEventDispatcherGlib::processEvents ()
   from /usr/local/lib/libQt5Core.so.5
0000046 0x00000008134b269c in qt_plugin_instance ()
   from /usr/local/lib/qt5/plugins/platforms/libqxcb.so
0000047 0x000000080246b45e in QEventLoop::exec ()
   from /usr/local/lib/libQt5Core.so.5
0000048 0x000000080246e072 in QCoreApplication::exec ()
   from /usr/local/lib/libQt5Core.so.5
0000049 0x00000000014c027b in mainApp (argc=1, argv=0x7fffffffd3a8)
    at main_nix.cpp:86
0000050 0x00000000014c01c2 in main (argc=1, argv=0x7fffffffd3a8)
    at main_nix.cpp:54
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0032827)
Kunda (developer)
14-Jul-19 00:16

Confirmed! r19352
(0032838)
FirasH (developer)
14-Jul-19 22:16

Thanks jghali!
Scribus 1.5.0.svn (19357): cannot reproduce this issue.
Closing as fixed.

- Issue History
Date Modified Username Field Change
14-Jul-18 20:31 FirasH New Issue
14-Jul-18 22:34 FirasH Steps to Reproduce Updated View Revisions
14-Jul-19 00:16 Kunda Note Added: 0032827
14-Jul-19 00:16 Kunda Status new => confirmed
14-Jul-19 00:16 Kunda Target Version => 1.5.0
14-Jul-19 02:58 jghali Status confirmed => resolved
14-Jul-19 02:58 jghali Fixed in Version => 1.5.0svn
14-Jul-19 02:58 jghali Resolution open => fixed
14-Jul-19 02:58 jghali Assigned To => jghali
14-Jul-19 22:16 FirasH Note Added: 0032838
14-Jul-19 22:16 FirasH Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker