Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012552ScribusShape Drawingpublic14-Jul-24 01:4914-Jul-26 06:35
ReporterFirasH 
Assigned Tojghali 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSFreeBSDOS Version10.0.2
Product Version1.4.5.svn 
Target Version1.4.5Fixed in Version1.4.5.svn 
Summary0012552: Deleting a node of a Shape with 3 nodes crashes Scribus
DescriptionDeleting a node of a Shape with 3 nodes crashes Scribus.
Steps To Reproduce0) Create a new document
1) Insert a rectangular Shape
2) Double-click on the Shape (Nodes window opens)
3) Delete a node
4) Delete another node

Scribus crashes due to Signal 11
Additional Information1.4.5.svn (19364)


Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 80ac06400 (LWP 100370/scribus)]
0x00000000008c9f2d in FPointArray::point (this=0x7fffffffafa0, i=4294967295,
    x=0x7fffffffafc8, y=0x7fffffffafc0)
    at /usr/home/.../Scribus/scribus/fpointarray.cpp:142
142 *x = p->xp;
(gdb) bt
#0 0x00000000008c9f2d in FPointArray::point (this=0x7fffffffafa0,
    i=4294967295, x=0x7fffffffafc8, y=0x7fffffffafc0)
    at /usr/home/.../Scribus/scribus/fpointarray.cpp:142
0000001 0x00000000007a7137 in CanvasMode_NodeEdit::drawControls (this=0x80ac53f80,
    p=0x7fffffffb1e8)
    at /usr/home/.../Scribus/scribus/canvasmode_nodeedit.cpp:142
0000002 0x0000000000746b62 in Canvas::paintEvent (this=0x814ddc6e0,
    p=0x7fffffffb838)
    at /usr/home/.../Scribus/scribus/canvas.cpp:906
0000003 0x0000000801e85c0d in QWidget::event ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000004 0x0000000801e3945b in QApplicationPrivate::notify_helper ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000005 0x0000000801e3c307 in QApplication::notify ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000006 0x00000008030a1135 in QCoreApplication::notifyInternal ()
   from /usr/local/lib/qt4/libQtCore.so.4
0000007 0x0000000801e80d38 in QWidgetPrivate::drawWidget ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000008 0x00000008020408e3 in QWidgetPrivate::scrollRect ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000009 0x0000000801e78ac1 in QWidgetPrivate::syncBackingStore ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000010 0x0000000801e85f15 in QWidget::event ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000011 0x0000000802229ff9 in QMainWindow::event ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000012 0x0000000801e3945b in QApplicationPrivate::notify_helper ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000013 0x0000000801e3c307 in QApplication::notify ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000014 0x00000008030a1135 in QCoreApplication::notifyInternal ()
   from /usr/local/lib/qt4/libQtCore.so.4
0000015 0x000000080203dc35 in QPrinterInfo::supportedPaperSizes ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000016 0x000000080203dfff in QPrinterInfo::supportedPaperSizes ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000017 0x0000000801e8852f in QWidget::repaint ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000018 0x0000000801e885a8 in QWidget::repaint ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000019 0x00000000009298bf in Hruler::Draw (this=0x81506b1c0, where=261)
    at /usr/home/.../Scribus/scribus/hruler.cpp:852
0000020 0x0000000000ea99ba in ScribusView::eventFilter (this=0x814fc3c00,
    obj=0x814ddc6e0, event=0x7fffffffc9f0)
    at /usr/home/.../Scribus/scribus/scribusview.cpp:4787
0000021 0x00000008030a141d in QCoreApplicationPrivate::sendThroughObjectEventFilters ()
   from /usr/local/lib/qt4/libQtCore.so.4
0000022 0x0000000801e3944a in QApplicationPrivate::notify_helper ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000023 0x0000000801e3aca3 in QApplication::notify ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000024 0x00000008030a1135 in QCoreApplication::notifyInternal ()
   from /usr/local/lib/qt4/libQtCore.so.4
0000025 0x0000000801e39e7f in QApplicationPrivate::sendMouseEvent ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000026 0x0000000801eafedb in qt_try_modal ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000027 0x0000000801eae77a in QApplication::x11ProcessEvent ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000028 0x0000000801ed93c5 in QX11Info::isCompositingManagerRunning ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000029 0x00000008076d1142 in g_main_context_dispatch ()
   from /usr/local/lib/libglib-2.0.so.0
0000030 0x00000008076d1497 in g_main_context_pending ()
   from /usr/local/lib/libglib-2.0.so.0
0000031 0x00000008076d1524 in g_main_context_iteration ()
   from /usr/local/lib/libglib-2.0.so.0
0000032 0x00000008030cd6ce in QEventDispatcherGlib::processEvents ()
   from /usr/local/lib/qt4/libQtCore.so.4
0000033 0x0000000801ed908d in QX11Info::isCompositingManagerRunning ()
   from /usr/local/lib/qt4/libQtGui.so.4
0000034 0x000000080309e617 in QEventLoop::exec ()
   from /usr/local/lib/qt4/libQtCore.so.4
0000035 0x00000008030a16cd in QCoreApplication::exec ()
   from /usr/local/lib/qt4/libQtCore.so.4
0000036 0x000000000108e2cb in mainApp (argc=1, argv=0x7fffffffd6a8)
    at main_nix.cpp:84
0000037 0x000000000108e212 in main (argc=1, argv=0x7fffffffd6a8)
    at main_nix.cpp:52
TagsNo tags attached.
Attached Files

- Relationships
related to 0012249closedjghali Deleting Bezier Curve nodes crashes/freezes Scribus in determined condition 

-  Notes
(0032939)
Kunda (manager)
14-Jul-24 02:24

Cannot reproduce on OSX 10.8.5
1.5.0svn r19357
1.4.4 stable
This bug may just be platform specific
(0032940)
Kunda (manager)
14-Jul-24 02:29

Firash added a screencast: https://www.dropbox.com/s/jmxetbtyuta17mg/12552.mp4 [^]
(0032941)
FirasH (developer)
14-Jul-24 02:30

I could not reproduce this issue on openSUSE with the SAME steps, follow those instead:

0) Create a new document
1) Insert a rectangular Shape
2) Double-click on the Shape (Nodes window opens)
3) Delete a node
4) Select a node
5) Click on "Delete Nodes"

Scribus crashes due to Signal 11
(0032942)
FirasH (developer)
14-Jul-24 02:35

BSD screencast: https://www.dropbox.com/s/zww6v0a4yao2372/12552BSD.mp4 [^]
(0032972)
jghali (administrator)
14-Jul-25 00:47

I cannot reproduce this issue on Windows as I simply cannot delete any node when only 3 remains.
(0033009)
FirasH (developer)
14-Jul-26 01:39

The crash is fixed in 1.4.5.svn (19369) on openSUSE.
Need to build & test on FreeBSD to change the Status to Closed.
(0033015)
FirasH (developer)
14-Jul-26 06:35

Thanks jghali!
Fixed in 1.4.5.svn (19369).

- Issue History
Date Modified Username Field Change
14-Jul-24 01:49 FirasH New Issue
14-Jul-24 02:23 FirasH Relationship added related to 0012249
14-Jul-24 02:24 Kunda Note Added: 0032939
14-Jul-24 02:25 Kunda Target Version => 1.5.0
14-Jul-24 02:28 Kunda Target Version 1.5.0 => 1.4.5
14-Jul-24 02:29 Kunda Status new => confirmed
14-Jul-24 02:29 Kunda Note Added: 0032940
14-Jul-24 02:30 FirasH Note Added: 0032941
14-Jul-24 02:35 FirasH Note Added: 0032942
14-Jul-25 00:47 jghali Note Added: 0032972
14-Jul-26 00:37 jghali Status confirmed => resolved
14-Jul-26 00:37 jghali Fixed in Version => 1.4.5.svn
14-Jul-26 00:37 jghali Resolution open => fixed
14-Jul-26 00:37 jghali Assigned To => jghali
14-Jul-26 01:39 FirasH Note Added: 0033009
14-Jul-26 06:35 FirasH Note Added: 0033015
14-Jul-26 06:35 FirasH Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker