Mantis Issue Tracking for Scribus
· Hosting provided by / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001474ScribusImport / Exportpublic2004-12-29 21:232015-10-11 00:55
ReporterSorin Paliga 
Assigned Tofschmid 
PlatformppcOSMAC OS XOS Version10.3.7
Product Version1.3.0cvs 
Target VersionFixed in Version1.5.1svn 
Summary0001474: rtf import
DescriptionWell, at least the ppc/MAC OS X version has a problem; if not wrong, the same in Linux: the only importable format is text, which practically means to loose basic formatting like typeface.

Also, if working with diacritical marks, pre-composed or Combining Diacritical Marks (U 0300 ...) there seems to be a major problem. The best guess I had was to save as 'text' and UTF8 encoding; yet there are problems.

If a good rtf import parser may be included, Scribus may INDEED become a great competitor to consecrated DTP apps; definitely better than Xpress, perhaps also than InDesign (well, that's difficult, but not impossible).

I shall do my best to promote Scribus whenever and wherever possible, provided that this may be improved. Please tell me if wrong, or superficial.
Steps To ReproduceAny time, I assume.
TagsNo tags attached.
Attached Filestgz file icon koffice.tgz [^] (27,491 bytes) 2005-06-16 05:36

- Relationships
related to 0004511acknowledged Text export: RTF 
parent of 0013406assignedfschmid Paragraph Styles are not being imported from RTF files 
related to 0008697closedfschmid Suggested Improvement of RTF Import with UNRTF 
child of 0003621assignedTsoots Metabug: COSS text importer update 
Not all the children of this issue are yet resolved or closed.

-  Notes
cbradney (administrator)
2004-12-29 21:39

You can import in 1.2.1cvs.
cbradney (administrator)
2004-12-29 21:39

Changing to a feature request. This is not a major bug.
Tsoots (manager)
2004-12-30 18:12

This is on my todo list, not that high ranked but is there :)

If anybody wants to give it a try I'm willing to give all the help I'm able to give. Just contact me at freenode #scribus or
Sorin Paliga (reporter)
2004-12-30 22:41

My modest abilities with Fink in MAC OS X have not allowed to install the version mentioned by cbradney. Many thanks to Tsoots for the bright perspective.
Of course, the terrible project to have an app running on all 3 major platforms is fantastic... The MAC OS X version, despite its requiring X11, is good indeed, and does not seem below the versions running in MDK 10.1 or Ubuntu.
I humbly suggest to concentrate on the ability to import rtf, doc and sxw formats, which would really aleviate our life; and would make Scribus a GREAT, really great dtp app. I find this much more useful than any other new feature.
plinnell (administrator)
2005-04-06 15:52

moving to 1.3 for the roadmap
subik (manager)
2005-06-16 05:43

I've studied some RTF importers. There are 3 possibillities:
* write everithing from scratch. IMHO the stupid way, because there are some promising parsers already.
* use Abiword importer. Gtk based but c++.
* use koffice importer (see attached file). Plain Qt(! except some kdebug.h - easy to remove/simulate). We'll need to rewrite only the RTF nodes - Scribus mappings. "Full of flesh" but sounds reasonable to me.

and winner is... koffice (in this time)
ringerc (administrator)
2005-06-18 12:20

Note that in 1.3cvs as a workaround you can save as .sxw from and import that.

I'm personally hoping that at some stage it'll be possible to use the OO.o UNO bindings to support importing any format understands. It's probably a fair bit of work though, and troublesome for Mac OS X (where we have alpha Aqua builds, but there's no Aqua version of OpenOffice).
Sorin Paliga (reporter)
2005-06-19 18:40


There is no good OpenOffice proper for MAC OS X, but NeoOffice/J is just sufficient, even if slow enough as compared to other similar apps. Therefore if Scribus may have a sxw parser this would be indeed sufficient.
cbradney (administrator)
2005-06-19 18:54

Scribus already has an SXW and ODT importer.
ringerc (administrator)
2005-06-19 20:17

Note that you'll only get those importers in more recent versions of Scribus. 1.2RC is ... ancient. At least by Scribus standards. You'd be well advised to grab 1.2.1 or preferably 1.2.2cvs to get the latest bug fixes and improvements (there have been a LOT of them, and that's not counting the development 1.3 branch).

I think Martin Costabel keeps the Fink versions of Scribus fairly current (if you're using the testing branch of fink - IIRC the stable branch is almost fossilized), so that may be a good option. Alternately, there's a page "Installing Scribus from CVS sources on Mac OS X" on that might be useful - but be aware it presumes some UNIX experience.
Kunda (manager)
2015-10-10 06:17

So how do you use this new importer?
Open a text frame and drag/drop an .rtf in to it ?

- Issue History
Date Modified Username Field Change
2004-12-29 21:23 Sorin Paliga New Issue
2004-12-29 21:39 cbradney Note Added: 0003288
2004-12-29 21:39 cbradney Note Added: 0003289
2004-12-29 21:39 cbradney Severity major => feature
2004-12-30 18:12 Tsoots Note Added: 0003298
2004-12-30 22:41 Sorin Paliga Note Added: 0003303
2005-04-06 15:52 plinnell Note Added: 0004095
2005-04-06 15:52 plinnell Product Version 1.2.1cvs => 1.3.0cvs
2005-06-16 05:36 subik File Added: koffice.tgz
2005-06-16 05:43 subik Note Added: 0005052
2005-06-18 12:20 ringerc Note Added: 0005062
2005-06-18 12:20 ringerc Status new => acknowledged
2005-06-19 18:40 Sorin Paliga Note Added: 0005068
2005-06-19 18:54 cbradney Note Added: 0005069
2005-06-19 20:17 ringerc Note Added: 0005070
2006-04-11 00:04 Tsoots Relationship added child of 0003621
2006-04-11 00:05 Tsoots Status acknowledged => assigned
2006-04-11 00:05 Tsoots Assigned To => Tsoots
2010-01-10 23:07 cbradney Relationship added related to 0008697
2010-08-30 03:31 christoph_s Assigned To Tsoots => jainbasil
2015-10-09 20:36 fschmid Status assigned => resolved
2015-10-09 20:36 fschmid Fixed in Version => 1.5.1svn
2015-10-09 20:36 fschmid Resolution open => fixed
2015-10-09 20:36 fschmid Assigned To jainbasil => fschmid
2015-10-10 06:09 Kunda Relationship added related to 0004511
2015-10-10 06:17 Kunda Note Added: 0036594
2015-10-10 09:15 christoph_s Status resolved => closed
2015-10-11 00:55 Kunda Relationship added parent of 0013406

Copyright © 2000 - 2015 MantisBT Team
Powered by Mantis Bugtracker