Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001488ScribusShape Drawingpublic05-Jan-04 23:1205-Apr-16 10:59
Reporterlouisdesjardins 
Assigned Tofschmid 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSMandrakeOS Version10
Product Version1.2.1cvs 
Target VersionFixed in Version1.2.2cvs 
Summary0001488: Being able to resize a straight line or change its angle from any end-points
DescriptionRight now, it's only possible to resize a straight line or modify its angle from the right-end-point (at creation time). When you try to do this by grabbing the left-end-point, you can only move the line around.

This occurs no matter how you set the basepoint [End point] or [Left point].

Behaviour not fully as expected.
Interface [cursor and dialogs] a little misleading.
Steps To ReproduceDraw a straight line.
Grab the left-end-point. The line can't be resized and/or rotated. [unexpected]
Grab the right-end-point. The line can be resized and/or rotated. [expected]
Grab the line in between the 2 end-points, you can move the line, unchanged. [expected]
Additional InformationNote the cursor change to a cross (with arrowhead on each end) when on the line in between the end-points. This is OK because you can displace the line.

I think the cursor, when on any end-point, should be a two-arrowhead cursor which tells users they can now edit the line. This occurs only when you click on the end-point. When you do the same on a text or image frame, the cursor changes, without clicking, as soon as you go over any handle. Same should apply here.

Plus, I don't understand why the basepoint set to [End point] makes it impossible to rotate the line with values, while at the same time it can be moved freely with the cursor (and you can see the values as they are changing in the greyed field) ? My understanding of a basepoint is it's only used as a reference. Useful, I must say.

The actual interface is somewhat misleading: there are 2 places where you can find the basepoint, in Properties>Lines and in Properties>Geometry.

And while it seems impossible to set the basepoint of lines in the Properties>Geometry panel, this basepoint actually is the one previously set on a text or picture frame. And it works! The values that appear in the fields are related to the basepoint. Other than that, as jo-hannes points it, there is no way to change the basepoint. It would be very useful to be able to rotate a line on its center axis, for example.

[With basepoint set to Left point] Values in Width and Rotation fields are updated in real time while X-Pos and Y-Pos are only updated when the modification is done.

[With basepoint set to End point] Values in X2, Y2 and Rotation fields are updated in real time while X1, Y1 are only updated when the modification is done.

Not that I find the last 2 points to be bugs but it only striked me!

There are a few bugs related to straight lines.

Related to bug 0000250
Related to bug 0000689
TagsNo tags attached.
Attached Files

- Relationships
related to 0002407acknowledged Metabug: Misleading and wrong cursors 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
05-Jan-04 23:12 louisdesjardins New Issue
05-Apr-16 10:42 fschmid Status new => resolved
05-Apr-16 10:42 fschmid Fixed in Version => 1.2.2cvs
05-Apr-16 10:42 fschmid Resolution open => fixed
05-Apr-16 10:42 fschmid Assigned To => fschmid
05-Apr-16 10:59 cbradney Status resolved => closed
07-May-23 21:51 christoph_s Relationship added related to 0002407



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker