Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001771ScribusGraphics / Image Framespublic2005-03-08 17:142006-01-16 23:24
Reporterafonit 
Assigned Tocbradney 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformUbuntu Hoary LinuxOSUbuntu Hoary LinuxOS Versionhoary
Product Version1.3.2cvs 
Target VersionFixed in Version1.3.2cvs 
Summary0001771: Unable to choose scale frame to image size, does not exist, only exists in the context menu of "adjust frame to picture"
Descriptionwhen importing an image into an image frame, you can bring up the 'properties' toolbar and under 'shape' you can select 'scale to frame size'

however

there is not a selection for scale frame size to image size.

Steps To Reproduceinspection of the properties menu revelals the absence of this option, also in settings preferences there is not this type of option.
Additional InformationI think this feature would be most usefull, almost so much so that it could perhaps we worthy of a button on the main toolbar, so that it could be selected as a 'mode' to work in. This in and of itself is a particular type of workflow that would be handy to be able to readily turn on and off.

By work flow, I mean that one might be importing many many images into many frame, and it would be nice to switch this 'mode' on of scaling frames to the image sizes, so that you can just import and move the images around, instead of having to right click each image and select "adjust frame to picture".


The reason why this would be usefull is thus:

in production environments, especially in directory publishing, the images/ads are made at their intended size, therefore, the job when producing the scribus document is to import the images and move them around into their needed locations on the scribus layout. Therefore it would be nice to import the images and have the frames adjust to the picture, withought the need to right click on each object.
hence, the usefulness of a 'mode' switch or button for this functionality.


obviously this may not be usefull for everyone, so I have marked this feature as low.
TagsNo tags attached.
Patch
Attached Files

- Relationships
related to 0001779closedcbradney decrease bloating in context menus for frames 

-  Notes
(0003889)
afonit (reporter)
2005-03-08 17:36

just noticed

in the right click (context menu)
we can see that 'image visible' is defaulted to be selected.

it would be great if we could do a similar default, or selectablity similar to 'image visible' for 'adjust frame to picture'


I imagine that would be the simplest implementation and would be unobtrusive.
(0003890)
louisdesjardins (developer)
2005-03-08 18:02

Agree. Nice idea.

I think that one neat place to implement this would be in the Settings>Preferences>Tools where Image frames can be set [right now] to either Free Scaling or Scale to Frame Size [plus the option of making this proportionnal or not].

There is still room in that dialog and I would see the one more option (that already exist through the contextual menu) directly into the Prefs settings. Enabling this option would do exactly what you describe.
(0004164)
plinnell (administrator)
2005-04-08 09:50

bumping to 1.2.2 for possible inclusion
(0004902)
cbradney (administrator)
2005-06-05 21:49

In 1.3 you can now assign a shortcut to this option, and it exists on the Item menu.
(0005379)
plinnell (administrator)
2005-07-03 23:12

bumping to 1.2.3
(0006409)
plinnell (administrator)
2005-09-04 23:45

bumping to 1.3.x.. not easy to fix in 1.2.x 1.3.x has new menu code
(0008107)
plinnell (administrator)
2006-01-15 15:04

This is fixed in 1.3.2 and will not be added the 1.2.x, the menu code is more complicated and adding this might introduce additional bugs.

- Issue History
Date Modified Username Field Change
2005-03-08 17:14 afonit New Issue
2005-03-08 17:36 afonit Note Added: 0003889
2005-03-08 18:02 louisdesjardins Note Added: 0003890
2005-03-29 12:38 cbradney Relationship added related to 0001779
2005-03-29 12:39 cbradney Status new => assigned
2005-03-29 12:39 cbradney Assigned To => cbradney
2005-03-29 19:02 cbradney Summary unable to choose scale frame to image size, does not exist, on exists in the context menu of "adjust frame to picture" => Unable to choose scale frame to image size, does not exist, only exists in the context menu of "adjust frame to picture"
2005-04-08 09:50 plinnell Note Added: 0004164
2005-04-08 09:50 plinnell Product Version 1.2.1 => 1.2.2cvs
2005-06-05 21:49 cbradney Assigned To cbradney =>
2005-06-05 21:49 cbradney Note Added: 0004902
2005-07-03 23:12 plinnell Note Added: 0005379
2005-07-03 23:12 plinnell Assigned To => cbradney
2005-07-03 23:12 plinnell Product Version 1.2.2cvs => 1.2.3
2005-09-04 23:45 plinnell Note Added: 0006409
2005-09-04 23:45 plinnell Product Version 1.2.3 => 1.3.2cvs
2006-01-15 15:04 plinnell Note Added: 0008107
2006-01-15 15:04 plinnell Status assigned => resolved
2006-01-15 15:04 plinnell Resolution open => fixed
2006-01-15 15:04 plinnell Fixed in Version => 1.3.2cvs
2006-01-16 23:24 plinnell Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker