Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001816ScribusFontspublic2005-03-25 22:592005-06-01 19:42
Reporteravox 
Assigned Tocbradney 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.3 
Target VersionFixed in Version1.3.0cvs 
Summary0001816: Fonts are only recognized in 'pfa', 'pfb', 'ttf' and 'otf' files.
DescriptionFreetype has the ability to open most font files including Mac resource forks, *.dfont files and TrueType collections (*.ttc).
Scribus should:
* recognize any font which freetype can open
* recognize all fonts in a collection
* identify font types by content instead of by extension
* look for fonts in the std Mac directories (Library/Fonts etc.)

The following patch provides this.
TagsNo tags attached.
Patch
Attached Filesdiff file icon morefonts5.diff [^] (68,950 bytes) 2005-05-28 01:20 [Show Content]

- Relationships
related to 0002015closedavox This issue lists all known regressions of the Aqua port compared with the 13 Linux version 

-  Notes
(0004097)
avox (administrator)
2005-04-06 16:44

Changes:

* extracts TTF from TTC files for embedding
* uses Adobe Glyphnames if FT says PS Glyphnames isn't reliable

Needs additional file scribus/glyphnames.txt.q
which unfortunately produces lots of warnings ATM
(0004099)
cbradney (administrator)
2005-04-06 20:40

Why does it need this text file?
(0004100)
avox (administrator)
2005-04-06 21:05
edited on: 2005-04-06 21:21

glyphnames.txt.q is #included in util.cpp.
Without it the array of glyphnames will be empty and
PS and PDF export will not work for some TTF/OTF fonts
(symptom: all chars have undefined glyphs)

It's the file "glyphlist.txt" from Adobe with added quotes and commas.
See http://partners.adobe.com/public/developer/en/opentype/glyphlist.txt [^]

(0004102)
cbradney (administrator)
2005-04-06 22:01

We need confirmation on licensing of the glyph list in its current format, otherwise we need something from unicode.org I assume.
(0004105)
avox (administrator)
2005-04-07 01:58

Ok, last patch doesn't need glyphnames any more but finds glyphnames like this:

1. if FT_HAS_GLYPH_NAMES(face) is true, use FT_Get_Glyph_Name()
2. Otherwise, OR if FT returned ".notdef", OR if FT returned an empty name:
3a. if unicode is 16bit, use "uni1234" name
3b. if unicode is more than 16 bit, use "u12345" name

Now works with MS Mincho, MS Gothic and Papyrus in one document
(0004793)
avox (administrator)
2005-05-26 22:15

Updated the patch with a version against current CVS
(0004813)
cbradney (administrator)
2005-05-27 22:56

Uploaded new version of morefonts4.diff with fix for #endif in the wrong place.
(0004830)
plinnell (administrator)
2005-05-29 11:04

This crash is triggered adding fonts to $HOME/.fonts

Font Univers-ExtraBlackObl loaded from /home/peter/.fonts/UniEBO49.pfa(1)
Font /home/peter/.fonts/UniEBO49.pfb(1) is duplicate of /home/peter/.fonts/UniEBO49.pfa(1)

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1089528960 (LWP 6823)]
0x409a5202 in parse_encoding () from /usr/lib/libfreetype.so.6
(gdb) bt
#0 0x409a5202 in parse_encoding () from /usr/lib/libfreetype.so.6
0000001 0x409a574f in parse_dict () from /usr/lib/libfreetype.so.6
0000002 0x409a5a66 in T1_Face_Init () from /usr/lib/libfreetype.so.6
0000003 0x4096c71f in open_face () from /usr/lib/libfreetype.so.6
0000004 0x4096cef6 in FT_Open_Face () from /usr/lib/libfreetype.so.6
0000005 0x4096dc38 in FT_New_Face () from /usr/lib/libfreetype.so.6
0000006 0xbfffd790 in ?? ()
0000007 0x00000000 in ?? ()
0000008 0xbfffd874 in ?? ()
0000009 0x00000004 in ?? ()
0000010 0xbfffdbb0 in ?? ()
0000011 0xbfffd7b8 in ?? ()
0000012 0x087ba210 in ?? ()
0000013 0xbfffd8b0 in ?? ()
0000014 0xbfffd7c0 in ?? ()
0000015 0x00000018 in ?? ()
0000016 0x40919f40 in __JCR_LIST__ () from /usr/lib/qt3/lib/libqt-mt.so.3
0000017 0x08b0c2c8 in ?? ()
0000018 0xbfffd8f0 in ?? ()
0000019 0xbfffd898 in ?? ()
0000020 0x0830d964 in SCFonts::AddScalableFont (this=0x0, filename=Cannot access memory at address 0x2
)
    at scfonts.cpp:589
Previous frame inner to this frame (corrupt stack?
(0004831)
plinnell (administrator)
2005-05-29 11:08

with same fonts in ./fonts. instant death on startup. Note this is a Suse 9.1 system with ft 2.1.7


Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1089528960 (LWP 8193)]
0x409a5202 in parse_encoding () from /usr/lib/libfreetype.so.6
(gdb)
(0004833)
plinnell (administrator)
2005-05-29 12:40

OK, I think I have figured out the crashes. It seems FT error checking is being disabled by the patch or not working with Ft 2.1.7.

Testing the same fonts (which are definitely borken) on my home system without the patch works fine e.g. Scribus quietly drops them on loading.

Contining to test.
(0004851)
plinnell (administrator)
2005-05-31 20:44

needed to be added is a check for FT 2.1.9+

- Issue History
Date Modified Username Field Change
2005-03-25 22:59 avox New Issue
2005-03-25 22:59 avox File Added: morefonts.diff
2005-04-06 16:36 avox File Added: morefonts2.diff
2005-04-06 16:44 avox Note Added: 0004097
2005-04-06 16:45 avox File Added: glyphnames.txt.q
2005-04-06 20:40 cbradney Note Added: 0004099
2005-04-06 21:05 avox Note Added: 0004100
2005-04-06 21:06 avox Note Edited: 0004100
2005-04-06 21:21 avox Note Edited: 0004100
2005-04-06 22:01 cbradney Note Added: 0004102
2005-04-07 01:53 avox File Added: morefonts3.diff
2005-04-07 01:58 avox Note Added: 0004105
2005-05-26 22:14 avox File Added: morefonts4.diff
2005-05-26 22:15 avox Note Added: 0004793
2005-05-26 22:25 avox File Deleted: morefonts.diff
2005-05-26 22:25 avox File Deleted: morefonts2.diff
2005-05-26 22:25 avox File Deleted: glyphnames.txt.q
2005-05-26 22:25 avox File Deleted: morefonts3.diff
2005-05-26 22:25 avox Status new => assigned
2005-05-26 22:25 avox Assigned To => fschmid
2005-05-27 07:53 mhanski Relationship added related to 0002015
2005-05-27 22:55 cbradney File Deleted: morefonts4.diff
2005-05-27 22:55 cbradney File Added: morefonts4.diff
2005-05-27 22:56 cbradney Note Added: 0004813
2005-05-28 01:20 avox File Added: morefonts5.diff
2005-05-28 18:51 cbradney Assigned To fschmid => cbradney
2005-05-29 11:04 plinnell Note Added: 0004830
2005-05-29 11:08 plinnell Note Added: 0004831
2005-05-29 12:40 plinnell Note Added: 0004833
2005-05-29 20:19 cbradney Status assigned => resolved
2005-05-29 20:19 cbradney Fixed in Version => 1.3.0cvs
2005-05-29 20:19 cbradney Resolution open => fixed
2005-05-31 20:44 plinnell Note Added: 0004851
2005-06-01 19:42 cbradney File Deleted: morefonts4.diff
2005-06-01 19:42 cbradney Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker