Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002221ScribusImport / Exportpublic2005-07-11 01:052012-01-01 21:38
Reporterchristoph_s 
Assigned Tofschmid 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSLinuxOS VersionMandrake 10.1
Product Version1.3 
Target VersionFixed in Version1.5.0svn 
Summary0002221: scribus crash with signal 0000006 or complete freeze while trying to import complex svg files
DescriptionI tried to import very complex svg files into scribus. The svgs
were vectorised bitmaps produced with autotrace/potrace and afterwards edited in
inkscape.

When I try to import the files into scribus, it either crashes with
signal 0000006 or freezes and needs to be killed.
Steps To ReproduceCreate new doc > import file > svg > seclect file > open > scribus dies
TagsNo tags attached.
Patch
Attached Files? file icon problem_svgs.tar.bz [^] (634,700 bytes) 2005-07-11 01:05
png file icon logo.png [^] (258,611 bytes) 2005-07-11 02:10

- Relationships
has duplicate 0002220closedringerc scribus crash with signal 0000006 or complete freeze while trying to import omple svg files 
has duplicate 0009542closedjghali Crash when importing very large vector file 
related to 0002438acknowledged Metabug: Cases of extreme memory use 
related to 0005008closedjghali Crashes with SVG files 
related to 0005014closedcbradney SVG import freezes Scribus 
related to 0004732new SVG test cases 
related to 0005006closedavox Crash while resizing SVG 
child of 0002931acknowledged Metabug: SVG 

-  Notes
(0005499)
ringerc (administrator)
2005-07-11 02:03
edited on: 2005-07-11 02:13

stativ.svg works fine here. It takes forever to import, and it's a screaming nightmare to manipulate on the page (Scribus has real problems with selections of many tiny objects - takes aages drawing selection rectangles) but it imports just fine.

The attachment is actually a screenshot of stativ.svg, not logo.svg .

(0005500)
ringerc (administrator)
2005-07-11 02:10

When manipulating the imported object I did see:

*** attempt to put segment in horiz list twice
*** attempt to put segment in horiz list twice

on the console.
(0005501)
ringerc (administrator)
2005-07-11 02:11

Note that I was testing with late 1.2.2cvs .
(0005502)
ringerc (administrator)
2005-07-11 02:16

logo.svg is fine too. Both exhibit the same problems as text converted to outlines though, in terms of being very difficult to manipulate due to selection border redraws taking so long, and having the weird "double scan" effect when dropped at the end of a drag.

stativ.svg had

*** attempt to put segment in horiz list twice

errors when I rendered it in the GIMP, too. I wonder where that error is coming from?
(0005535)
plinnell (administrator)
2005-07-11 18:34

the libart message is answered here: http://www.scribus.org.uk/modules.php?op=modload&name=FAQ&file=index&myfaq=yes&id_cat=10#54 [^]
(0006250)
plinnell (administrator)
2005-08-26 23:41

bumping this to 1.2.4, so it does not get lost in the shuffle. This is a symptom of some memory handling with complex drawings in general.
(0007410)
plinnell (administrator)
2005-11-12 01:21

bumping to 1.3, as 1.3.2cvs is vastly better and a new SVG importer should help. I don't know if this fixable in 1.2.x.
(0015208)
cbradney (administrator)
2007-02-11 21:39

Christoph, please retest
(0015213)
christoph_s (administrator)
2007-02-11 23:05

no change. stativ.svg causes freeze, logo.svg leaves the doc uneditable (scrbus becoming dead slow). Loading any of both files in 1.3.3.8 or 1.3.4cvs slows down the whole ui (not only scribus) dramatically.

- Issue History
Date Modified Username Field Change
2005-07-11 01:05 christoph_s New Issue
2005-07-11 01:05 christoph_s File Added: problem_svgs.tar.bz
2005-07-11 01:52 ringerc Relationship added has duplicate 0002220
2005-07-11 02:03 ringerc Note Added: 0005499
2005-07-11 02:03 ringerc Status new => acknowledged
2005-07-11 02:10 ringerc Note Added: 0005500
2005-07-11 02:10 ringerc File Added: logo.png
2005-07-11 02:11 ringerc Note Added: 0005501
2005-07-11 02:13 ringerc Note Edited: 0005499
2005-07-11 02:16 ringerc Note Added: 0005502
2005-07-11 18:34 plinnell Note Added: 0005535
2005-08-26 23:41 plinnell Note Added: 0006250
2005-08-26 23:41 plinnell Product Version 1.2.1 => 1.2.4cvs
2005-08-27 05:21 ringerc Relationship added related to 0002438
2005-11-12 01:21 plinnell Note Added: 0007410
2005-11-12 01:21 plinnell Severity crash => major
2005-11-12 01:21 plinnell Product Version 1.2.4cvs => 1.3
2006-05-17 21:12 christoph_s Relationship added child of 0002931
2006-12-26 18:27 christoph_s Relationship added related to 0005008
2006-12-26 18:29 christoph_s Relationship added related to 0005014
2006-12-26 18:32 christoph_s Relationship added related to 0004732
2006-12-26 18:34 christoph_s Relationship added related to 0005006
2007-02-11 21:39 cbradney Note Added: 0015208
2007-02-11 23:05 christoph_s Note Added: 0015213
2010-12-01 15:02 jghali Relationship added has duplicate 0009542
2011-12-30 21:56 fschmid Status acknowledged => resolved
2011-12-30 21:56 fschmid Fixed in Version => 1.5.0svn
2011-12-30 21:56 fschmid Resolution open => fixed
2011-12-30 21:56 fschmid Assigned To => fschmid
2012-01-01 21:38 cbradney Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker