Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003426ScribusInternalpublic2006-03-15 09:352014-07-17 02:27
Reporterjo-hannes 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusconfirmedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version1.6 milestoneFixed in Version 
Summary0003426: double clicking a sla file when scribus is already opened opens a second instance of scribus
Descriptionthats not really necessary.
TagsNo tags attached.
Patch
Attached Files

- Relationships
has duplicate 0006672closedjghali Second process/instance launches 
has duplicate 0011639closedjghali Open documents in running instance, please 

-  Notes
(0009478)
jghali (administrator)
2006-03-25 21:29

won't fix for a while, needs interapplication communication
(0009486)
ringerc (administrator)
2006-03-27 04:05

This isn't an easy one, as Jean mentioned. Single-instance-per-user apps are ... interesting ... to get working right. Ever used an app that exits, or crashes, but really leaves a process running with no windows, so whenever you try to launch a new copy it just asks the non-functional existing process to do something? You have to manually find and kill the misbehaving process, or reboot, to resolve the issue.

Names that come to mind for me include Firefox, Thunderbird, Eudora and OpenOffice. I'm sure a lot more apps do it too.

Windows actually provides some explicit support for single-instance apps, but on other platforms its even worse. On Linux, for example, it can even be hard to decide what you should treat as a single session. Can a user run two copies if they're on different DISPLAYs? What about one copy run by two different users, appearing on the same DISPLAY? Gah. Not so bad for Scribus, but for things that regularly get used remotely (eg firefox) it's a bit harsh. I tend to favour "if in doubt, launch another instance" myself.

Anyway, getting single-instance operation going _and_ _working_ _reliably_ will most likely take some serious work, and there are a lot of other things to do first :S
(0032797)
Kunda (manager)
2014-07-17 01:51

I can't reproduce this issue on 1.5svn OSX r19342.
Is there some sort of obscure edge-case this still happens with?
(0032798)
Kunda (manager)
2014-07-17 02:25

Reopening because issue still exists on KDE.

- Issue History
Date Modified Username Field Change
2006-03-15 09:35 jo-hannes New Issue
2006-03-25 21:29 jghali Note Added: 0009478
2006-03-25 21:30 jghali ETA none => > 1 month
2006-03-27 04:05 ringerc Note Added: 0009486
2006-03-27 04:05 ringerc Status new => confirmed
2006-05-04 23:14 plinnell Category Win32 => Internal
2006-05-04 23:14 plinnell Product Version 1.3.3cvs => 1.6 milestone
2008-01-16 08:21 jghali Relationship added has duplicate 0006672
2013-07-01 19:32 jghali Relationship added has duplicate 0011639
2014-07-17 01:51 Kunda Note Added: 0032797
2014-07-17 01:51 Kunda Status confirmed => resolved
2014-07-17 01:51 Kunda Resolution open => fixed
2014-07-17 01:51 Kunda Assigned To => Kunda
2014-07-17 02:25 Kunda Note Added: 0032798
2014-07-17 02:25 Kunda Assigned To Kunda =>
2014-07-17 02:25 Kunda Status resolved => confirmed
2014-07-17 02:27 Kunda Product Version 1.6 milestone =>
2014-07-17 02:27 Kunda Target Version => 1.6 milestone



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker