Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000504ScribusUsabilitypublic2004-04-20 10:222009-01-26 22:04
Reportermega 
Assigned Toavox 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformallOSallOS Versionall
Product Version 
Target Version1.3.5Fixed in Version1.3.5svn 
Summary0000504: We need more accurate object selection
DescriptionWith two overlaped objects, there is not possible select one (smaller usually) of them (with mouse, without overview). When I click on two overlaped objects, there should be selected object, whose center is closer to cursor.

There should be more inteligent object selection. Layers are bad workaround.
Additional InformationIn uploaded project, try to select middle line a try to add bottom line to sellection only with mouse... It's impossible for me :|
TagsNo tags attached.
Patch
Attached Filesgz file icon LineSelect.sla.gz [^] (8,121 bytes) 2004-04-20 10:22

- Relationships
related to 0000482closedavox Illogical behaviour when resizing/moving a frame below another. Ctrl should not be required to do the action. 
related to 0002407acknowledged Metabug: Misleading and wrong cursors 
related to 0007726closedpierremarchand unselect group from a multi (shift left-click) does not work properly 
child of 0003171acknowledged Metabug: Selection improvements 
child of 0005693closedplinnell 1.3.5 bug collection (prior to roadmap) 

-  Notes
(0009839)
jo-hannes (developer)
2006-04-12 12:05

dont think thats low if this is still an issue
(0009912)
mhanski (developer)
2006-04-13 21:16

Planned in Roadmap Extras http://wiki.scribus.net/index.php/1.3.x_Roadmap_Extras [^]
with no ETA

Changing the status to acknowledged
(0018523)
christoph_s (administrator)
2008-01-10 01:44

It's still impossible to select all 3 items. Try the follwing: Select first line from below, then press Ctrl+Shift (or Shift) and try to select the second line from below. Now the upper line is selcted. Press Ctrl+Shift agan to select the middle line. Now the middle line is selected, but the upper line is deselected.
(0018532)
cbradney (administrator)
2008-01-10 21:41

Its not impossible.. but u need another control shift click at the end to do it
(0019852)
pepe (reporter)
2008-06-16 14:50

There seems to be a more severe issue in my Svn R 12262 (June 13th) with the attached example: With control shift, I can select items below, but on the second control shift click, they are just added to the selection. The selection of the object above is not undone any more as in earlier versions. There seems to be no way to get rid of the selection of the first object (the one above). Another or more control shift clicks don't do that.
(0020989)
avox (administrator)
2009-01-25 19:33

That's probably a lack of documentation.
With current svn, there can be three modifiers that can be combined:

Ctrl - select an object beneath the currently selected one
Shift - dont clear the selection but add to it
Alt - allow selection of objects within groups

So ctr-shift-click is supposed to extend the selection by the one below the currently selected one beneath the cursor.

Just clicking Ctrl-Click should cycle through all objects at the position from top to bottom, finally deselecting all and then starting with the top again.

Same with Ctrl-Alt-Click will include group members in the cycle.
(0020995)
rubikwuerfel (reporter)
2009-01-26 00:37

May I suggest switching the meaning of Ctrl and Alt, since that's how Inkscape handles the same problem for quite some time now.

- Issue History
Date Modified Username Field Change
2004-04-20 10:22 mega New Issue
2004-04-20 10:22 mega File Added: LineSelect.sla.gz
2005-08-09 18:31 ringerc Relationship added related to 0000482
2006-02-04 00:40 jo-hannes Relationship added child of 0003171
2006-04-12 10:48 mhanski Priority normal => low
2006-04-12 10:48 mhanski Category General => Usability
2006-04-12 10:48 mhanski OS => all
2006-04-12 10:48 mhanski OS Version => all
2006-04-12 10:48 mhanski Platform => all
2006-04-12 12:05 jo-hannes Note Added: 0009839
2006-04-12 12:21 mhanski Priority low => normal
2006-04-13 21:16 mhanski Note Added: 0009912
2006-04-13 21:16 mhanski Status new => acknowledged
2007-05-23 21:42 christoph_s Relationship added related to 0002407
2008-01-08 23:34 cbradney Status acknowledged => assigned
2008-01-08 23:34 cbradney Assigned To => avox
2008-01-08 23:34 cbradney Status assigned => resolved
2008-01-08 23:34 cbradney Fixed in Version => 1.3.5
2008-01-08 23:34 cbradney Resolution open => fixed
2008-01-08 23:35 cbradney Fixed in Version 1.3.5 => 1.3.5svn
2008-01-08 23:35 cbradney Target Version => 1.3.5
2008-01-10 01:44 christoph_s Status resolved => feedback
2008-01-10 01:44 christoph_s Resolution fixed => reopened
2008-01-10 01:44 christoph_s Note Added: 0018523
2008-01-10 08:58 jghali Summary We need more accuray object selection => We need more accurate object selection
2008-01-10 21:41 cbradney Note Added: 0018532
2008-01-14 19:29 christoph_s Relationship added child of 0005693
2008-06-16 14:50 pepe Note Added: 0019852
2009-01-25 19:33 avox Note Added: 0020989
2009-01-26 00:37 rubikwuerfel Note Added: 0020995
2009-01-26 16:34 pierremarchand Relationship added related to 0005960
2009-01-26 16:35 pierremarchand Relationship deleted related to 0005960
2009-01-26 16:36 pierremarchand Relationship added related to 0007726
2009-01-26 22:04 cbradney Status feedback => resolved
2009-01-26 22:04 cbradney Resolution reopened => fixed
2009-01-26 22:04 cbradney Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker