Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000577ScribusStylespublic2004-05-02 19:382012-11-13 21:32
Reportermhanski 
Assigned Tocbradney 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.3.4cvs 
Target VersionFixed in Version1.4.2.svn 
Summary0000577: Paragraph Styles -> Kerning and language options missing
DescriptionThese two options which are available in the "Properties/Text" palette, are missing in the "Paragraph Styles". Generally, it would be good to keep the "Properties/Text" palette and "Paragraph Styles" coherent (due to usability).
TagsNo tags attached.
Patch
Attached Files

- Relationships
related to 0001279feedbacklouisdesjardins Adequation of settings in Paragraph styles/Properties palette/Text editor 
related to 0002250closedcbradney Paragraph styles UI needs work 
related to 0003312feedback Add an option to apply hyphenation from the properties palette 
related to 0003828acknowledged Metabug: Hyphenation 
related to 0003911closedavox Enable "forced" hyphenation 
related to 0004572new Hyphenation styles 
child of 0000111assigned Scribus Document File format 
child of 0003821acknowledged Metabug: Usability 

-  Notes
(0004930)
mhanski (developer)
2005-06-07 07:36
edited on: 2005-07-20 23:26

I still miss the "Language:" option in the paragraph styles.

Apart from being consistent with the Properties palette, setting the language within a style would be good for another reason: the user could define styles like "body_text_german", or "quotation_english" and make sure this way, the the proper hyphenation and spell check rules would be applied. For now, I have to separately define styles and then apply language in the Properties palette, which is a terrible drudgery while working with longer multilingual texts.

(0007864)
louisdesjardins (developer)
2005-12-30 14:37

I strongly agree with this.
(0009915)
mhanski (developer)
2006-04-13 21:17

Planned in Roadmap Extras http://wiki.scribus.net/index.php/1.3.x_Roadmap_Extras [^]
with no ETA

Changing the status to acknowledged
(0011467)
avox (administrator)
2006-05-25 20:23

Of course Language will be a character style attribute...

Any hints how to hyphenate mixed language words?
No hyphenation, or use language of first char, or hyphenate at language changes?
(0011468)
louisdesjardins (developer)
2006-05-25 21:22

1. Language in paragraph style is what Quark does. So, in the same text frame, you can handle many languages. This is a must.

2. Language in character style would allow to hyphenate a specific word in another language than the paragraph it is in. I am not aware if Quark or ID have that onboard.

To me number 2 falls in the category of real "fine tuning". If the feature is implemented, it can be useful. At the same time I'd say it could easily become one of the best unknown feature for lots of users!
(0011469)
louisdesjardins (developer)
2006-05-25 22:25

FYI just checked with both ID CS2 and Quark 6.5 and there is no language option in the character style for both of them. Language option is only available for the Paragraph Style.
(0011470)
louisdesjardins (developer)
2006-05-25 22:30

<begin_quote>
>>>Any hints how to hyphenate mixed language words?
>>>No hyphenation, or use language of first char, or hyphenate at language changes?
<end_quote>

I guess the default settings for language would be what Scribus grabs at launch. Then it is up to the user to set the language according to the needs.

Not sure if this answer actually helps you.
(0011471)
mhanski (developer)
2006-05-25 23:41

<begin_quote>
>>>Any hints how to hyphenate mixed language words?
>>>No hyphenation, or use language of first char, or hyphenate at language changes?
<end_quote>

I would opt for no hyphenation for mixed language words. I would consider such mixed language words as user faults and treat them as "no language assigned" cases.
(0011476)
mkoren (reporter)
2006-05-26 18:13

>>>I would consider such mixed language words as user faults and treat them as "no language assigned" cases.

Is it not possible to have "word-level" properties, that can only be applied at a per-word granularity? It seems ugly to have a property that can be applied incorrectly to part of a word when that intrinsically doesn't make sense. A word would seem to be, practically speaking, the smallest unit which can meaningfully have a language attribute.
(0011477)
avox (administrator)
2006-05-26 18:36

> Is it not possible to have "word-level" properties, that can only be applied at a per-word granularity?
> It seems ugly to have a property that can be applied incorrectly to part of a word when that
> intrinsically doesn't make sense.

Per word properties would be too much hassle to implement. I'll probably just take the first char's
language attribute as tht for the whole word -- I guess users will find out quickly enough if there
should be problems.

> A word would seem to be, practically speaking, the smallest unit which can meaningfully have
> a language attribute.

In doubt that could be a single char.
(0011481)
mhanski (developer)
2006-05-26 19:19

avox, do you plan "Language" as an _paragraph_ style attribute too, as requested in this RFE? If yes, which one should prevail in doubt: character style, paragraph style, or the last applied?
(0011483)
avox (administrator)
2006-05-26 20:37

As with other char attributes:

an explicitly set charattribute has precedence over par attributes.
not explicitly set charattributes take their defaults from parstyle, automatically update if parstyle is changed.

applying a *named* parstyle will overwrite charattributes if these charattributes are explicitly set in the named parstyle.

At least that's my current plans. We'll have to check out how it works in practice.
(0011484)
mkoren (reporter)
2006-05-26 21:33

>>>Per word properties would be too much hassle to implement.

Correct me if I'm wrong, just a thought here....

It seems to me a paragraph style is not much more than a character style that snaps to paragraph boundaries and sets the defaults for that paragraph. What if the application of a style could snap to user-defined boundaries (which could be either paragraphs or words, e.g.)? There wouldn't actually have to be a different kind of style, just selectable granularity.

But only styles with a granularity of at least a word could set language, and only styles with a granularity of at least a paragraph could set properties like vertical before/after spacing and the like.
(0011486)
louisdesjardins (developer)
2006-05-26 22:00

After reading the last posts, I can only come to conclusion it is not a good idea to introduce language at char style level.

Language belongs to paragraph styles.

Language choice is for hyphenation only anyways. If someone needs a word to be hyphenated another way than in the current language it is better to implement a feature like "hyphenation exception" to handle those cases.

Hope that helps!
(0011488)
mkoren (reporter)
2006-05-26 23:01

What if there were just one kind of style, instead of separate style types for character, paragraph, etc.? One of the properties of the style could be the smallest unit to which it could be applied--character, word, line, paragraph, etc.

Each text attribute in the DTD would then be assigned a minimum granularity of style that would be able to set that attribute, and would be disabled for a style if a smaller granularity is selected (e.g., a style that can be applied to individual characters can't set line spacing or language).

This would work well with the "first n..." feature in 0000363: a style could specify different attributes or named styles for the first n of any smaller granularity unit. So the first line of a paragraph of style A could have line style B, which in turn applies word or character style C to its first four words:

CCCC CCCC CCCCC
AAAAA AAA AA AAA A
AAA AA.

CC C CCC CC BB BBB
AAA AA ... :)
(0011489)
avox (administrator)
2006-05-26 23:21

That sounds too complicated to me. Anyway, even the styles applied to the first words/lines of a paragraph would still be charstyles.

And some attributes just make sense only on paragraph level, eg. indentation or alignment.

So far word granularity is only in question for Language, and it's just too much work to implement the necessary code for that.
(0013107)
mhanski (developer)
2006-10-23 08:59
edited on: 2006-10-23 09:12

hmm, I've just noticed that the "Language" setting in the "Properties" palette is no longer available! This and the missing language setting in "Paragraph Styles" deprives me of the possibility to have bilingual/multilingual, hyphenated text frames in one Scribus document. 1 Scribus document == 1 language? If it stayed this way, I'd consider it a major regression.

Edited 5 minutes later: OK, I should have noticed the "Language" setting in "Character Styles". Still not convinced, why we shouldn't have "Language" at "Paragraph Styles" (to be overriden by Char Styles setting) level and in the Propoerties Palette (which would overwrite para and char styles)?

(0013108)
louisdesjardins (developer)
2006-10-23 16:11

I agree with mhanski. The language settings is confusing at the moment.

Testing Style Manager with 1.3.4 cvs 21 oct. 06. I didn't put too much energy into this because I know Tsoots is working on it at the moment. But I think it is worth to pursue the discussion.

I will not discuss the Paragraph Style dialog which will go away.

In the Style Manager, we can create a Paragraph Style. When in that dialog we have a General tab and a Character Style tab (can't remember if we have a 3rd tab there, and don't have that CVS on my office Mac). I find the name of this Character Style tab confusing because what it actually allows to set is the character parameters of the Paragraph Style. Obviously, from that stand point, "Language" has to be there. But can one say this is part of a "Character Style"? I'd say no.

So, is it the name of the tab into the Paragraph Style dialog of the Style Manager that is the problem? I think so.

Because at the same time, we also have a Character Style which can be set through the Style Manager, along with a Line Style... and probably more to come.

I find this confusing. I know the Paragraph Style dialog was a bit crowded and this is the reason why it is now splitted into different tabs. Could we possibly think of renaming the "General" tab to "Space settings" and the other "Character Settings" or something that would at least tell the user that the 2 tabs complete each other?

Also, I do think (and I insist!) that "Language" is part of a paragraph option. It could be left like it is in the actual "Character Style" of Paragraph Style (I am getting confused myself writing this because of that tab name).

And, as "Language" in that case is for hyphenation, we might be well inspired to name this submenu "Hyphenation Language" instead of "Language". This would clear any confusion any user might have regarding this feature. :)
(0013110)
mhanski (developer)
2006-10-23 16:31

Louis, just a side note: we don't know, if there won't be some other language relevant tools (spellchecking, thesaurus) in the future, simple " Language" and a nice tooltip would be the safer option than "Hyphanetation language".
(0013111)
louisdesjardins (developer)
2006-10-23 16:42

Maciej, I understand but how does an eventual Spellchecker (or Thesaurus or any such "content" or "editorial" editing tool) relates to a Style? Isn't it something totally different that we would not want to see into that dialog anyway?

What I think is just not adding to confusion with for instance the GUI language because it is important to note that those can be different. And it also have the advantage of giving users the hint that different styles with different hyphenation languages can co-exist into one document, one text frame.
(0013112)
mhanski (developer)
2006-10-23 17:21
edited on: 2006-10-23 17:29

<quote>Maciej, I understand but how does an eventual Spellchecker (or Thesaurus or any such "content" or "editorial" editing tool) relates to a Style? Isn't it something totally different that we would not want to see into that dialog anyway?</quote>

No, you misunderstood, it seems, I hadn't been clear enough. Only the "Language" relates to styles, and there shouldn't be anything about "Hyphenation language" or "Spellechecking language" in this dialog -- you'd assign the "Language" to a para style, that's it. If the Scribus team decided to add new tools to the "Extras" menu, such as Spellchecking or Thesaurus, these tools would rely on the language setting too, not only the hyphenation tool. That's why I'm against renaming the "Language" setting to "Hyphenation language".


- Issue History
Date Modified Username Field Change
2004-05-02 19:38 mhanski New Issue
2005-05-25 13:17 mhanski Relationship added related to 0001279
2005-06-06 22:52 fschmid Status new => resolved
2005-06-06 22:52 fschmid Fixed in Version => 1.3.0cvs
2005-06-06 22:52 fschmid Resolution open => fixed
2005-06-06 22:52 fschmid Assigned To => fschmid
2005-06-07 07:36 mhanski Status resolved => feedback
2005-06-07 07:36 mhanski Resolution fixed => reopened
2005-06-07 07:36 mhanski Note Added: 0004930
2005-07-20 23:26 mhanski Note Edited: 0004930
2005-07-20 23:30 mhanski Relationship added related to 0002250
2005-10-09 01:33 mhanski Relationship added child of 0000111
2005-12-27 17:47 mhanski Product Version => 1.3.2cvs
2005-12-30 14:37 louisdesjardins Note Added: 0007864
2006-01-15 22:51 plinnell Product Version 1.3.2cvs => 1.3.3cvs
2006-04-02 13:25 mhanski Product Version 1.3.3cvs => 1.3.4cvs
2006-04-13 21:17 mhanski Note Added: 0009915
2006-04-13 21:17 mhanski Status feedback => acknowledged
2006-04-13 21:19 mhanski Status acknowledged => assigned
2006-05-02 15:28 mhanski Relationship added related to 0003312
2006-05-15 20:09 christoph_s Relationship added child of 0003821
2006-05-16 23:49 christoph_s Relationship added related to 0003828
2006-05-25 19:45 fschmid Assigned To fschmid => avox
2006-05-25 20:23 avox Note Added: 0011467
2006-05-25 21:22 louisdesjardins Note Added: 0011468
2006-05-25 22:25 louisdesjardins Note Added: 0011469
2006-05-25 22:30 louisdesjardins Note Added: 0011470
2006-05-25 23:41 mhanski Note Added: 0011471
2006-05-26 18:13 mkoren Note Added: 0011476
2006-05-26 18:36 avox Note Added: 0011477
2006-05-26 19:19 mhanski Note Added: 0011481
2006-05-26 20:37 avox Note Added: 0011483
2006-05-26 21:33 mkoren Note Added: 0011484
2006-05-26 21:52 mkoren Note Added: 0011485
2006-05-26 22:00 louisdesjardins Note Added: 0011486
2006-05-26 23:01 mkoren Note Added: 0011488
2006-05-26 23:21 avox Note Added: 0011489
2006-06-13 03:54 christoph_s Relationship added related to 0003911
2006-10-23 08:59 mhanski Note Added: 0013107
2006-10-23 09:12 mhanski Note Edited: 0013107
2006-10-23 16:11 louisdesjardins Note Added: 0013108
2006-10-23 16:26 mhanski Note Added: 0013109
2006-10-23 16:27 mhanski Note Deleted: 0013109
2006-10-23 16:31 mhanski Note Added: 0013110
2006-10-23 16:42 louisdesjardins Note Added: 0013111
2006-10-23 17:21 mhanski Note Added: 0013112
2006-10-23 17:29 mhanski Note Edited: 0013112
2006-10-23 21:47 mkoren Note Deleted: 0011485
2006-11-21 15:44 christoph_s Relationship added related to 0004572
2012-10-15 22:22 cbradney Status assigned => resolved
2012-10-15 22:22 cbradney Fixed in Version 1.3.0cvs => 1.4.2.svn
2012-10-15 22:22 cbradney Resolution reopened => fixed
2012-10-15 22:22 cbradney Assigned To avox => cbradney
2012-11-13 21:32 cbradney Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker