Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000633ScribusStylespublic2004-05-11 14:482005-07-03 11:17
Reporterlouisdesjardins 
Assigned Tofschmid 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSMandrakeOS Version10
Product Version1.2.2cvs 
Target VersionFixed in Version1.2.2cvs 
Summary0000633: Drop caps not reaching to the top, and other issues
DescriptionPlease see the attached files, all is well described there. This is following my email to the list (may 10, 2004).
TagsNo tags attached.
Patch
Attached Files? file icon BogueLettrine.sla [^] (38,697 bytes) 2004-05-11 14:48
pdf file icon Figure 1.pdf [^] (37,098 bytes) 2004-07-18 16:46
pdf file icon Figure 2.pdf [^] (30,225 bytes) 2004-07-18 16:46
pdf file icon Figure 3.pdf [^] (29,085 bytes) 2004-07-18 16:47
pdf file icon Figure 4.pdf [^] (28,286 bytes) 2004-07-18 16:47
pdf file icon Figure 5.pdf [^] (17,463 bytes) 2004-07-18 16:47
pdf file icon Figure 6.pdf [^] (35,565 bytes) 2004-07-18 16:48
pdf file icon dropcapbugs_screen.pdf [^] (409,651 bytes) 2004-07-18 17:44

- Relationships
related to 0001337confirmed Drop caps only drop first char of a par beginning with a quote 

-  Notes
(0001757)
cbradney (administrator)
2004-06-16 19:04

Reminder sent to louisdesjardins

Please update to CVS, test and close bug or let us know, thanks.
(0001885)
plinnell (administrator)
2004-07-05 05:28

Reminder sent to louisdesjardins

Louis, can you test this.. we are trying to clean up the bug tracker in prepping for 1.2 final.

Thanks.
(0001891)
plinnell (administrator)
2004-07-06 05:52

behaviour is still present in current CVS with the file from this bug
(0001987)
louisdesjardins (developer)
2004-07-17 21:45

As per July 17 2004 cvs, this bug is still present, as described(*).

Just to make sure my explanation is clear, I want to add that the drop cap is reaching too high above the top line of the font (the ascenders) of the text. From what I see with other DTP programs, the result can vary from font to font but the differences are v e r y tiny. Basically, what we want to achieve is that all type seems to hang from the top, with the drop cap always sitting on a baseline of the current text.

(*) To be precise, the 4th issue in the provided file is partly solved : there is no white space under the drop cap when “lock to baseline grid“ is active but the drop cap still starts too high.

Hope this will help!
(0001990)
louisdesjardins (developer)
2004-07-18 17:01

I have provided 6 files that include notes to explain that bug. They are screen shots of the scribus files as all my attempts to provide a pdf file from the application didn’t work. (Acrobat is giving me a “damaged file“ warning that I couldn’t fix. Same result happened with 1.4 or 1.5 compatibility, with 2 sets of different fonts, in Acrobat 4 and in Acrobat 6, using various compression and no compression... Tried hard with not much success. If you find it difficult reading my notes on the screen shot, please let me know.)

After this is fixed, I have two suggestions : 1) to be able to apply the Drop Cap to more than just the first letter; 2) to be able to define a different color/shade to the drop cap (this, I know Quark 5 doesn’t do it and I can check with other DTP programs...) A bonus! If you want me to file a new “bug“ (feature request), again, let me know.
(0001994)
cbradney (administrator)
2004-07-18 17:31

Yes, PDF export seems to be broken now except if you set linescreen options. Im sure itll be fixed tonight.
(0001995)
louisdesjardins (developer)
2004-07-18 17:46

Thanks! The PDF is OK now. So here it is.
(0001996)
cbradney (administrator)
2004-07-18 18:09

Nicely explained... I think Franz has something to go by now. Thanks very much.
(0002732)
louisdesjardins (developer)
2004-10-20 14:51

Reminder sent to cbradney

Hi Craig,

I just want to say this bug is still present in the current CVS.
I do make a fair use of drop caps...
Of course, I know issues are addressed one by one. So no pressure from me. Just a reminder! ;-)

Cheers!

Louis
(0003557)
cbradney (administrator)
2005-01-29 23:59

Franz, had this again. Can you please have a look here?
(0004178)
plinnell (administrator)
2005-04-08 11:35

bumping to 1.2.2
(0004823)
fschmid (administrator)
2005-05-29 09:49

Most issues with Drop Caps should be fixed now.
(0004824)
cbradney (administrator)
2005-05-29 10:49

This only looks slightly different now in the last paragraph in the sample document. The rest still look wrong to me, 1.2.2/1.3.0cvs vs 1.2.2cvs from a few days ago vs 1.2.1 there isnt much difference.
(0004825)
cbradney (administrator)
2005-05-29 10:58

What I see as different looks to have been confirmed fixed by Louis before. Franz do you see something different there?
(0004834)
fschmid (administrator)
2005-05-29 13:01

Don't take that attached doc as a reference, instead create a new doc and apply
the Drop Caps to some paragraphs. Compare this now with the look from 1.3.0cvs
from yesterday. You should see the differnce that the Drop Caps is now really
on top of the Frame when you apply it to the first paragraph of a textframe.
(0005335)
plinnell (administrator)
2005-07-02 13:53

I have tested this too with current 1.2.2cvs and I am inclined to close it as fixed. Thoughts ?

- Issue History
Date Modified Username Field Change
2004-05-11 14:48 louisdesjardins New Issue
2004-05-11 14:48 louisdesjardins File Added: BogueLettrine.sla
2004-06-11 12:59 fschmid Status new => resolved
2004-06-11 12:59 fschmid Resolution open => fixed
2004-06-11 12:59 fschmid Assigned To => fschmid
2004-06-16 19:04 cbradney Note Added: 0001757
2004-07-05 05:28 plinnell Note Added: 0001885
2004-07-06 05:52 plinnell Status resolved => feedback
2004-07-06 05:52 plinnell Resolution fixed => reopened
2004-07-06 05:52 plinnell Note Added: 0001891
2004-07-17 21:45 louisdesjardins Note Added: 0001987
2004-07-18 16:46 louisdesjardins File Added: Figure 1.pdf
2004-07-18 16:46 louisdesjardins File Added: Figure 2.pdf
2004-07-18 16:47 louisdesjardins File Added: Figure 3.pdf
2004-07-18 16:47 louisdesjardins File Added: Figure 4.pdf
2004-07-18 16:47 louisdesjardins File Added: Figure 5.pdf
2004-07-18 16:48 louisdesjardins File Added: Figure 6.pdf
2004-07-18 17:01 louisdesjardins Note Added: 0001990
2004-07-18 17:31 cbradney Note Added: 0001994
2004-07-18 17:44 louisdesjardins File Added: dropcapbugs_screen.pdf
2004-07-18 17:46 louisdesjardins Note Added: 0001995
2004-07-18 18:09 cbradney Note Added: 0001996
2004-10-20 14:51 louisdesjardins Note Added: 0002732
2005-01-29 23:59 cbradney Note Added: 0003557
2005-01-30 00:00 cbradney Status feedback => confirmed
2005-04-08 11:35 plinnell Note Added: 0004178
2005-04-08 11:35 plinnell Status confirmed => assigned
2005-04-08 11:35 plinnell Product Version 1.2CVS => 1.2.2cvs
2005-05-29 09:49 fschmid Status assigned => resolved
2005-05-29 09:49 fschmid Fixed in Version => 1.2.2cvs
2005-05-29 09:49 fschmid Resolution reopened => fixed
2005-05-29 09:49 fschmid Note Added: 0004823
2005-05-29 10:49 cbradney Note Added: 0004824
2005-05-29 10:58 cbradney Note Added: 0004825
2005-05-29 13:01 fschmid Note Added: 0004834
2005-06-29 04:05 ringerc Relationship added related to 0001337
2005-07-02 13:53 plinnell Note Added: 0005335
2005-07-03 11:17 cbradney Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker