Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000709ScribusUser Interfacepublic04-May-24 22:4105-Dec-01 00:35
Reportermhanski 
Assigned Tocbradney 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version1.3.2cvs 
Summary0000709: Switched Yes/No and Yes/No/Cancel dialogues
DescriptionThis is certainly not a priority one case, but perhaps it would serve the usability to accustom diverse Yes/No and Yes/No/Cancel dialogues to what the user most often expects. IMO, No/Yes dialogs should be switched to Yes/No (see screen shot 1). I'm not as certain regarding the three choice dialogues, but I think, the order should be from the highest to the least probability, i.e. Yes/No/Cancel respectively Close/Save/Cancel (see screenshot 2). Last but not least an example, that some dialogues in Scribus follow this rule (screen shot 3).
TagsNo tags attached.
Attached Filespng file icon 2options.png [^] (30,887 bytes) 04-May-24 22:41


png file icon 3options.png [^] (9,737 bytes) 04-May-24 22:42


png file icon Save_Cancel.png [^] (43,273 bytes) 04-May-24 22:42

- Relationships
related to 0003821acknowledged Metabug: Usability 

-  Notes
(0001570)
subik (manager)
04-May-25 08:37

i agree and i'm able to do it
(0001574)
malex (administrator)
04-May-25 16:15

I already raised this issue some time ago. Franz was adamantly against it as the proposed way does not conform to the Apple HIG. Please talk to him before you start changing the dialogs.
(0001575)
jo-hannes (developer)
04-May-25 19:31

what means APPLE HIG? i agree with subik and mhansky, i also made this proposal but cbradney said there is no real standard although im also known to yes-no-cancel
(0001576)
cbradney (administrator)
04-May-25 20:59

The decision was made previously that as is used in various systems, the default should be on the left, whether this be yes or no.
(0001577)
fschmid (administrator)
04-May-25 20:59

malex, that thing with the HIG (Apple Human Interface Guidelines) was only meant for the default button being used, not for the placement of the buttons itself.
(0001843)
redrat (reporter)
04-Jun-25 00:33

I find the current button layout really irritating. I think scribus should follow the button layout of kde. It almost looks like a KDE application and it's confusing for people who use KDE and Scribus. Applications look a like but behave different...

(and btw. I thought scribus is mainly an linux application. I make no sense to use the _APPLE_ hig). Maybe there's a way this is configureable or it's plattform based...)
(0004062)
subik (manager)
05-Apr-04 09:23

I've browsed whole 1.3cvs - it seems everything is reworked "KDE way". Maciej, malex do you agree?
(0004064)
cbradney (administrator)
05-Apr-04 17:12

No, theres plenty that are No-Yes. My plans were to be able to set this, or detect the WM if user requested, and then let the dialog swap them around. Its not that hard. We should not be coding for KDE or Gnome, but allowing switching based on user prefs.
(0006913)
cbradney (administrator)
05-Oct-05 00:17

I have started to implement a new message dialog class that can switch based on environment, ie Win32, OSX, Gnome or KDE. Eg, the new File Revert warning dialog.
(0007327)
ringerc (administrator)
05-Nov-05 05:18

MrB, is this done? It looks like it is at least partially.
(0007329)
cbradney (administrator)
05-Nov-05 13:04

Its partially done, but I havent scoured all sources for QMessageBox:: calls yet. Just done the ones I have come across.

- Issue History
Date Modified Username Field Change
04-May-24 22:41 mhanski New Issue
04-May-24 22:41 mhanski File Added: 2options.png
04-May-24 22:42 mhanski File Added: 3options.png
04-May-24 22:42 mhanski File Added: Save_Cancel.png
04-May-25 08:37 subik Note Added: 0001570
04-May-25 08:37 subik Status new => assigned
04-May-25 08:37 subik Assigned To => subik
04-May-25 16:15 malex Note Added: 0001574
04-May-25 19:31 jo-hannes Note Added: 0001575
04-May-25 20:59 cbradney Note Added: 0001576
04-May-25 20:59 fschmid Note Added: 0001577
04-Jun-25 00:33 redrat Note Added: 0001843
05-Apr-04 09:23 subik Note Added: 0004062
05-Apr-04 09:23 subik Status assigned => feedback
05-Apr-04 17:12 cbradney Note Added: 0004064
05-Oct-05 00:16 cbradney Status feedback => assigned
05-Oct-05 00:16 cbradney Assigned To subik => cbradney
05-Oct-05 00:17 cbradney Note Added: 0006913
05-Nov-05 05:18 ringerc Note Added: 0007327
05-Nov-05 13:04 cbradney Note Added: 0007329
05-Nov-25 23:11 cbradney Status assigned => resolved
05-Nov-25 23:11 cbradney Fixed in Version => 1.3.2cvs
05-Nov-25 23:11 cbradney Resolution open => fixed
05-Dec-01 00:35 cbradney Status resolved => closed
06-May-15 20:12 christoph_s Relationship added related to 0003821



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker