Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007793ScribusPDFpublic2009-02-14 13:362012-04-29 12:54
ReporterBAlpha 
Assigned Tojghali 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
Platformi686OSFedora LinuxOS Version10
Product Version1.3.5svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0007793: Make crop mark length user-settable
DescriptionIt would be nice to have a way to manually set the length of crop (and maybe other) marks on export, possibly also allowing negative values (such that the marks are inside the bleed area instead of outside, where the latter adds to the page size, which may be undesirable).
TagsNo tags attached.
Patch
Attached Filesdiff file icon cropmark.diff [^] (42,209 bytes) 2012-03-21 19:12 [Show Content]
pdf file icon Document-1.pdf [^] (2,013 bytes) 2012-03-24 19:35
diff file icon croplength.diff [^] (42,156 bytes) 2012-03-24 19:36 [Show Content]
diff file icon cropmarklength.diff [^] (50,011 bytes) 2012-03-24 23:37 [Show Content]

- Relationships

-  Notes
(0021139)
jghali (administrator)
2009-02-14 13:52

Yep. However i'm not sure *at all* we should allow negative values as having crop marks in the bleed area may cause crop marks to be viewable after trimming.
(0021140)
BAlpha (reporter)
2009-02-14 16:33

True, but helpful when you want to come as close as possible to the original format while still having bleed when proofing on non-oversized paper. That's probably why InDesign does exactly that when printing directly.
(0027791)
louisdesjardins (developer)
2012-03-12 20:11

I agree that negative values can be useful.

I second this RFE !
(0027841)
Chelen (developer)
2012-03-21 19:16

I tried to do a patch to change the length of crop marks, it is what you would have isn't it?

With pdf, I can choose the length of crop but I have not test with printer as I do not have one here.

ps: It is my first patch so, if you have comment or something to improve on this patch, just ask.
(0027855)
jghali (administrator)
2012-03-24 13:04
edited on: 2012-03-24 13:31

I tested your patch. There are a few things that do not work :

- spinbox in pdf export dialog do not always use proper unit
- when exporting pdf of a document with non zero bleed, mark offset is not always correctly applied. Try with 5 mm bleed, crop marks + bleed marks enabled, 3mm crop size and 0mm offset.

Also some implementation recommandations :
- crop mark size should apply to bleed mark size
- no need to enable/disable crop mark size widget

[Edit] I will fix item 3 and 4 myself.

(0027857)
Chelen (developer)
2012-03-24 19:35

Here is the news patch which use proper unit correctly.
About the second issue, I don't understand. I tried with these values but it looks good. I have added my pdf if you want to see my result.

About other recommendations, I wonder if I should apply this value to bleed mark but I didn't as I was not sure you want this in this patch. It is a good idea I think, thanks for doing this.

I add the enable/disable widget because this value is useless if we don't need mark crop. And it is a way to inform the user that this spinBox is related to cropMark even there is a tooltip

I wait more information to fix the second issue
(0027858)
jghali (administrator)
2012-03-24 20:01

The sample pdf shows the issue : in our context offset means distance between mark and bleed area, the pdf would be correct if 'offset' was the distance between mark and border of page.

Tip : fixing that issue needs modifying around two lines :)
(0027859)
Chelen (developer)
2012-03-24 23:37

In fact, I tried to export pdf with scribus 1.4.1svn and it work the same than in this case. If you change bleed length, it doesn't change bleed mark position and the value is the length between crop marks and bleed marks.

In this news patch, bleeds' values are the distance between the border of the page and the mark. And, bleed marks are resized to be at this same distance.

There is an other problem but I think it is user's business, if bleed is to small, color mark and some others exceed bleed length.
(0027869)
jghali (administrator)
2012-03-27 22:38

Sorry for the delay, I committed your patch (after some refactoring). Thanks!

- Issue History
Date Modified Username Field Change
2009-02-14 13:36 BAlpha New Issue
2009-02-14 13:52 jghali Note Added: 0021139
2009-02-14 16:33 BAlpha Note Added: 0021140
2009-03-15 03:02 christoph_s Status new => acknowledged
2009-03-15 03:02 christoph_s Target Version => 1.3.6
2012-03-12 20:11 louisdesjardins Note Added: 0027791
2012-03-21 19:12 Chelen File Added: cropmark.diff
2012-03-21 19:16 Chelen Note Added: 0027841
2012-03-24 13:04 jghali Note Added: 0027855
2012-03-24 13:30 jghali Note Edited: 0027855 View Revisions
2012-03-24 13:31 jghali Note Edited: 0027855 View Revisions
2012-03-24 19:35 Chelen Note Added: 0027857
2012-03-24 19:35 Chelen File Added: Document-1.pdf
2012-03-24 19:36 Chelen File Added: croplength.diff
2012-03-24 20:01 jghali Note Added: 0027858
2012-03-24 23:37 Chelen Note Added: 0027859
2012-03-24 23:37 Chelen File Added: cropmarklength.diff
2012-03-27 22:38 jghali Note Added: 0027869
2012-03-27 22:54 jghali Status acknowledged => resolved
2012-03-27 22:54 jghali Fixed in Version => 1.5.0svn
2012-03-27 22:54 jghali Resolution open => fixed
2012-03-27 22:54 jghali Assigned To => jghali
2012-04-29 12:54 cbradney Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker