Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007910ScribusFontspublic2009-03-30 20:242013-04-11 15:58
ReporterMike 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS Version8.10
Product Version1.3.5svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0007910: add support for OpenType kerning tables
Descriptionadd support for OpenType kerning tables
Steps To ReproduceDownload e.g. pagella font, write AV and To and use OpenType and Type 1. Type 1 has nice kerning whereas OpenType doesn't any.

Pagella font:
http://www.gust.org.pl/projects/e-foundry/tex-gyre/pagella [^]

Additional Information- TrueType works ok
- Type 1 works ok

I also tried some other OpenType fonts, but with the same result.
TagsNo tags attached.
Patch
Attached Filespng file icon OpenType_kerning.png [^] (29,560 bytes) 2009-03-30 20:26


png file icon kern150.png [^] (57,278 bytes) 2010-07-08 18:37


diff file icon sc135-otf-kerning.diff [^] (14,990 bytes) 2011-02-16 10:41 [Show Content]

- Relationships
has duplicate 0009383closedale GPOS kern table not used in Scribus (kerning pairs for Latin+diacritics) 

-  Notes
(0021445)
cbradney (administrator)
2009-03-30 22:25

Pierre has a patch for this, however as it changes layout, it will go into 1.3.6.
(0023702)
timpul (reporter)
2010-04-15 22:16

Just an acknowledge!
Now I'm working on a GPL font. I tried to create kerning by classes. (Similar gliphs in a group.) I mentioned that no program can handle this feature except InDesign.
Only "Individual Kerning Pair" is the winner in TTF and OTF, too.
Take a look at the blog entry how each programs handle kerning in " AVAY" and "kö".
http://my.opera.com/brtkr/blog/kern-class-error-in-linux [^]
Thanks.
(0024978)
user3518
2010-12-04 10:43
edited on: 2010-12-04 10:51

The problem results from the use of the FreeType2-library in Scribus.

See the FreeType2 tutorial (http://freetype.sourceforge.net/freetype2/docs/tutorial/step2.html [^]):
"The API can only access kerning via the ‘kern’ table; OpenType kerning via the ‘GPOS’ table is not supported. You need a higher-level library like Pango or ICU to handle that."

So, this obviously can't be fixed unless one of these libraries is being used in Scribus. (This would probably be a major change, but the problem is increasingly urgent since many contemporary fonts aren't available anymore unless in OpenType format. Would it be possible to change the "severity" of this issue to "major"??)

(0024979)
pierremarchand (reporter)
2010-12-04 11:40

For a long time now we have code that builds a pseudo kern table by analysing the content of the kern feature in OpenType fonts. So yes we use FT, but lack of kerning was critical enough that we had to find a workaround.
(0024980)
user3518
2010-12-04 14:18

Dear Pierre, thank you, but: I've tried on Windows (!) with Scribus 1.3.6, 1.3.7 and 1.3.8 – kerning definitely does not work there when using OpenType-fonts while it works well with TrueType- ans PS-fonts. So, sorry if I ask again: The "issue details" only talk about "Platform: Linux" and 1.5.0 as targeted version (while cbradney says there's a patch in version 1.3.6). => Is there a solution for the Windows-version, too?
(0025603)
plinnell (administrator)
2011-02-16 10:53

R16365 has the patch for 1.4.0.svn
(0030071)
jghali (administrator)
2013-04-11 15:58

Resolving and closing this issue. OTF kerning support has been working for quite some time in trunk.

- Issue History
Date Modified Username Field Change
2009-03-30 20:24 Mike New Issue
2009-03-30 20:26 Mike File Added: OpenType_kerning.png
2009-03-30 22:25 cbradney Status new => assigned
2009-03-30 22:25 cbradney Assigned To => pierremarchand
2009-03-30 22:25 cbradney Note Added: 0021445
2009-03-30 22:26 cbradney Target Version => 1.3.6
2010-04-15 22:16 timpul Note Added: 0023702
2010-07-08 18:37 pierremarchand File Added: kern150.png
2010-09-29 15:34 ale Relationship added has duplicate 0009383
2010-12-04 10:43 user3518 Note Added: 0024978
2010-12-04 10:51 user3518 Note Edited: 0024978 View Revisions
2010-12-04 11:40 pierremarchand Note Added: 0024979
2010-12-04 14:18 user3518 Note Added: 0024980
2011-02-16 10:41 plinnell File Added: sc135-otf-kerning.diff
2011-02-16 10:53 plinnell Note Added: 0025603
2013-04-11 15:58 jghali Note Added: 0030071
2013-04-11 15:58 jghali Status assigned => resolved
2013-04-11 15:58 jghali Fixed in Version => 1.5.0svn
2013-04-11 15:58 jghali Resolution open => fixed
2013-04-11 15:58 jghali Status resolved => closed
2013-04-11 15:58 jghali Assigned To pierremarchand =>



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker