Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008392ScribusShape Drawingpublic2009-08-28 12:402010-06-23 01:58
ReporterMike 
Assigned Tocbradney 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformallOSallOS Versionall
Product Version1.3.5 
Target Version1.5.0Fixed in Version1.3.8svn 
Summary0008392: add resize to align and distribute
Descriptionadd resize to align and distribute

- create third item Resize

Relative to: Firt Selected, Last Selected, Page, Margins, Guide, Salection

Selected Guide:

 - according to width (denote by two-direction horizontal arrow)
 - according to height (denote by two-direction vertical arrow)
TagsNo tags attached.
Patch
Attached Filespatch file icon scribus-1.3.6-alignwidths.patch [^] (16,700 bytes) 2010-04-15 00:15 [Show Content]

- Relationships

-  Notes
(0023696)
pspencer (reporter)
2010-04-15 00:21

We needed this functionality in our 1.3.6 installation, and have implemented something similar but a little simpler than the proposed feature in this issue report; a patch is attached if this is of any interest as an interim measure until the feature is complete.

The patch adds an option to the Align tab so that, when aligning item edges together, one can choose whether to do the alignment by moving both edges of the object (the current method) or by leaving the other edge fixed (resizing the object instead of moving it).

Thus one can set a group of vertically arranged objects to be the same width by choosing the "align by resizing" option then simply clicking the align-left and align-right buttons.

It doesn't help much the case where one wants to equalize the width of horizontally arranged objects, since after doing this the objects will be all on top of one another, but one could then re-distribute them relative to the page using the "distribute" tab.

(We chose to implement resizing in the scenario where we need to use it most, and couldn't wait until the feature comes out in 1.3.5.)
(0023697)
cbradney (administrator)
2010-04-15 00:30

Thanks for the patch pspencer!! I will review it and commit in the coming days

- Issue History
Date Modified Username Field Change
2009-08-28 12:40 Mike New Issue
2009-10-05 00:15 cbradney Target Version => 1.5.0
2009-10-05 00:15 cbradney Status new => assigned
2009-10-05 00:15 cbradney Assigned To => cbradney
2010-04-15 00:15 pspencer File Added: scribus-1.3.6-alignwidths.patch
2010-04-15 00:21 pspencer Note Added: 0023696
2010-04-15 00:30 cbradney Note Added: 0023697
2010-06-23 00:21 jghali Status assigned => resolved
2010-06-23 00:21 jghali Fixed in Version => 1.3.8svn
2010-06-23 00:21 jghali Resolution open => fixed
2010-06-23 01:58 christoph_s Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker