Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0009892ScribusGeneralpublic2011-03-30 13:582013-09-19 20:40
ReportereMate 
Assigned Tocbradney 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformMacOSOS10.6OS Version10.6.7
Product Version1.4.0svn 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0009892: impossible to access to pages after 9
DescriptionI have tried Scribus 1.4.0rc3 (for intel Mac, Leopard version) but have not been able to acces to pages after 9 of a 25 pages document created with Scribus 1.3.9 (Mac version, on same computer).
Additional InformationMac Mini Core Duo 1 Go RAM
TagsNo tags attached.
Patch
Attached Files? file icon Lecture.sla [^] (151,298 bytes) 2011-03-30 13:58
diff file icon 9892.diff [^] (17,825 bytes) 2011-06-03 12:25 [Show Content]

- Relationships
related to 0009824new Incorrect scroll[bar] dimensions; possibly due to improper canvas dimension calculations 
parent of 0010396closedcbradney impossible to access to pages after 9 
has duplicate 0009961closedcbradney Scrollbar breaks as soon as new pages are added - document corrupted then 
has duplicate 0010008closedjghali limited zoom through the pages 
has duplicate 0010055closedjghali Cannot Pan at Zoom > 1320% 
has duplicate 0010471closedjghali Zoom und Display bei mehr als 50 Seiten in der Arbeitsdatei 

-  Notes
(0025983)
jghali (administrator)
2011-03-30 20:14

Seems specific to OS X, document can be opened without problem on Windows in rc3
(0025984)
su-v (reporter)
2011-03-30 23:13

Not reproduced with Scribus 1.4.0rc3 on OS X 10.5.8 (i386)
MacBookPro5,1, 2.4 GHz Intel C2D, 2GB RAM

All 25 pages are accessible (using the scroll bar or the page selector at the bottom of the window)
(0026008)
cbradney (administrator)
2011-04-06 00:09
edited on: 2011-04-06 00:09

Please download the rc3 dmg for Tiger from sourceforge and re-test.. with that version I see no issue.. carbon based UI.. with the leopard one.. cocoa based.. problem is there

(0026011)
eMate (reporter)
2011-04-06 08:18

I agree : no problem with this Tiger version.
(0026014)
bubu (reporter)
2011-04-06 22:06

No problem on Linux (Ubuntu 10.10, 1.4rc2)
(0026015)
su-v (reporter)
2011-04-06 22:27
edited on: 2011-04-06 22:29

I redid the tests on Mac OS X Leopard with both versions (1.4.0rc3 Tiger Intel, and 1.4.0rc3 Leopard Intel):

1) Tiger Intel: all pages are reachable, independent of zoom level

2) Leopard Intel: number of accessible pages (via scrollbar or page selector) depends on zoom level:

100% zoom: page 12 is the last one to be fully displayed, page 13 is cut off at the top and can't be scrolled further down, nor can later pages be reached by using the page selector
 50% zoom: all pages including the last one, page 25, are fully displayed and can be reached by scrolling or using the page selector

Reproduced and confirming the reported issue with the Leopard Intel build.

(sorry for having missed this in my first test).

(0026147)
sonne (reporter)
2011-04-25 18:39

I agree: No problem with the Tiger Version. Would be nice, if that problem could be fixed in the Leopard Version too.
(0026199)
plinnell (administrator)
2011-05-12 16:54

OK we know now this is a general not OSX issue. Pierre one of the developers is working on a solution.

This can also affect other platforms, but just not as visible.
(0026617)
cbradney (administrator)
2011-07-20 21:36

This could be fixed ok with the Lion upgrade.. currently looks like it.
(0026618)
cbradney (administrator)
2011-07-20 22:54

nm.. still broken
(0026698)
skyle (reporter)
2011-08-10 17:20

Still broken after 6 months and update to MAC OS 10.7 (LION). If your document is a serious one, like 100 pages in my case, you'll have to look at the last page at 10% zoom. Have you ever tried to lay out a page at that zoom. I felt like I was in the middle of an SNL or Monty Python skit.

I am going to continue to try and use this program for personal stuff like announcements or newsletters to get used to it so that if it ever comes around for professional work I'll be ready to use it more seriously. I do think it is a good start and is still in version 1x so that's not so bad. I also really like the idea of Open Source.
(0026701)
ale (manager)
2011-08-10 18:24

skyle, this is one of the issues which are blocking the release of 1.4!

peter: what are the evidences that it's not a os x specific issue? i haven't heard of anybody having seen this bug...
(0026704)
cbradney (administrator)
2011-08-10 21:07
edited on: 2011-08-10 21:08

skyle.. someone is actually working on this.. it requires a rewrite of various parts of the canvas code. it could take awhile. Its working around OSX vs Qt canvas sizing. OSX is forcing a certain size that is too small for the pages.

(0026708)
skyle (reporter)
2011-08-12 01:53

How does adobe size their canvas? It seem to remember that you could set the artboard size in one of their products. Could that be done with Scribus-give the user a setting in the preferences to set. But then why wouldn't it just be as large as it needs to be for, say a 500 page document at 11" high per page. What happens to the normal view if the canvas is enormous? If that is a problem can't it just be a variable of the zoom? -2x zoom --> 2x canvas size, etc.
This is interesting. I like to know what road you're going down as I might be able to help since I know nothing about programming or C++ or Qt.
(0027014)
JLuc (updater)
2011-10-13 00:35

On windows 7, it might be "the contrary" : on a 30 pages document, when displaying the last page, the scrollcursor is only at the middle of the whole scrollbar and i can go down down far away down displaying nothing anymore. It is the same and consistent at all scales however.
(0030556)
cbradney (administrator)
2013-09-04 22:27

Fixed with the move to Qt5

- Issue History
Date Modified Username Field Change
2011-03-30 13:58 eMate New Issue
2011-03-30 13:58 eMate File Added: Lecture.sla
2011-03-30 20:14 jghali Note Added: 0025983
2011-03-30 20:30 cbradney Relationship added related to 0009824
2011-03-30 23:13 su-v Note Added: 0025984
2011-04-05 23:04 cbradney Target Version => 1.4.0
2011-04-06 00:09 cbradney Note Added: 0026008
2011-04-06 00:09 cbradney Note Edited: 0026008 View Revisions
2011-04-06 08:18 eMate Note Added: 0026011
2011-04-06 22:06 bubu Note Added: 0026014
2011-04-06 22:27 su-v Note Added: 0026015
2011-04-06 22:29 su-v Note Edited: 0026015 View Revisions
2011-04-25 15:19 cbradney Relationship added has duplicate 0009961
2011-04-25 18:39 sonne Note Added: 0026147
2011-05-12 16:54 plinnell Note Added: 0026199
2011-05-12 16:54 plinnell Assigned To => pierremarchand
2011-05-12 16:54 plinnell Status new => assigned
2011-05-28 13:02 jghali Relationship added has duplicate 0010008
2011-06-03 12:25 plinnell File Added: 9892.diff
2011-06-17 08:17 jghali Relationship added has duplicate 0010055
2011-07-20 21:36 cbradney Note Added: 0026617
2011-07-20 22:54 cbradney Note Added: 0026618
2011-08-10 17:20 skyle Note Added: 0026698
2011-08-10 18:24 ale Note Added: 0026701
2011-08-10 21:07 cbradney Note Added: 0026704
2011-08-10 21:08 cbradney Note Edited: 0026704 View Revisions
2011-08-12 01:03 cbradney Assigned To pierremarchand => avox
2011-08-12 01:53 skyle Note Added: 0026708
2011-10-13 00:35 JLuc Note Added: 0027014
2011-11-24 21:31 cbradney Issue cloned: 0010396
2011-11-24 21:31 cbradney Relationship added parent of 0010396
2011-11-25 21:18 cbradney Target Version 1.4.0 => 1.4.1
2012-01-02 10:35 jghali Relationship added has duplicate 0010471
2012-04-29 23:13 cbradney Target Version 1.4.1 => 1.4.2
2013-01-13 22:34 cbradney Target Version 1.4.2 => 1.4.3
2013-07-04 22:25 cbradney Target Version 1.4.3 => 1.5.0
2013-09-04 22:27 cbradney Note Added: 0030556
2013-09-04 22:27 cbradney Status assigned => resolved
2013-09-04 22:27 cbradney Fixed in Version => 1.5.0svn
2013-09-04 22:27 cbradney Resolution open => fixed
2013-09-04 22:27 cbradney Assigned To avox => cbradney
2013-09-19 20:40 cbradney Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker