View Issue Details

IDProjectCategoryView StatusLast Update
0010024ScribusStory Editor / Text Framespublic2016-05-06 19:28
ReporterPeterMatrix Assigned To 
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionfixed 
Platformscribus 1.4.0 rc3OSwin xp 
Summary0010024: In Linked Text Frame the Frame Break add extra blank line in the second frame's firs column
DescriptionIn case two or more Text Frames are linked, Frame Break add extra blank line in the second frame's firs column, so the second Text Frame's second column starting 1 line higher then the first column of this frame.
Steps To ReproduceHave 2 or more text frames.
Text Frame 1: no column
Text Frame 2: 2 coulmns
Text Frame x: 2 or more columns
Link them together.
Put text into it (lorem ipsum for example).
Use Story Editor >> Insert >> Space >> Frame Break
In case You insert the frame break at the end of a paragraph, the new paragraph will have ADDITIONAL 1 BLANK LINE in the document, and can not be aligned with the second column's first line. See pink arrows in the picture. So YOu can apply different styles for each paragraph, but this aokward unalignment will be stay there.

Additional InformationIf you put the frame break anywhere else in the text of the paragraph this is not happening. But in this case You can not apply different stylings to the paragraph's parts.

Please let me know how to solve this.

Peter
Tagsduplicate, layout, linked frames
PatchNo

Relationships

duplicate of 0005553 acknowledged column-/frame-breaks add line break to the next column/frame 
related to 0005366 new frame break doesn't break paragraph 
related to 0008749 closedjghali After an explicit frame-break, the first line of the paragraph is not indented as a first list 
related to 0008892 closedjghali left indent is missing after the line/column/frame break 

Activities

PeterMatrix

2011-06-03 21:23

reporter  

WrongFrameBrake.PNG (136,236 bytes)   
WrongFrameBrake.PNG (136,236 bytes)   

ale

2011-06-05 09:11

manager   ~0026315

there are a few bugs related with this one and which affect the frame breaks.

i guess that somebody should go through them all and work on it :-)

cezaryece

2011-06-05 15:21

developer   ~0026317

ale: list them here for easier browsing

JLuc

2014-12-24 16:41

developer   ~0034311

I reproduce this issue but is this really an issue ?
As long as "frame break" is a special glyph, the EndOfParagraph being AFTER the frame break is moved at the begining of the new frame.

As a workaround, or rather an other way of doing, is to insert the frame break AFTER the end of line paragraph = at the beginning of following paragraph.
Doing so, some of the paragraph properties as "vertical space before" will be used for the first part of paragraph and will be lost for paragraph main body. Of course.

there could be another solution : it would require to change the "frame break" glyph into a "End of Paragraph" property...

Kunda

2015-03-23 23:29

updater   ~0034739

What's the verdict ?

Kunda

2016-04-13 16:04

updater   ~0040135

This may be a dupe of 0005553

JLuc

2016-05-06 19:28

developer   ~0040852

Doublon de 0005553

Issue History

Date Modified Username Field Change
2011-06-03 21:23 PeterMatrix New Issue
2011-06-03 21:23 PeterMatrix File Added: WrongFrameBrake.PNG
2011-06-05 09:11 ale Note Added: 0026315
2011-06-05 15:21 cezaryece Note Added: 0026317
2014-04-07 15:48 JLuc Tag Attached: layout
2014-12-24 16:41 JLuc Note Added: 0034311
2014-12-24 16:42 JLuc Patch => No
2014-12-24 16:42 JLuc Priority urgent => normal
2014-12-24 16:52 JLuc Severity major => text
2015-03-23 23:29 Kunda Note Added: 0034739
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames
2016-04-13 16:03 Kunda Relationship added related to 0005553
2016-04-13 16:04 Kunda Note Added: 0040135
2016-04-13 16:04 Kunda Relationship added related to 0005366
2016-04-13 16:06 Kunda Relationship added related to 0008749
2016-04-13 16:06 Kunda Relationship added related to 0008892
2016-04-13 16:07 Kunda Tag Attached: duplicate
2016-04-13 17:03 JLuc Relationship replaced duplicate of 0005553
2016-04-14 13:58 Kunda Tag Attached: linked frames
2016-05-06 19:28 JLuc Note Added: 0040852
2016-05-06 19:28 JLuc Status new => closed
2016-05-06 19:28 JLuc Resolution open => fixed