View Issue Details

IDProjectCategoryView StatusLast Update
0010144ScribusShape Drawingpublic2011-09-15 19:34
Reporterondrej.nemecek Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformAMD Athlon(tm) 64 X2 Dual CoreOSLinuxOS VersionUbuntu 10.10
Product Version1.5.0svn 
Target VersionFixed in Version1.4.0svn 
Summary0010144: Shapes are sometimes cutfed off after grouping
DescriptionUnder some circumstances shapes are displayed bad when grouped.
Possibly reason is bad evaluation of group dimension.
Steps To Reproduce1. create line (width 2mm, length 40mm)
2. create circle (radius 40mm)
3. place center point of circle created i step 2 on basepoint of line created in step 1
4. multiple duplicate line created in step 1 11-times (create 11 copies with rotation 30 deg.)
5. steps 1-4 results in perfectly aligned pattern (see attachment)
6. now group all 12 lines - which breakes aligning at the end of some lines (see attachment)
7. next ungroups all 12 lines - which fix problem
8. next group all 12 lines and circle too - in this case no problem occurs
Additional InformationThe same problem can be seen in Scribus 1.4.0.rc5 and Scribus 1.5.0.svn too.
Tagsalignment
Patch

Activities

ondrej.nemecek

2011-07-22 11:57

reporter  

ondrej.nemecek

2011-07-22 11:58

reporter  

scribus-bugreport-broken-dimensions-of-group-01.sla (74,615 bytes)

ondrej.nemecek

2011-07-22 12:07

reporter   ~0026635

I attached:

- sample scribus document
- png export of this document

I hope my report helps resolve it successfully.

Best regards to all developers!
Ondrej Nemecek.

ondrej.nemecek

2011-07-22 13:03

reporter  

ondrej.nemecek

2011-07-22 13:05

reporter   ~0026636

> i wonder why i can't reproduce the problem...
> here, when i group the elements, no node is moved...
> i've even try to let some guides near the lines...
> do you have any idea how i could reproduce it?
>
> ciao
> a.l.e

All you need to reproduce problem is to group lines exactly as shown on picture
scribus-bugreport-broken-dimensions-of-group-01-how-to-reproduce.png

O.

ondrej.nemecek

2011-07-22 13:08

reporter   ~0026637

> i wonder why i can't reproduce the problem...
> here, when i group the elements, no node is moved...

One more comment - no, there is no _move_ of nodes!
But there is cut-off of some parts of noeds, so ending
parts of lines are not displayed.

ale

2011-07-22 13:15

manager   ~0026638

i'm copy pasting your ungrouped set of lines, moving it at another place in the document and grouping it.

the lines look perfect...

ondrej.nemecek

2011-07-22 13:22

reporter   ~0026639

What? Really? Please, simply select my set of lines and take screenshot. I can't believe that the selection (and than the group) is accurate.

Is there available some offical build of 1.4 or 1.5 Scribus version for Windows? I can try it there.

ale

2011-07-22 13:27

manager   ~0026640

ok, now i can reproduce it: you are only grouping the lines!

the circle is not in the group...

and i have a workaround:
- copy paste the circle (so that you have to circles one on top of the other...)
- group the lines with one of both circles...
- alt-click on the circle in the group to select it (or use the outline tool)
- delete the circle in the group
- you can use the other circle to check that everything is correct...

ondrej.nemecek

2011-07-22 13:53

reporter   ~0026641

Thanks, it works as you say: All seems good when you grouped lines with circle and - which is important - it seems goog also when circle is from group afterwards deleted!

I guess that this detail is important to solve problem. We can compare broken group and workarounded group and then find solution in Scribus code.

fschmid

2011-08-02 22:35

administrator   ~0026674

Fixed now in 1.5.0svn

fschmid

2011-08-02 22:52

administrator   ~0026675

Fixed now in 1.4.0svn too.

ale

2011-08-03 15:08

manager   ~0026677

looks good in 1.5!
thanks

Issue History

Date Modified Username Field Change
2011-07-22 11:57 ondrej.nemecek New Issue
2011-07-22 11:57 ondrej.nemecek File Added: scribus-bugreport-broken-dimensions-of-group-01-page001.png
2011-07-22 11:58 ondrej.nemecek Tag Attached: alignment
2011-07-22 11:58 ondrej.nemecek File Added: scribus-bugreport-broken-dimensions-of-group-01.sla
2011-07-22 12:07 ondrej.nemecek Note Added: 0026635
2011-07-22 12:33 jghali Severity major => minor
2011-07-22 12:33 jghali Steps to Reproduce Updated View Revisions
2011-07-22 13:03 ondrej.nemecek File Added: scribus-bugreport-broken-dimensions-of-group-01-how-to-reproduce.png
2011-07-22 13:05 ondrej.nemecek Note Added: 0026636
2011-07-22 13:08 ondrej.nemecek Note Added: 0026637
2011-07-22 13:15 ale Note Added: 0026638
2011-07-22 13:22 ondrej.nemecek Note Added: 0026639
2011-07-22 13:27 ale Note Added: 0026640
2011-07-22 13:53 ondrej.nemecek Note Added: 0026641
2011-08-02 22:07 fschmid Assigned To => fschmid
2011-08-02 22:07 fschmid Status new => confirmed
2011-08-02 22:35 fschmid Note Added: 0026674
2011-08-02 22:52 fschmid Note Added: 0026675
2011-08-02 22:52 fschmid Status confirmed => resolved
2011-08-02 22:52 fschmid Fixed in Version => 1.4.0svn
2011-08-02 22:52 fschmid Resolution open => fixed
2011-08-03 15:08 ale Note Added: 0026677
2011-09-15 19:34 cbradney Status resolved => closed