View Issue Details

IDProjectCategoryView StatusLast Update
0010260ScribusStory Editor / Text Framespublic2014-07-11 17:18
Reportercgwpublishing Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformPC AMDOSUbuntuOS Version11.04
Product Version1.4.0svn 
Target VersionFixed in Version 
Summary0010260: Story editor does not update until I exit and re-enter 3 times or more, but the key buffer executes outside of the story editor
DescriptionThis is a very difficult problem to search for a solution.

I always edit text in the story editor, so I click on a text frame, press Ctrl T and the story editor opens, usually as a background window which I have to bring to the front. I position the cursor where I want to edit and start typing. Nothing happens. I close the story editor window.

When I then press Ctrl T to go back into the story editor, Scribus executes whatever was in the keyboard buffer on the whole text frame. If I had previously tried to delete text, Scribus now deletes the entire text frame. If I had previously pressed the right cursor arrow to move the cursor right, it moves the text frame right by as many steps as I pressed the right arrow.

If I close and reopen the story editor a few times, it then works normally. However, the problem will recur several times throughout any instance of using Scribus.
Steps To ReproduceOpen the story editor
Type anything
Close the story editor
Open the story editor
The contents of the keyboard buffer now execute on the text frame (or presumably whatever happens to be selected)
Additional InformationThis has started happening in the last few weeks, it hasn't always been like it.
TagsNo tags attached.
Patch

Activities

ale

2011-09-14 14:23

manager   ~0026869

can't replicate with current svn on debian nor with 1.4.0rc5 from malex' repository on ubuntu 10.4.

that is: i can normally update the frame with the text i type in the story editor.

cgwpublishing

2011-09-16 13:17

reporter   ~0026879

Last edited: 2011-09-16 13:30

View 3 revisions

I removed and reinstalled Scribus from the standard repository in Ubuntu 11.04 (universe) as the debian.scribus.net/debian/ repository was apparently disabled on upgrade to natty. The current version displays in the package manager as 1.4.0.dfsg~rc2-1 (natty).

At first, I thought the problem had gone away, but in fact it is still happening. It just doesn't happen when I first open a new document in Scribus, but as soon as I make a few edits using the story editor, the problem was back, exactly as described.

I then changed the repository information and package manager picked up the rc5 upgrade. I have upgraded and verified that the version running is indeed rc5.

The first time I ran rc5 and used the story editor, the same problem occurred. I selected a text frame, ctrl-T, positioned the cursor, pressed backspace, nothing happened, clicked close, the dialog asked if I wanted to discard changes, I said yes, the story editor closed, I unselected and reselected the text frame and as soon as I pressed ctrl-T again, the text frame disappeared; acting upon the earlier backspace keypress.

cgwpublishing

2011-10-18 09:48

reporter   ~0027041

This problem is still ongoing, I have now noticed that it also affects other features, where I cannot enter anything into a dialogue box until I close the dialogue box, then it seems that whatever I typed stays in the keyboard buffer and only comes out when I press a key outside of the dialogue box that I was trying to enter text into.

Story editor is now pretty much unusable, which is annoying. I know that a lot of people prefer to edit text on canvas but I don't, I like the story editor's control, ease of use and speed.

cgwpublishing

2011-10-19 18:54

reporter   ~0027056

This problem gets worse the more I am forced to use the on-canvass editor instead of the story editor.

Here's the latest. I am editing a large block of text on the back of a book cover, and as I type, not all of the letters make it into the text frame, for example "may think that this book can" becomes "may tthn btooan tan ta".

But that's not all, when I press backspace, I don't get a backspace, I get the next character that I had typed before characters stopped displaying. If I press backspace enough times, I get all of the remaining characters out, in no discernible order, and then I eventually start getting backspaces.

cgwpublishing

2011-10-20 18:40

reporter   ~0027072

And is it a keyboard hardware problem?

I thought so at first, when I plugged in another keyboard and it worked... the first 3 times I tried. Then it stopped.

If I unplug the keyboard (USB) and plug it back again, the problem goes away for about 3 editing attempts, then it's back.

I also tried the OnBoard on screen keyboard to rule out a hardware problem. Same thing happens.

I'm at my wits end because my job depends on using Scribus, and right now it is becoming completely unusable, I have to all my text editing somewhere else as all I can do is copy & paste.

cgwpublishing

2011-10-20 19:30

reporter   ~0027074

OK, now this is ridiculous, it's now happening in other dialogue boxes too. I can't even edit colours now. To add a new colour, I have to type the colour's name in a text editor, copy it an paste it into the edit colours dialogue box with a mouse right click.

And Scribus is the only software I am having this problem with.

I am now running 1.4.0 rc6 and I uninstalled, deleted the .scribus folder and reinstalled, no change.

ale

2011-10-21 13:30

manager   ~0027075

hi

as someone already told you in the forums, there is probably a problem related to something else installed on your computer...

it may be related to the locales, qt, the window manager, the settings for qt, or about anything...

since you are using ubuntu you can try this: install "Qt 4 Settings", run it, and choose "Cleanlooks" as GUI style...

good luck!
a.l.e

Issue History

Date Modified Username Field Change
2011-09-13 21:27 cgwpublishing New Issue
2011-09-14 14:23 ale Note Added: 0026869
2011-09-16 13:17 cgwpublishing Note Added: 0026879
2011-09-16 13:18 cgwpublishing Note Edited: 0026879 View Revisions
2011-09-16 13:30 cgwpublishing Note Edited: 0026879 View Revisions
2011-10-18 09:48 cgwpublishing Note Added: 0027041
2011-10-19 18:54 cgwpublishing Note Added: 0027056
2011-10-20 18:40 cgwpublishing Note Added: 0027072
2011-10-20 19:30 cgwpublishing Note Added: 0027074
2011-10-21 13:30 ale Note Added: 0027075
2014-07-11 17:18 FirasH Status new => closed
2014-07-11 17:18 FirasH Resolution open => unable to reproduce
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames