View Issue Details

IDProjectCategoryView StatusLast Update
0010263ScribusUser Interfacepublic2014-08-04 15:54
ReporterJLuc Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSWinOS Version7
Product Version1.4.0svn 
Target VersionFixed in Version1.5.0svn 
Summary0010263: [patch] Better Masterpage Import
DescriptionWhen importing master pages :

- the input areas are very small and can only display a very little part of the file name or of the masterpage name.
> they should be twice bigger at least

- in the "Select master page to import" dropdown select, it would be very handy to have an "import ALL masterpages" option.

- More important : there should be an option to choose the name the imported master page will have in the destination document, and specifically to choose among existing masterpage : this would easyen the upgrade the masterpages in all files of a same project.

TagsNo tags attached.
Patch

Relationships

related to 0012588 closedale Master Page import Improvements 
child of 0003837 acknowledged Metabug: Master pages/Page templates 

Activities

JLuc

2011-09-15 09:17

developer  

JLuc

2011-09-15 09:19

developer   ~0026873

Added screenshot of the dialog showing small areas for file name and masterpage name, showing how the file and masterpage page have to be truncated in these 2 too small display areas.

ale

2011-09-15 13:44

manager   ~0026875

patch attached

ale

2011-09-15 15:24

manager  

wider_masterpagename.patch (457 bytes)
Index: ui/mergedoc.cpp
===================================================================
--- ui/mergedoc.cpp	(revision 16829)
+++ ui/mergedoc.cpp	(working copy)
@@ -62,7 +62,7 @@
 		masterPageNameData = new ScComboBox(this);
 		masterPageNameData->setEnabled(false);
 		importPageLabel->setBuddy( masterPageNameData );
-		fromInfoLayout->addWidget( masterPageNameData, 1, 1 );
+		fromInfoLayout->addWidget( masterPageNameData, 1, 1, 1, 2);
 	}
 	else
 	{

JLuc

2011-09-16 17:36

developer   ~0026882

Thanks ale

As for the other possible improvements, the "import style" is a good example of what could be done for masterpages. Translating 'styles choose' dialog into 'masterpage' would provide :

- the list of all masterpage in the selected doc
- ability to select all or none of them
- ability to select or unselect the masterpages one by one
- option to either rename or overwrite in case of existing masterpage with same name.

cbradney

2011-09-18 21:45

administrator   ~0026887

Thanks :)

JLuc

2011-09-26 13:16

developer   ~0026908

I tried with new 1.4 svn version compiled on ubuntu, and it seems it doesnt show any better.
It is however possible to change the window size, so it is just a matter of launchtime size.

ale

2011-09-28 10:19

manager  

import_masterpage.png (4,411 bytes)
import_masterpage.png (4,411 bytes)

ale

2011-09-28 10:20

manager   ~0026920

Last edited: 2011-09-28 10:20

View 2 revisions

attached what i see with current svn and a the default window size...

... looks correct to me...

or did you want something else?

ale

2011-10-08 16:08

manager   ~0026993

the file name field should grow a little...

JLuc

2011-10-21 21:17

developer   ~0027076

Yes, the name field should be bigger than 3 characters. 20 characters looks like a more suitable length.

+ other bettering about this very same filename input field:
as long as it is only possible to import ONE masterpage, it would be helpful if the dialog would remember the file that was used for the previous master page import and propose it as a default value.

Kunda

2014-08-04 02:07

updater  

Kunda

2014-08-04 02:10

updater   ~0033167

Looks good on 10.8.5 1.5svn r19401
Added screenshot of the true size of the dialog box the comes up.
The name field has ample enough room.
Can any confirm on other platforms/distros
Can we close this?

JLuc

2014-08-04 10:47

developer   ~0033173

Size of file input zone is now ok.

Other possible improvements should be reported elsewhere :

- ability to select or unselect the masterpages one by one, or none or all of them at once

- option to either rename or overwrite existing masterpage with same name.

Issue History

Date Modified Username Field Change
2011-09-14 15:12 JLuc New Issue
2011-09-15 09:17 JLuc File Added: Scribus Import Masterpage.JPG
2011-09-15 09:19 JLuc Note Added: 0026873
2011-09-15 13:44 ale Note Added: 0026875
2011-09-15 13:44 ale Summary Better Masterpage Import => [patch] Better Masterpage Import
2011-09-15 15:24 ale File Added: wider_masterpagename.patch
2011-09-16 17:36 JLuc Note Added: 0026882
2011-09-18 21:45 cbradney Note Added: 0026887
2011-09-18 21:45 cbradney Status new => resolved
2011-09-18 21:45 cbradney Fixed in Version => 1.4.0svn
2011-09-18 21:45 cbradney Resolution open => fixed
2011-09-18 21:45 cbradney Assigned To => cbradney
2011-09-26 13:16 JLuc Note Added: 0026908
2011-09-28 10:19 ale File Added: import_masterpage.png
2011-09-28 10:20 ale Note Added: 0026920
2011-09-28 10:20 ale Note Edited: 0026920 View Revisions
2011-09-28 18:32 cbradney Status resolved => closed
2011-10-08 16:08 ale Note Added: 0026993
2011-10-08 16:08 ale Assigned To cbradney =>
2011-10-08 16:08 ale Status closed => new
2011-10-21 21:17 JLuc Note Added: 0027076
2014-08-04 02:07 Kunda File Added: import-master-page-dialog.png
2014-08-04 02:10 Kunda Note Added: 0033167
2014-08-04 02:10 Kunda Status new => feedback
2014-08-04 10:47 JLuc Note Added: 0033173
2014-08-04 10:47 JLuc Status feedback => new
2014-08-04 10:47 JLuc Status new => resolved
2014-08-04 10:47 JLuc Fixed in Version 1.4.0svn => 1.5.0svn
2014-08-04 10:47 JLuc Assigned To => JLuc
2014-08-04 10:48 JLuc Assigned To JLuc =>
2014-08-04 10:48 JLuc Status resolved => closed
2014-08-04 15:51 Kunda Status closed => feedback
2014-08-04 15:51 Kunda Resolution fixed => reopened
2014-08-04 15:51 Kunda Relationship added child of 0003837
2014-08-04 15:51 Kunda Status feedback => closed
2014-08-04 15:51 Kunda Resolution reopened => fixed
2014-08-04 15:54 Kunda Relationship added related to 0012588