View Issue Details

IDProjectCategoryView StatusLast Update
0010316ScribusUser Interfacepublic2011-10-12 22:24
ReporterJLuc Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
PlatformPCOS7OS Version
Product Version1.4.0svn 
Target VersionFixed in Version 
Summary0010316: Importing an SLA doc with linked text frames
DescriptionI'm working with linked text frames document.
Each page is made of one text frame that is linked to the previous and next one.
There are images spread accross the whole document.

When importing such a document at the end of another one, the pages are created well in place, and the images frames are layed out ok, but things go wrong with linked text frames.
- on each page, 2 text frames are created instead of one, sometime at the same place, sometime at a slightly different place.
- Only ONE of the set of text frames are linked. The other one are not linked.
- Bad luck : the text appears only in one of the 2 first page frames : in the not linked one. So all other pages are empty.

Solution is to :
- unlink first (empty) frame
- link with-text first frame to previously-second linked text frame

It does not seem to be related to the masterpages that are identical and do not feature such a text frame.

Looking at the history window I discover a line : "doc : adding pages" + a lot of lines creating new text frames : all the frames are being created. BUT the frame numbering in the outline window and in the history window show that "doc : adding pages" allready has created the copied frames. That's why frames are there twice.


I tried to reproduce using a simple 3 page SLA document, but the problem didnt arose in the same way : the copied pages featured NON LINKED frames, this is same problem, but there was not a second linked frame on each frame as in my reallife situation.
Steps To ReproduceThis reproduces the last paragraph only :

- Create a (facing pages) doc with 3 pages, each with an empty text frame
- link the 3 text frames
- fill with lorem
- save as foo.sla
- save as bar.sla
- import foo.sla at the end of bar.sla
-> imported frames are not linked

This will show the "copied frames are not linked" problem. However it will not show the "frames are copied twice" problem.
TagsNo tags attached.
Patch

Relationships

duplicate of 0008056 assignedale [WIP PATCH] Import pages with linked text frames breaks the links 

Activities

JLuc

2011-10-12 21:57

developer  

bar.sla (26,779 bytes)

JLuc

2011-10-12 22:11

developer   ~0027012

Note : in the complex "frames are copied twice, once linked, once not, once with text, once without", i notice also that the masterpage elements are not copied on the inserted pages.

jghali

2011-10-12 22:24

administrator   ~0027013

Duplicate of 0008056

Issue History

Date Modified Username Field Change
2011-10-12 21:57 JLuc New Issue
2011-10-12 21:57 JLuc File Added: bar.sla
2011-10-12 22:11 JLuc Note Added: 0027012
2011-10-12 22:24 jghali Note Added: 0027013
2011-10-12 22:24 jghali Relationship added duplicate of 0008056
2011-10-12 22:24 jghali Status new => resolved
2011-10-12 22:24 jghali Resolution open => duplicate
2011-10-12 22:24 jghali Assigned To => jghali
2011-10-12 22:24 jghali Status resolved => closed