View Issue Details

IDProjectCategoryView StatusLast Update
0010407ScribusOS-MacOSXpublic2014-07-07 18:04
Reporterkjnether Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version1.4.0svn 
Target VersionFixed in Version 
Summary0010407: Freezes once document loaded
DescriptionEvery time Scribus starts it would freeze. Going to the mac Activity Monitor would show that the process was not responding. Waited a good 15 minutes for it to respond but nothing. Tried starting from the command line and got this error when it was run:

...
Font /System/Library/Fonts/AppleGothic.ttf(1) is duplicate of /System/Library/Fonts/AppleGothic.ttf(1)
Loading font /System/Library/Fonts/Monaco.dfont (found using fontconfig)
Font /System/Library/Fonts/Monaco.dfont(1) is duplicate of /System/Library/Fonts/Monaco.dfont(1)
Loading font /System/Library/Fonts/?????? ProN W6.otf (found using fontconfig)
Font /System/Library/Fonts/?????? ProN W6.otf is broken, discarding it
cairo-font-face.c:191: failed assertion `CAIRO_REFERENCE_COUNT_HAS_REFERENCE (&font_face->ref_count)'
Scribus Crash
-------------
Scribus crashes due to Signal 0000006
Calling Emergency Save


Let me know if there is anything I can do to help debug this issue. In the mean time I am compiling the svn version on my linux box to see if the error occurs there also. I'll let you know what I come up with. In the mean time does not seem to affect the windows build.

TagsNo tags attached.
Patch

Activities

Kunda

2014-07-01 01:03

updater   ~0032382

Please provide further info. Did this issue persist?

Issue History

Date Modified Username Field Change
2011-11-26 20:14 kjnether New Issue
2014-07-01 01:03 Kunda Note Added: 0032382
2014-07-01 01:03 Kunda Status new => feedback
2014-07-07 18:04 FirasH Status feedback => closed
2014-07-07 18:04 FirasH Resolution open => unable to reproduce
2014-10-08 18:37 Kunda Category Mac OS => OS-MacOSX