View Issue Details

IDProjectCategoryView StatusLast Update
0010461ScribusGeneralpublic2014-06-28 12:32
Reportermelchiaros Assigned To 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionunable to reproduce 
PlatformLinuxOSopenSUSEOS Version12.1
Product Version1.4.0svn 
Target VersionFixed in Version 
Summary0010461: SIGSEV in CanvasMode_NodeEdit::handleNodeEditPress
DescriptionI´am on scribus 1.4.0rc6 on openSUSE12.1 kernel3.1.0 64bit.

I´was using scribus Bezier-Curve abilities with propertiy manipulation.

More exact, I was handeling point properties of the Bezier-Curve, when it crashed.

In moment I can´t say more precise what was happening, because I´am new to scribus, but I work it out a bit and try to reproduce.

I have a long stacktrace here, I attach it.
Steps To Reproduce??? -> I write it in additional comments, when I know it.
Additional Informationgdb hold with injump point::

Program received signal SIGSEGV, Segmentation fault.
CanvasMode_NodeEdit::handleNodeEditPress (this=0x25c7070, m=0x7fffffffcf10) at /usr/src/debug/scribus-1.4.0.rc6/scribus/canvasmode_nodeedit.cpp:784
784 FPoint base = cli.point(cli.size()-2);


The rest is in the attachment
TagsNo tags attached.
Patch

Activities

melchiaros

2011-12-28 16:27

reporter  

Manipulation on BezierCurve points stacktrace (24,940 bytes)
Program received signal SIGSEGV, Segmentation fault.
CanvasMode_NodeEdit::handleNodeEditPress (this=0x25c7070, m=0x7fffffffcf10) at /usr/src/debug/scribus-1.4.0.rc6/scribus/canvasmode_nodeedit.cpp:784
784                                     FPoint base = cli.point(cli.size()-2);
(gdb) thread apply all bt
                                                                                                                                                                                                                                                                               
Thread 7 (Thread 0x7fffe2454700 (LWP 13103)):                                                                                                                                                                                                                                  
#0  0x00007ffff4496423 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87                                                                                                                             
#1  0x00007ffff34faa98 in g_main_context_poll (n_fds=2, fds=0x7fffd4001ad0, timeout=-1, context=0x7fffd4001400, priority=<optimized out>) at gmain.c:3386                                                                                                                      
#2  g_main_context_iterate (context=0x7fffd4001400, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068                                                                                                                                                   
#3  0x00007ffff34faf59 in g_main_context_iteration (context=0x7fffd4001400, may_block=1) at gmain.c:3136                                                                                                                                                                       
#4  0x00007ffff65fe50f in QEventDispatcherGlib::processEvents (this=0x7fffd4002450, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422                                                                                                                             
#5  0x00007ffff65d2a22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149                                                                                                                                                             
#6  0x00007ffff65d2c1f in QEventLoop::exec (this=0x7fffe2453bb0, flags=...) at kernel/qeventloop.cpp:201                                                                                                                                                                       
#7  0x00007ffff64ea5df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498                                                                                                                                                                                       
#8  0x00007ffff65b5aef in QInotifyFileSystemWatcherEngine::run (this=0x2338dc0) at io/qfilesystemwatcher_inotify.cpp:248                                                                                                                                                       
#9  0x00007ffff64ed025 in QThreadPrivate::start (arg=0x2338dc0) at thread/qthread_unix.cpp:331                                                                                                                                                                                 
#10 0x00007ffff41b0f05 in start_thread (arg=0x7fffe2454700) at pthread_create.c:301                                                                                                                                                                                            
#11 0x00007ffff449f53d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115                                                                                                                                                                                            
                                                                                                                                                                                                                                                                               
Thread 2 (Thread 0x7fffe2c55700 (LWP 12607)):                                                                                                                                                                                                                                  
#0  0x00007ffff4498c33 in select () at ../sysdeps/unix/syscall-template.S:82                                                                                                                                                                                                   
#1  0x00007ffff65b54a1 in QProcessManager::run (this=0x7ffff6903f80) at io/qprocess_unix.cpp:245                                                                                                                                                                               
#2  0x00007ffff64ed025 in QThreadPrivate::start (arg=0x7ffff6903f80) at thread/qthread_unix.cpp:331                                                                                                                                                                            
#3  0x00007ffff41b0f05 in start_thread (arg=0x7fffe2c55700) at pthread_create.c:301                                                                                                                                                                                            
#4  0x00007ffff449f53d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115                                                                                                                                                                                            
                                                                                                                                                                                                                                                                               
Thread 1 (Thread 0x7ffff7fb59a0 (LWP 12598)):                                                                                                                                                                                                                                  
#0  CanvasMode_NodeEdit::handleNodeEditPress (this=0x25c7070, m=0x7fffffffcf10) at /usr/src/debug/scribus-1.4.0.rc6/scribus/canvasmode_nodeedit.cpp:784                                                                                                                        
#1  0x0000000000683e90 in CanvasMode_NodeEdit::mousePressEvent (this=0x25c7070, m=0x7fffffffcf10) at /usr/src/debug/scribus-1.4.0.rc6/scribus/canvasmode_nodeedit.cpp:430                                                                                                      
#2  0x0000000000b82a4e in ScribusView::eventFilter (this=0x2574330, obj=0x25766a0, event=0x7fffffffcf10) at /usr/src/debug/scribus-1.4.0.rc6/scribus/scribusview.cpp:4833                                                                                                      
#3  0x00007ffff65d39a8 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x25766a0, event=0x7fffffffcf10) at kernel/qcoreapplication.cpp:902                                                                                           
#4  0x00007ffff7057bff in notify_helper (e=0x7fffffffcf10, receiver=0x25766a0, this=0x1182720) at kernel/qapplication.cpp:4477                                                                                                                                                 
#5  QApplicationPrivate::notify_helper (this=0x1182720, receiver=0x25766a0, e=0x7fffffffcf10) at kernel/qapplication.cpp:4453                                                                                                                                                  
#6  0x00007ffff705d3bb in QApplication::notify (this=<optimized out>, receiver=0x25766a0, e=0x7fffffffcf10) at kernel/qapplication.cpp:4042                                                                                                                                    
#7  0x00007ffff65d381c in QCoreApplication::notifyInternal (this=0x7fffffffdbf0, receiver=0x25766a0, event=0x7fffffffcf10) at kernel/qcoreapplication.cpp:787                                                                                                                  
#8  0x00007ffff7058c02 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215                                                                                                                                       
#9  QApplicationPrivate::sendMouseEvent (receiver=0x25766a0, event=0x7fffffffcf10, alienWidget=0x25766a0, nativeWidget=0x19b5390, buttonDown=0x25766a0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3141                                               
#10 0x00007ffff70d4bc5 in QETWidget::translateMouseEvent (this=0x19b5390, event=<optimized out>) at kernel/qapplication_x11.cpp:4475                                                                                                                                           
#11 0x00007ffff70d3a9a in QApplication::x11ProcessEvent (this=0x7fffffffdbf0, event=0x7fffffffd7d0) at kernel/qapplication_x11.cpp:3601                                                                                                                                        
#12 0x00007ffff70fb312 in x11EventSourceDispatch (s=0x118b560, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146                                                                                                                                           
#13 0x00007ffff34fa58d in g_main_dispatch (context=0x11899a0) at gmain.c:2425                                                                                                                                                                                                  
#14 g_main_context_dispatch (context=0x11899a0) at gmain.c:2995                                                                                                                                                                                                                
#15 0x00007ffff34fad88 in g_main_context_iterate (context=0x11899a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073                                                                                                                                  
#16 0x00007ffff34faf59 in g_main_context_iteration (context=0x11899a0, may_block=1) at gmain.c:3136                                                                                                                                                                            
#17 0x00007ffff65fe50f in QEventDispatcherGlib::processEvents (this=0x1187900, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422                                                                                                                                  
#18 0x00007ffff70faf9e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204                                                                                                                      
#19 0x00007ffff65d2a22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149                                                                                                                                                             
#20 0x00007ffff65d2c1f in QEventLoop::exec (this=0x7fffffffdba0, flags=...) at kernel/qeventloop.cpp:201                                                                                                                                                                       
#21 0x00007ffff65d6de7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064                                                                                                                                                                                        
#22 0x0000000000cfa134 in mainApp (argc=1, argv=<optimized out>) at /usr/src/debug/scribus-1.4.0.rc6/scribus/main_nix.cpp:84                                                                                                                                                   
#23 0x00007ffff43e723d in __libc_start_main (main=0x589d10 <main(int, char**)>, argc=1, ubp_av=0x7fffffffdd28, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffffffdd18) at libc-start.c:226                                            
#24 0x000000000058a481 in _start () at ../sysdeps/x86_64/elf/start.S:113                                                                                                                                                                                                       
(gdb) continue                                                                                                                                                                                                                                                                 
Continuing.                                                                                                                                                                                                                                                                    
Scribus Crash                                                                                                                                                                                                                                                                  
-------------                                                                                                                                                                                                                                                                  
Scribus crashes due to Signal #11                                                                                                                                                                                                                                              
^C                                                                                                                                                                                                                                                                             
Program received signal SIGINT, Interrupt.                                                                                                                                                                                                                                     
0x00007ffff4496423 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87                                                                                                                                 
87        int result = INLINE_SYSCALL (poll, 3, CHECK_N (fds, nfds), nfds, timeout);                                                                                                                                                                                           
(gdb) thread apply all bt                                                                                                                                                                                                                                                      
                                                                                                                                                                                                                                                                               
Thread 7 (Thread 0x7fffe2454700 (LWP 13103)):                                                                                                                                                                                                                                  
#0  0x00007ffff4496423 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87                                                                                                                             
#1  0x00007ffff34faa98 in g_main_context_poll (n_fds=2, fds=0x7fffd4001ad0, timeout=-1, context=0x7fffd4001400, priority=<optimized out>) at gmain.c:3386                                                                                                                      
#2  g_main_context_iterate (context=0x7fffd4001400, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068                                                                                                                                                   
#3  0x00007ffff34faf59 in g_main_context_iteration (context=0x7fffd4001400, may_block=1) at gmain.c:3136                                                                                                                                                                       
#4  0x00007ffff65fe50f in QEventDispatcherGlib::processEvents (this=0x7fffd4002450, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#5  0x00007ffff65d2a22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007ffff65d2c1f in QEventLoop::exec (this=0x7fffe2453bb0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007ffff64ea5df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007ffff65b5aef in QInotifyFileSystemWatcherEngine::run (this=0x2338dc0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007ffff64ed025 in QThreadPrivate::start (arg=0x2338dc0) at thread/qthread_unix.cpp:331
#10 0x00007ffff41b0f05 in start_thread (arg=0x7fffe2454700) at pthread_create.c:301
#11 0x00007ffff449f53d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fffe2c55700 (LWP 12607)):
#0  0x00007ffff4498c33 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007ffff65b54a1 in QProcessManager::run (this=0x7ffff6903f80) at io/qprocess_unix.cpp:245
#2  0x00007ffff64ed025 in QThreadPrivate::start (arg=0x7ffff6903f80) at thread/qthread_unix.cpp:331
#3  0x00007ffff41b0f05 in start_thread (arg=0x7fffe2c55700) at pthread_create.c:301
#4  0x00007ffff449f53d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7ffff7fb59a0 (LWP 12598)):
#0  0x00007ffff4496423 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ffff34faa98 in g_main_context_poll (n_fds=7, fds=0x2b76b80, timeout=9999, context=0x11899a0, priority=<optimized out>) at gmain.c:3386
#2  g_main_context_iterate (context=0x11899a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x00007ffff34faf59 in g_main_context_iteration (context=0x11899a0, may_block=1) at gmain.c:3136
#4  0x00007ffff65fe50f in QEventDispatcherGlib::processEvents (this=0x1187900, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#5  0x00007ffff70faf9e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#6  0x00007ffff65d2a22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007ffff65d2c1f in QEventLoop::exec (this=0x7fffffffbd50, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007ffff7509f86 in QDialog::exec (this=0x7fffffffbdc0) at dialogs/qdialog.cpp:552
#9  0x00007ffff752b5a2 in QMessageBoxPrivate::showOldMessageBox (parent=<optimized out>, icon=<optimized out>, title=<optimized out>, text=<optimized out>, button0Text=<optimized out>, button1Text=<optimized out>, button2Text=..., defaultButtonNumber=0, 
    escapeButtonNumber=-1) at dialogs/qmessagebox.cpp:1948
#10 0x00007ffff752b6be in QMessageBox::critical (parent=<optimized out>, title=<optimized out>, text=<optimized out>, button0Text=<optimized out>, button1Text=<optimized out>, button2Text=<optimized out>, defaultButtonNumber=0, escapeButtonNumber=-1)
    at dialogs/qmessagebox.cpp:2363
#11 0x0000000000cf9f28 in defaultCrashHandler (sig=<optimized out>) at /usr/src/debug/scribus-1.4.0.rc6/scribus/main_nix.cpp:135
#12 <signal handler called>
#13 FPoint (p=..., this=0x7fffffffc6e0) at /usr/src/debug/scribus-1.4.0.rc6/scribus/fpoint.h:40
#14 CanvasMode_NodeEdit::handleNodeEditPress (this=0x25c7070, m=0x7fffffffcf10) at /usr/src/debug/scribus-1.4.0.rc6/scribus/canvasmode_nodeedit.cpp:784
#15 0x0000000000683e90 in CanvasMode_NodeEdit::mousePressEvent (this=0x25c7070, m=0x7fffffffcf10) at /usr/src/debug/scribus-1.4.0.rc6/scribus/canvasmode_nodeedit.cpp:430
#16 0x0000000000b82a4e in ScribusView::eventFilter (this=0x2574330, obj=0x25766a0, event=0x7fffffffcf10) at /usr/src/debug/scribus-1.4.0.rc6/scribus/scribusview.cpp:4833
#17 0x00007ffff65d39a8 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x25766a0, event=0x7fffffffcf10) at kernel/qcoreapplication.cpp:902
#18 0x00007ffff7057bff in notify_helper (e=0x7fffffffcf10, receiver=0x25766a0, this=0x1182720) at kernel/qapplication.cpp:4477
#19 QApplicationPrivate::notify_helper (this=0x1182720, receiver=0x25766a0, e=0x7fffffffcf10) at kernel/qapplication.cpp:4453
#20 0x00007ffff705d3bb in QApplication::notify (this=<optimized out>, receiver=0x25766a0, e=0x7fffffffcf10) at kernel/qapplication.cpp:4042
#21 0x00007ffff65d381c in QCoreApplication::notifyInternal (this=0x7fffffffdbf0, receiver=0x25766a0, event=0x7fffffffcf10) at kernel/qcoreapplication.cpp:787
#22 0x00007ffff7058c02 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#23 QApplicationPrivate::sendMouseEvent (receiver=0x25766a0, event=0x7fffffffcf10, alienWidget=0x25766a0, nativeWidget=0x19b5390, buttonDown=0x25766a0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3141
#24 0x00007ffff70d4bc5 in QETWidget::translateMouseEvent (this=0x19b5390, event=<optimized out>) at kernel/qapplication_x11.cpp:4475
#25 0x00007ffff70d3a9a in QApplication::x11ProcessEvent (this=0x7fffffffdbf0, event=0x7fffffffd7d0) at kernel/qapplication_x11.cpp:3601
#26 0x00007ffff70fb312 in x11EventSourceDispatch (s=0x118b560, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#27 0x00007ffff34fa58d in g_main_dispatch (context=0x11899a0) at gmain.c:2425
#28 g_main_context_dispatch (context=0x11899a0) at gmain.c:2995
#29 0x00007ffff34fad88 in g_main_context_iterate (context=0x11899a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#30 0x00007ffff34faf59 in g_main_context_iteration (context=0x11899a0, may_block=1) at gmain.c:3136
#31 0x00007ffff65fe50f in QEventDispatcherGlib::processEvents (this=0x1187900, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007ffff70faf9e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007ffff65d2a22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007ffff65d2c1f in QEventLoop::exec (this=0x7fffffffdba0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007ffff65d6de7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x0000000000cfa134 in mainApp (argc=1, argv=<optimized out>) at /usr/src/debug/scribus-1.4.0.rc6/scribus/main_nix.cpp:84
#37 0x00007ffff43e723d in __libc_start_main (main=0x589d10 <main(int, char**)>, argc=1, ubp_av=0x7fffffffdd28, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffffffdd18) at libc-start.c:226
#38 0x000000000058a481 in _start () at ../sysdeps/x86_64/elf/start.S:113
(gdb) continue
Continuing.
Calling Emergency Save

Program received signal SIGSEGV, Segmentation fault.
ScribusMainWindow::emergencySave (this=0x0) at /usr/src/debug/scribus-1.4.0.rc6/scribus/scribus.cpp:9199
9199            QWidgetList windows = wsp->windowList();
gdb) continue
Continuing.
[Thread 0x7fffe2454700 (LWP 13103) exited]
[Thread 0x7fffe2c55700 (LWP 12607) exited]

Program terminated with signal SIGSEGV, Segmentation fault.
The program no longer exists.
(gdb) 

melchiaros

2011-12-28 16:49

reporter   ~0027404

Have tried arround. Can´t not say exactly.

It was on using "open BezierCurve" and "Closing BezierCurve" in the properties dialog.

Thats all.

cbradney

2012-01-04 19:39

administrator   ~0027454

Would you have a document to share that we can reproduce with?

Issue History

Date Modified Username Field Change
2011-12-28 16:27 melchiaros New Issue
2011-12-28 16:27 melchiaros File Added: Manipulation on BezierCurve points stacktrace
2011-12-28 16:49 melchiaros Note Added: 0027404
2012-01-04 19:39 cbradney Note Added: 0027454
2014-06-28 12:32 FirasH Status new => closed
2014-06-28 12:32 FirasH Resolution open => unable to reproduce