View Issue Details

IDProjectCategoryView StatusLast Update
0011240ScribusStory Editor / Text Framespublic2015-03-10 06:25
Reporterjeffmcneill Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformintel i5OSOSXOS VersionMountain Lion
Product Version1.5.0svn 
Target VersionFixed in Version1.5.0svn 
Summary0011240: With or without crash; linked textframes unlinked
DescriptionScribus crashes with error 11 (for whatever reason), when opening the last project, the textframes are no longer linked. This is on a project that had an automatically generated textframes on all pages and automatically linked.

After the crash, have to manually relink all frames.

This happens every time after crashing.
Steps To ReproduceCreate Scribus document with automatically linked textframes. Enter text.

Wait for Scribus to crash.

Open back up probject and linked textframes are unlinked and text is only visible on first page.
TagsNo tags attached.
Patch

Relationships

duplicate of 0012940 closedcbradney qHash() returns uint and Scribus stores item IDs as ints. 
related to 0008056 assignedale [WIP PATCH] Import pages with linked text frames breaks the links 

Activities

jeffmcneill

2012-12-12 00:37

reporter   ~0029359

Note: I get the same problem when I have a document and Save As a new document name. When I close that document and then open up either the original or the newly named version, the text is no longer flowing across all the textframes. I have to relink across all pages. This is a small problem with a 36 page document I am working on. My next project is 180 pages and this will be five times more painful.

christoph_s

2012-12-13 07:38

administrator   ~0029361

I can't reproduce the issue on Linux, so it seems to be a OS X-related problem.

Also, it would be interesting to know why Scribus crashes in the first place. Using bt or the Mac OS X equivalent might be helpful.

jeffmcneill

2013-03-29 07:26

reporter   ~0030017

I would like to provide crash information, but do not know how to do this. I am running this on mac osx. Please advise.

Kunda

2014-08-06 20:35

updater   ~0033194

Jeffmcneill, I'm on MacOSX, can you upload an example .sla file for me to test this?

Kunda

2014-08-19 08:26

updater   ~0033279

I've encountered this (on 10.8.5 1.5.0svn r19425) but without a crash. Just saving and opening file found that linked text frames were broken and only first text frame showing text. Trying to reproduce.

Kunda

2014-08-19 10:06

updater   ~0033282

Confirmed on 10.8.5 1.5.0svn r19425
Uploaded a file with 3 linked text boxes.
Added 'Sample Text' and then I crashed Scribus purposely using 0012538

Kunda

2014-08-19 10:12

updater  

broken-text-links.sla (17,359 bytes)

Kunda

2014-08-19 18:36

updater   ~0033289

Bah... suddenly I can't recreate this. Any help to reproduce would be helpful

Kunda

2014-08-20 07:47

updater   ~0033295

This issue does not require a crash to unlink the text boxes. One can simply close Scribus and then reopen it and the link chain will be broken.

Kunda

2014-08-21 11:50

updater   ~0033311

Added loose association to 0008056

Kunda

2014-08-25 04:23

updater   ~0033342

jeffmcneill, please upload an .sla to demonstrate this issue. Thanks

cbradney

2014-10-05 21:10

administrator   ~0033900

I see no issue with the currently uploaded file.

Kunda

2014-10-05 21:53

updater   ~0033903

I know this issue happened since i last tested it in Aug. even if the .sla file doesn't reflect that. I will attempt to test and upload an .sla that demonstrates this in the next few days. In the meantime is there anyone that can recreate and demonstrate this bug?

Kunda

2014-10-08 17:59

updater   ~0033932

Uploaded broken-links-example.sla that shows the problem.

Steps to recreate:
1) Open broken-links-example.sla
2) Notice that page 1 has text but none of the other pages do. They other pages have text boxes in them.
3) Start to link that text box from page 1 to page 2.
4) Link page 2 to page 3
5) repeat step 4 until there are no more pages
6) save the .sla and close the .sla project
7) reopen the saved .sla and observe the links do not persist

Kunda

2014-10-08 17:59

updater  

broken-links-example.sla (51,942 bytes)

Kunda

2014-10-08 19:43

updater   ~0033940

So far Craig, Jean and FirasH cannot reproduce.

JLuc

2014-10-12 07:50

developer   ~0033987

Last edited: 2014-10-13 15:09

View 2 revisions

I use a lot linked text frames and i sometime have crashes
but so far i _haven't_ had a crash unlink frames in previously saved SLA

Kunda

2014-10-13 15:11

updater   ~0034000

Unblocking and de-assigning target version. I will keep this assigned to me just in case this bug rears it's ugly head sometime in the future. On that day I there will be vindication

Issue History

Date Modified Username Field Change
2012-12-07 02:31 jeffmcneill New Issue
2012-12-12 00:37 jeffmcneill Note Added: 0029359
2012-12-13 07:38 christoph_s Note Added: 0029361
2013-03-29 07:26 jeffmcneill Note Added: 0030017
2014-08-06 20:35 Kunda Note Added: 0033194
2014-08-19 08:26 Kunda Note Added: 0033279
2014-08-19 10:00 Kunda File Added: broken-text-links.sla
2014-08-19 10:06 Kunda Note Added: 0033282
2014-08-19 10:06 Kunda Status new => confirmed
2014-08-19 10:06 Kunda Target Version => 1.5.0
2014-08-19 10:12 Kunda File Deleted: broken-text-links.sla
2014-08-19 10:12 Kunda File Added: broken-text-links.sla
2014-08-19 18:36 Kunda Note Added: 0033289
2014-08-20 07:47 Kunda Note Added: 0033295
2014-08-21 11:50 Kunda Relationship added related to 0008056
2014-08-21 11:50 Kunda Note Added: 0033311
2014-08-25 04:23 Kunda Note Added: 0033342
2014-09-11 02:34 Kunda Severity major => block
2014-10-05 21:10 cbradney Note Added: 0033900
2014-10-05 21:53 Kunda Note Added: 0033903
2014-10-05 22:41 Kunda Assigned To => Kunda
2014-10-05 22:41 Kunda Status confirmed => assigned
2014-10-08 17:59 Kunda Note Added: 0033932
2014-10-08 17:59 Kunda File Added: broken-links-example.sla
2014-10-08 18:01 Kunda Sticky Issue No => Yes
2014-10-08 19:43 Kunda Note Added: 0033940
2014-10-08 19:43 Kunda Summary After crash, linked textframes unlinked => [PLEASE TEST] After crash, linked textframes unlinked
2014-10-09 02:18 Kunda Sticky Issue Yes => No
2014-10-12 07:50 JLuc Note Added: 0033987
2014-10-13 15:09 Kunda Note Edited: 0033987 View Revisions
2014-10-13 15:11 Kunda Note Added: 0034000
2014-10-13 15:11 Kunda Severity block => minor
2014-10-13 15:11 Kunda Target Version 1.5.0 =>
2014-10-13 15:12 Kunda Summary [PLEASE TEST] After crash, linked textframes unlinked => After crash, linked textframes unlinked
2014-10-13 15:47 Kunda Summary After crash, linked textframes unlinked => With or without crash; linked textframes unlinked
2015-03-05 20:41 cbradney Relationship added duplicate of 0012940
2015-03-05 20:41 cbradney Status assigned => resolved
2015-03-05 20:41 cbradney Fixed in Version => 1.5.0svn
2015-03-05 20:41 cbradney Resolution open => duplicate
2015-03-05 20:41 cbradney Assigned To Kunda => cbradney
2015-03-10 06:25 cbradney Status resolved => closed
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames