View Issue Details

IDProjectCategoryView StatusLast Update
0011509ScribusPDFpublic2013-04-24 20:38
ReporterAstroman Pete Assigned Tojghali  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionno change required 
PlatformAnyOSAnyOS VersionAny
Product Version1.4.3.svn 
Target VersionFixed in Version 
Summary0011509: (Wishlist) Cache Image Frame PDF Previews to Speed Opening Documents
Description(This is a wishlist item.)

We're using Scribus in an architectural and engineering firm to tile PDFs published from our CAD system onto sheets with title blocks, notes and referencing. With a little Python, this works very well. This results in Scribus documents with dozens of image frames populated by PDFs, and they are slow to open because Scribus needs to rasterize each frame with Ghostscript to show the previews.

This start-up delay could be eliminated if Scribus cached these previews to disk. The previews could be updated by comparing the timestamp of the preview to the source PDF.

I'd imagine this should be optional, and probably turned-off by default and toggled in the Preferences dialog. It would speed our use of Scribus greatly, though. It would also go a long way toward my co-workers perceiving Scribus as a nimble, speedy program.

I believe the preview step happens in the "scimgdataloader.cpp" file.
TagsNo tags attached.
Patch

Activities

jghali

2013-04-24 20:38

administrator   ~0030112

Thanks, this feature is in fact already implemented in our current 1.5.0svn development version. We hope to release it during the second half of the year.

Issue History

Date Modified Username Field Change
2013-04-24 17:47 Astroman Pete New Issue
2013-04-24 20:38 jghali Note Added: 0030112
2013-04-24 20:38 jghali Status new => resolved
2013-04-24 20:38 jghali Resolution open => no change required
2013-04-24 20:38 jghali Assigned To => jghali
2013-04-24 20:38 jghali Status resolved => closed