View Issue Details

IDProjectCategoryView StatusLast Update
0011558ScribusGraphics / Image Framespublic2019-11-24 10:35
ReporterJLuc Assigned Toale  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.5.0svn 
Target VersionFixed in Version1.5.6.svn 
Summary0011558: 3 Efficiency Features to improve Image Manager
DescriptionWhen opening a file with lots of moved images (= with broken links), one has to attribute again each frame to its original image.
For example, this happen when opening an IDML file : all images are in a "Links" folder.

The image manager allows to do this BUT when there is only one answer to the search, it doesnt select this image but ask.

This feel painfull in the described case.
It could be much improved with following features :

- when there is only one search result image, allways pre-select it since there is no other choice (and enable the user to then click the OK button or not if not wished). It will avoid one totally useless click each time.

- propose the option to automatically "link frame with found image when there is only one". That will help in many cases.

- propose the option to automatically "link all unlinked frames in document, with found images in same folder". It will provide the user with the nice feeling that scribus understands the job being done and is very helping.
TagsNo tags attached.
PatchNo

Relationships

has duplicate 0011776 closedale [PATCH]: Missing linked ressources improvement 

Activities

JLuc

2013-05-31 10:21

developer   ~0030205

Last edited: 2013-05-31 16:40

View 5 revisions

Now, it requires 5 clicks on 3 different dialogs or windows for *each* image to be relinked to its source.
The 3 different dialogs are :
1) window manager (click 'search')
2) search dialog (click 'Begin search')
3) Result dialog (click to select unique image in dropdown list + click 'Select' button)

The search dialog would include the new
"Link frame with found image when there is only one result"
option as a checkbox.

As for the "Link other unlinked frames to other unique images found" option, it could also appear on this search dialog.
This feature could also (and maybe better) be called through a new "reLink" button on the image manager main window, on the left side of the bottom bar with the "Close" on the right.

As for the first feature it does not require any new interface element.
When there is only one search result image, it should simply be automatically pre-selected since there is no other alternative file.

JLuc

2013-10-10 20:52

developer   ~0030708

See common ideas and more in 0011776: Missing linked ressources improvement

ale

2019-11-24 10:35

manager   ~0047127

fixed through 0011776

Issue History

Date Modified Username Field Change
2013-05-31 08:29 JLuc New Issue
2013-05-31 10:21 JLuc Note Added: 0030205
2013-05-31 10:22 JLuc Note Edited: 0030205 View Revisions
2013-05-31 10:23 JLuc Note Edited: 0030205 View Revisions
2013-05-31 10:25 JLuc Note Edited: 0030205 View Revisions
2013-05-31 16:40 JLuc Note Edited: 0030205 View Revisions
2013-10-10 20:52 JLuc Note Added: 0030708
2013-10-11 07:27 pygmee Relationship added has duplicate 0011776
2015-09-17 20:10 Kunda Category Graphics / Image Frames => Graphics/Img Frames
2015-09-17 20:11 Kunda Category Graphics/Img Frames => Graphics / Image Frames
2019-10-24 14:55 JLuc Description Updated View Revisions
2019-10-24 14:55 JLuc Patch => No
2019-11-24 10:35 ale Assigned To => ale
2019-11-24 10:35 ale Status new => closed
2019-11-24 10:35 ale Resolution open => fixed
2019-11-24 10:35 ale Fixed in Version => 1.5.6.svn
2019-11-24 10:35 ale Note Added: 0047127