View Issue Details

IDProjectCategoryView StatusLast Update
0011731Scribus-public2014-07-07 18:52
Reportertoph Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformLinuxOSUbuntuOS Version13.04
Product Version1.5.0svn 
Target VersionFixed in Version 
Summary0011731: Repeatedly pressing arrow key will cause Scribus to stop accepting keyboard input
DescriptionI duplicated an object using copy/paste and tried to move it straight down on the page with the down arrow key. After a number of fast repeated keypresses. Scribus completely stopped accepting any keyboard input. In fact, any further keypress was interpreted as another down arrow key pressed.

The only way to stop this behavior was to restart Scribus.

The mouse is still working fine in this case, though.
Steps To ReproduceMove an object by repeatedly pressing down arrow (or any arrow key, for that matter) in fast sequence.
TagsNo tags attached.
Patch

Activities

jghali

2013-09-06 17:55

administrator   ~0030568

Unable to reproduce on Windows

toph

2013-09-06 18:08

reporter   ~0030569

Of course this might be a bug with Ububtu's (X's?) keyboard handling, but then again Scribus is the only program that behaves like this.

FirasH

2013-10-25 14:30

developer   ~0030783

I've tried to reproduce the bug on openSUSE 12.3 (KDE 4.10.5) pressing repeatedly up, down, left and right arrow keys for 3 minutes. Even with 6 selected items Scribus has no problems.

Kunda

2014-06-30 16:35

updater   ~0032377

Doesn't seem reproducible. Needs feedback from (toph) reporter. toph, please recheck latest version of SVN (currently at r19300) to see if reproducible and report back. If not we'll consider this issue closed.

Issue History

Date Modified Username Field Change
2013-09-06 16:37 toph New Issue
2013-09-06 17:55 jghali Note Added: 0030568
2013-09-06 18:08 toph Note Added: 0030569
2013-10-25 14:30 FirasH Note Added: 0030783
2014-06-30 16:35 Kunda Note Added: 0032377
2014-06-30 16:35 Kunda Status new => feedback
2014-07-07 18:52 FirasH Status feedback => closed
2014-07-07 18:52 FirasH Resolution open => unable to reproduce