View Issue Details

IDProjectCategoryView StatusLast Update
0012055ScribusTranslationpublic2017-06-23 10:06
ReporterJLuc Assigned Togpittman  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.5.0svn 
Target Version1.5.4Fixed in Version1.5.4.svn 
Summary0012055: "Back to previous version" label should rather be "Back to saved version" or "Restore from saved version"
DescriptionIn french the nowaday label is "Revenir à la version précédente".
"version précédente" is quite ambiguous.
What previous version ?
Is it about undoing ?
"Revenir à la version sauvegardée" would be explicit and more clear as what version is it.
Tags#easyhack, #pending, l10n
Patch

Activities

FirasH

2014-02-09 12:54

developer   ~0031293

Hello!
I have a suggestion for this issue.
In LibreOffice under File there are 2 options: "Reload" and "Versions"
Pressing "Reload" the document is restored to the latest saved version and from "Versions" you can save/compare/open/delete previous versions of the same file (everything saved in the same .odt file). It's a clever solution we could take as example, but it might be quite difficult to implement this kind of feature.

JLuc

2014-04-27 09:40

developer   ~0031825

Last edited: 2014-07-25 18:48

View 7 revisions

In inkscape in french its "Recharger"

BESIDE, The dialog that pops up when choosing this option says :
"Les changements dans votre document n'ont pas été enregistrés et vous souhaitez revenir à la version enregistrée.
Souhaitez-vous continuer ?"

"Souhaitez vous continuer" n'est pas très clair, puisque l'action en question consiste justement à arrêter de continuer le travail pour revenir à une version précédente.
(EN : its not clear because "continue" means here "go on with action", that is "stop work and restore", which is the contrary of "continue the editing". Proposing to "continue to stop" can be felt as ambiguous and should be avoided)

It would be better to change the text to :

"Les changements dans votre document n'ont pas été enregistrés. En revenant à la version enregistrée, vous allez donc perdre vos modifications récentes.
Souhaitez-vous vraiment revenir à la version enregistrée ?"
Avec un tel libellé, il n'y a pas d'ambiguité.

EN. Change text to something like : "Some changes have not been recorded. Restoring recorded version will discard all recent edits. Do you really want to restore recorded version ?"
Such a text is not paradoxal and not ambiguous.

Kunda

2014-09-02 13:14

manager   ~0033458

Thread discussion on ML:
http://lists.scribus.net/pipermail/scribus-dev/2014-September/thread.html

cbradney

2014-09-02 20:20

administrator   ~0033468

This would seem to be a translation issue only. The code is:
(*scrActions)["fileRevert"]->setTexts( tr("Re&vert to Saved"));

Revert to Saved seems fine to me.

Kunda

2014-09-02 20:44

manager   ~0033469

+1

JLuc

2014-09-04 11:05

developer   ~0033490

Last edited: 2016-12-07 22:50

View 2 revisions

"Revert to saved" is very fine.
In french, it would be "Revenir à la sauvegarde" or "Revenir à la version sauvegardée".

Note that there is also a usability issue with the confirm dialog that pops afterward choosing that action : its text is not clear because "continue" means here "go on with action", that is "stop work and restore", which is the contrary of "continue the editing". Proposing to "continue to stop" is ambiguous and should be avoided. A better text would be "Some changes have not been recorded. Reverting to the saved version will discard all recent edits. Do you really want to restore recorded version ?". This new text is not paradoxal and not ambiguous.

Kunda

2016-12-07 17:29

manager   ~0042773

@christoph_s do you mind weighing in on this? specifically 0012055:0033490 ?

Kunda

2016-12-13 11:44

manager   ~0042951

@jluc where is this in the code ? I searched for "Back to previous version" and other variations in order to make a patch and haven't located the string.

Also what you wrote in 0012055:0033490
> Note that there is also a usability issue with the confirm dialog that pops afterward choosing that action : its text is not clear because "continue" means here "go on with action", that is "stop work and restore", which is the contrary of "continue the editing". Proposing to "continue to stop" is ambiguous and should be avoided. A better text would be "Some changes have not been recorded. Reverting to the saved version will discard all recent edits. Do you really want to restore recorded version ?". This new text is not paradoxal and not ambiguous.

We should make a patch for that as well.

JLuc

2016-12-13 12:57

updater   ~0042952

"Back to previous version" is my english translation of the ambiguous french label "Revenir à la version précédente".

As stated formerly, in english, it is not ambiguous and it is "Revert to Saved".

English version is ok.
French version should be corrected.

Kunda

2016-12-13 13:05

manager   ~0042953

@jghali punting this to you since you are french language coordinator.

JLuc

2017-05-26 14:19

updater   ~0043944

fixed with http://scribus.net/websvn/listing.php?repname=Scribus&sc=1&rev=22047

FirasH

2017-06-23 10:06

developer   ~0044078

Thanks!
Fixed in 1.5.4.svn (22047).

Issue History

Date Modified Username Field Change
2014-02-08 21:58 JLuc New Issue
2014-02-09 12:54 FirasH Note Added: 0031293
2014-04-27 09:40 JLuc Note Added: 0031825
2014-04-27 09:40 JLuc Note Edited: 0031825 View Revisions
2014-04-27 09:41 JLuc Note Edited: 0031825 View Revisions
2014-04-27 09:42 JLuc Note Edited: 0031825 View Revisions
2014-04-27 11:02 JLuc Note Edited: 0031825 View Revisions
2014-04-27 11:03 JLuc Note Edited: 0031825 View Revisions
2014-05-21 19:39 cbradney Assigned To => jghali
2014-05-21 19:39 cbradney Status new => assigned
2014-07-25 02:43 Kunda Category User Interface => Translation
2014-07-25 02:43 Kunda Target Version => 1.5.1
2014-07-25 18:48 JLuc Note Edited: 0031825 View Revisions
2014-08-31 14:30 Kunda Tag Attached: easyhack
2014-09-02 13:14 Kunda Note Added: 0033458
2014-09-02 20:20 cbradney Note Added: 0033468
2014-09-02 20:44 Kunda Note Added: 0033469
2014-09-04 11:05 JLuc Note Added: 0033490
2014-10-15 17:07 Kunda Tag Renamed easyhack => #easyhack
2016-01-23 17:16 cbradney Target Version 1.5.1 => 1.5.3
2016-12-07 17:29 Kunda Note Added: 0042773
2016-12-07 22:50 JLuc Note Edited: 0033490 View Revisions
2016-12-08 22:04 Kunda Target Version 1.5.3 => 1.5.4
2016-12-13 00:22 Kunda Tag Attached: #pending
2016-12-13 00:22 Kunda Tag Attached: l10n
2016-12-13 11:32 Kunda Assigned To jghali => Kunda
2016-12-13 11:44 Kunda Note Added: 0042951
2016-12-13 12:57 JLuc Note Added: 0042952
2016-12-13 13:04 Kunda Assigned To Kunda => jghali
2016-12-13 13:05 Kunda Note Added: 0042953
2017-05-26 14:17 jghali Assigned To jghali => gpittman
2017-05-26 14:17 jghali Status assigned => resolved
2017-05-26 14:17 jghali Resolution open => fixed
2017-05-26 14:17 jghali Fixed in Version => 1.5.4.svn
2017-05-26 14:19 JLuc Note Added: 0043944
2017-06-23 10:06 FirasH Status resolved => closed
2017-06-23 10:06 FirasH Note Added: 0044078